Jump to content

ATI Mobility Radeon X2300 now WORKS CI/QE !


  • Please log in to reply
247 replies to this topic

#141
johannes.999

johannes.999

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
so any chance this could be working for the mobility 2400 ?
would be sooooooo happy if someone posted a solution for this card:)

#142
axiomriddler

axiomriddler

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
i use acer 4920g. anybody knows how 2 make mobility hd2400xt works well?

#143
BlackShady

BlackShady

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Hempstead, NY
I don't if many people noticed but there are several versions of the Radeon Mobility X2300, i think after AMD bought out ATI which is pretty recent, they updated the X2300 and renamed it X2300 HD and made it support DX10. Personally i Have a Gateway C-142XL with the X2300 HD, a lot of people have the following chip

M64 : Mobility Radeon X2300
DEV ID : 718a

i have

M71 : Mobility HD 2300
DEV ID : 7211

Windows picks it up as the Mobility HD 2300 but I think its the same thing
some people with the DEV ID:7210 were lucky and have QE/CI support being that their device id is listed in the ATIRadeonX1000.kext, so i tried to modify the kext to pick up my card but i get a kernel panic at bootup. Maybe we should wait and see if Apple updates the drivers to support those new chipsets from AMD which I doubt but we'll see.

ps: I attached my GPU-Z screenshot btw as reference

Attached Files



#144
starmie

starmie

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

The 10.5.5 Qe&CI working driver for device id 718A:

Can this driver solve the mouse tearing problem?

#145
qhero

qhero

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
my laptop is Sony vgn-cr1 . i can get CI/QE and 1280X800 under leopard. but i can't use X11. so i change my OS to Tiger. and in Tiger i can't get CI/QE but i can get 1280X800 by edit com.apple.Boot.plist. and i can see DVD and MOV . my X11 also work well. but only CI/QE don't work.

#146
GTOnizuka

GTOnizuka

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
Try installing XQuartz on latest version of Leopard :)

#147
ran000

ran000

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

The 10.5.5 Qe&CI working driver for device id 718A:


I have upgraded to 10.5.6 and subj could not work with Qe&CI. Please, could you look at or give any idea how to get it working!!!
Thank in advance.

#148
Rygu

Rygu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

The 10.5.5 Qe&CI working driver for device id 718A:


Works on Kalyway 10.5.2 on Sony VAIO CR31S/W with an ATI Radeon Mobility X2300. Visual artifacts appear though. :(

EDIT: Shoops! I get MAJOR visual artifacts (scrambled framebuffer) at login window and a black-out the second I login with this kext. ;)

#149
pere

pere

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 726 posts
.

#150
fred9113

fred9113

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Beijing China

The 10.5.6 ATIRadeonX1000.kext, Qe and CI working for ATI X2300 ID: 718A

Guys, tearing will always appear, there is a solution on the first post to this, but its a minor issue...
Resolution has to be changed on com.apple.boot.plist

Please, use each kext on corresponding Leopard version, a 10.5.5 kext on an 10.5.2 system will cause KP.


Thanks, I'll try it ,and post my result.

#151
blackmambo787

blackmambo787

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Hi Pere,

I've installed your kext for ati x2300 on 10.5.5 with kexthelperb7, but when i restarted with -v nothing is changed.I have still QE/CI not supported.
I have an Asus f3jr in which i have installed iatkos 2 and after i updated to 10.5.5, can you help me please?


Thank you

Hi Pere,

I've installed your kext for ati x2300 on 10.5.5 with kexthelperb7, but when i restarted with -v nothing is changed.I have still QE/CI not supported.
I have an Asus f3jr in which i have installed iatkos 2 and after i updated to 10.5.5, can you help me please?


Thank you

#152
Rygu

Rygu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hey I'm on 10.5.5 (updated from combo update) and using pere's 10.5.5, the loginwindow.app fails to render. I can hear it being active though. Anyone know why this happens?

EDIT: Had to reinstall again, but now it's working. Pere's 10.5.5 + the ATIRadeonX1000 extensions work 100%! CI/QE enabled.

#153
JustasT

JustasT

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hy, i'm using ASUS F5NV with ATI Radeon X2300 0x718a. installed iPC leopard 10.5.6, but i can't set my video card to work on QE/CI support. used latest provided kext, still no change. muose started teardroping but no support. how can i solve this?

#154
nfshp253

nfshp253

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
Hello, I have iDeneb 10.5.5 on my Asus A8Jr. It has the Mobility Radeon X2300 with the Device ID 718A. I've installed Pere's provided 10.5.5 kext but no difference. I have already inserted the resolution command thing into com.apple.Boot.plist but resolution is still at 1024x768. Can anyone help please? And the mouse artifacts are terrible. Tried MouseLocator but makes no difference!

#155
dragon_gxy

dragon_gxy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
any one can get 1280x800 on ASUS?I add those lines in com.apple.boot.plist,nothing happens.

#156
fabioo

fabioo

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Hello, I have iDeneb 10.5.5 on my Asus A8Jr. It has the Mobility Radeon X2300 with the Device ID 718A. I've installed Pere's provided 10.5.5 kext but no difference. I have already inserted the resolution command thing into com.apple.Boot.plist but resolution is still at 1024x768. Can anyone help please? And the mouse artifacts are terrible. Tried MouseLocator but makes no difference!


Same here. No way to change resolution. The 1280x1024 works only in safe mode. :)

#157
Harry84

Harry84

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hello!

I have ATI mobility Radeon X1100 and LEO 10.5.2
Can my card works with QE/CI?

What kexts I need to set?

#158
vaiobookpro

vaiobookpro

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

The 10.5.6 ATIRadeonX1000.kext, Qe and CI working for ATI X2300 ID: 718A

Guys, tearing will always appear, there is a solution on the first post to this, but its a minor issue...
Resolution has to be changed on com.apple.boot.plist

Please, use each kext on corresponding Leopard version, a 10.5.5 kext on an 10.5.2 system will cause KP.


Thank you, once again, Pere ;) Is there a way you can explain how to mod the ATIRadeonX1000.kext for each update of OSX. It will save you to post one for every update.

Have you managed to get external screen to work with id:718A ?

Also can you point me in the right direction for getting our wireless cards to work?

#159
blackmambo787

blackmambo787

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Unable to change resolution to 1280x800 on my laptop ASUS Z53jr (f3jr)....Did someone manage to do this?

Thanks

#160
pere

pere

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 726 posts

Thank you, once again, Pere :) Is there a way you can explain how to mod the ATIRadeonX1000.kext for each update of OSX. It will save you to post one for every update.

Have you managed to get external screen to work with id:718A ?

Also can you point me in the right direction for getting our wireless cards to work?


I just follow the first post method.... no external monitor.

There is a new driver developer for intel wifi cards here:
http://projectcampho...rcurysquad.com/





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy