Jump to content

ThinkPad T61 / T61P (X61 too) Installation and Config Guide

- - - - -

  • Please log in to reply
72 replies to this topic

#61
javi1r

javi1r

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Can somebody provide instructions on how to upgrade from 10.5.2 to 10.5.3?

I have follow the instructions from Kalyway. It looks like it is going to work but after the grey screen with the apple logo, it goes to a light blue screen, then to a black screen and nothing happens.

Any help is greatly appreciated. I have tried couple times already with no luck.

javi1r

#62
jimpatrick

jimpatrick

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I was able to successfully install iPC 10.5.6 on my ThinkPad T61, although like others here in this thread, I am still searching for an audio fix as well as a solution to the wireless network card. I've been trying practically everything I have read so far in the forums, all to no avail.

I have a feeling I am just not doing the correct thing. For instance, can someone please help me with a step by step, basic guide on how I can boot with -f boot flag as indicated in the instructions of iPC? And I really know nothing about kexts and extensions. I'm not that dumb though. Just basic instructions.

Thanks in advance.

#63
mhchan2002

mhchan2002

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Hi,

Mine to share the customization on it? How about the setting at BIOS? What is your T61 model number? Mine is 7661BL3 was it same at you. Thanks

#64
grandflash

grandflash

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
we are working to have the x61 brightness control working, please help :

http://www.insanelym...p...t&p=1139883

thank you, alex

#65
LillDragun

LillDragun

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
i have a Lenovo ThinkPad T61 7658-CTO

Intel Core 2 duo 2.20 GHz
2 gig ram
Atheros wifi
14.1 WXGA

I used iATKOS_v1.0i to install on my laptop and it installed without too much hassle. But when I try to load OSX it gets stuck in this screen after like 30 seconds. Any ideas of how to solve the problem or what it might be? please don't reply by saying that i should just get a mac. I would do that if i had $2000 lying around.

Attached Files



#66
anaxagoras

anaxagoras

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hello guys,

after tweaking around and reading a lot of tutorials i have decided to install iDeneb 10.5.7 on my Lenovo Thinkpad T61p. I have read tons of tutorials and tons of HCL and find out that lot of installations worked out of the box, with few things fully working and some not or partially working, but leopard booted. Mine not :) . I can get to chameleon 2.0 i select the partition where the mac os x is installed, but it is showing loading for 30 secs and after it tells me to restart machine everytime i want to boot iDeneb. I have tried to install drivers which worked for users with same laptops and hardware, but it does not work. Even clean install without drivers. Does anyone have some idea what to do now?

T61p specs 6460-8YG

PROC: Intel Core 2 Duo T7700 2,4GHz,
Chipset: Intel GM/PM965 chipset
RAM: 4GB RAM DDR 2 667Mhz
HDD: WD Scorpio Black 320GB, 16MB, 7200rpm, 12ms, Free-Fall sensor
GFX: Nvidia Quadro FX 570 256MB
SFX: SundMAX HD Integrated soundcard probably AD1984 as users with same laptop reported
ETH: Intel 82566MM Gigabit
WiFi: Intel 4965AGN

Other Things: 1GB Intel Turbo Memory, TPM Chip, BT, PCIMCIA, Memory Card Reader,

I had no problem installing and upgrading iDeneb to 10.5.8 in vmware on the same machine under Vista x64, but native install doesnt work. Tried iPC 10.5.6 Live DVD or iDeneb 10.5.7 many time with some drivers selected or clean with same result boot to screen saying restart with restart button or push power of button for long time. I will be very happy if someone will point me to some solution how to find out even what is wrong to search for something which will solve my problem.

Thank you.

#67
crashnburn_in

crashnburn_in

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
I have a Thinkpad T61with the NVidia NVS 140m.

I know this is 2009 and almost 1 year after all this.

Which would be the OSX / OSX86 Distro / Hack / Retail / Variant I should go for to install on this Thinkpad T61.

#68
crashnburn_in

crashnburn_in

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
I have a Thinkpad T61with the NVidia NVS 140m.

I know I might not have the NVidia full support but I'll take what I can at this point. 1400x1050 resolution to begin with would be NICE.

Which would be the OSX / OSX86 Distro / Hack / Retail / Variant I should go for to install on this Thinkpad T61.
PATH OF LEAST EFFORT, LEAST RESISTANCE?

#69
lacabos

lacabos

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

I have a Thinkpad T61with the NVidia NVS 140m.

I know I might not have the NVidia full support but I'll take what I can at this point. 1400x1050 resolution to begin with would be NICE.

Which would be the OSX / OSX86 Distro / Hack / Retail / Variant I should go for to install on this Thinkpad T61.
PATH OF LEAST EFFORT, LEAST RESISTANCE?


Hey,

I feel compelled to help my fellow t61ers out on this one. I'm currently typing this in OS X 10.5.8 on my T61 with the ethernet card installed on my laptop. There are a few errors I encountered while going about this but I can help out where I can. The few problems that I'm still working on are audio is completely off right now, resolution cannot go higher than 1024x768 (140m card not recognized), and no wifi.

So here are the solutions and status on some of these.
I used iDeneb 10.5.8 iso which can be found on many sites.
When installing this on my external hard drive I had to make sure to customize a few things. Add the voodoo touchpad PS2 fix. And install the Vanilla kernel.
When booting up I couldn't move the windows around without the graphics getting distorted. So I had to delete ALL the kexts located in the /system/library/extensions folder that started with NV. All but the NVSMU kext. This solved the window problem.
I had to use kext helper (Google "kext helper b7") to install the Intel 82566MM.kext and the NVinject.kext. I am not 100% sure that the NVinject.kext is useful, but its in.
Google "Project Camphor" to see the status on the wireless card for the 4965AGN. The developer looks to be making headway but who knows how long that will take. And search around for audio kexts. Remember if it doesn't boot up (kernel panic) at the Chameleon boot screen type -x (safemode). Finally, if you need wireless ASAP get a mac compatible wifi dongle for cheap!

Good luck and if you find more info on the t61 and audio, etc. make sure you post!

Cabo

Attached Files



#70
lacabos

lacabos

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Hey,

I feel compelled to help my fellow t61ers out on this one. I'm currently typing this in OS X 10.5.8 on my T61 with the ethernet card installed on my laptop. There are a few errors I encountered while going about this but I can help out where I can. The few problems that I'm still working on are audio is completely off right now, resolution cannot go higher than 1024x768 (140m card not recognized), and no wifi.

So here are the solutions and status on some of these.
I used iDeneb 10.5.8 iso which can be found on many sites.
When installing this on my external hard drive I had to make sure to customize a few things. Add the voodoo touchpad PS2 fix. And install the Vanilla kernel.
When booting up I couldn't move the windows around without the graphics getting distorted. So I had to delete ALL the kexts located in the /system/library/extensions folder that started with NV. All but the NVSMU kext. This solved the window problem.
I had to use kext helper (Google "kext helper b7") to install the Intel 82566MM.kext and the NVinject.kext. I am not 100% sure that the NVinject.kext is useful, but its in.
Google "Project Camphor" to see the status on the wireless card for the 4965AGN. The developer looks to be making headway but who knows how long that will take. And search around for audio kexts. Remember if it doesn't boot up (kernel panic) at the Chameleon boot screen type -x (safemode). Finally, if you need wireless ASAP get a mac compatible wifi dongle for cheap!

Good luck and if you find more info on the t61 and audio, etc. make sure you post!

Cabo


http://www.insanelym...amp;pid=1294186

-Has great info!

#71
Oglon3r

Oglon3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
For everybody with a FX570M t61p, install Mountian Lion for full QE/CL support.
Also you will need to install middleton bios to remove wifi card white list and unlock Sata II 3.0 Speeds.
List of cards that will work are here http://www.insanelym...00#entry1866982
Also sleep may be solved by following these commands;
1.Opening up the terminal and typing "sudo pmset lidwake 0" (without the quotes obviously). This is the only unnecessary step but it helped other problems I had where the screen would open and would be completely black, so I would recommend doing this, this just prevents your computer from automatically waking from sleep when you open the lid and you just have to press the power button to wake from sleep.
2. Next type "sudo pmset hibernatemode 3". Not sure what the 3 mode does differently but it defaults to 1. You can check that all these commands worked properly by typing "sudo pmset -g". Make sure you spelled hibernatemode and lidwake right because I don't have my Hackintosh in front of me so I am spelling them from memory.
3. Next just restart your computer and hit F2 at the dell screen to open your BIOS. Go to the advanced tab I believe and disable the option "Legacy USB support".
Thanks to element4lifex8 for this.
I have not yet tried the sleep fix but will come back with feedback once I do.

#72
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 915 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackintosh&Ap...
For all users:Lenovo ThinkPad T61 with GPU X3100
http://www.insanelym...vot61-7661-cto/
Work like sharm on this laptop :wink2:

#73
Oglon3r

Oglon3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
For anyone experiencing difficulties with the FX570M
use these kexts and follow these instructions.


http://adf.ly/ObMkI

Decompress the Extra Folder, you will see an "_Kexts_For_System" in Extensions.
Put all kexts in System/Library/Extension with Kextwizard or something similar.

ML developer preview worked
.
All the credit goes to cdyFlorian.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy