Jump to content

ThinkPad T61 / T61P (X61 too) Installation and Config Guide

- - - - -

  • Please log in to reply
72 replies to this topic

#41
Jeezoflip

Jeezoflip

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 651 posts
  • Interests:Computers of course!
i need the 140m to work!

#42
handyd

handyd

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I need some help. I'm starting with the Kalway 10.5.2 Install CD. The install went flawless with the Sleep Kernal. But I can't get the wireless to work at all.

I have the Thinkpad Wireless card and I followed the instructions, but it's not working.

I had it working once before when I started with the Kalway 10.5.1 CD, then did the upgrade to 10.5.2.

Any thoughts on what I can do?

Thanks.

#43
Jeezoflip

Jeezoflip

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 651 posts
  • Interests:Computers of course!
dude dude dude.... add the string to ur IO80211family.kext and then if that doesnt work after restarting and repairing permissions, then u might have to change ur en1 to eno in networkinterfaces.plist. if u have no idea what im talking about...well im sorry. im a bit drunk

#44
handyd

handyd

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I have the 168c,1014 added IO80211family.kext and it's save. I've rebooted several times and confirmed the change is there.

After restarting, the OS doesn't see the card. networkinterfaces.plist also doesn't show the Atheros card, just the Firewire. You mentioned repairing the permissions, but I'm not sure what needs to be repaired

Thanks for anything you might be able to provide?

EDIT:
Using this process, I have the machine seeing the card:

sudo -s
chown -R root:wheel /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext
chmod -R 755 /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext
touch /System/Library/Extensions
shutdown -r now

#45
Jeezoflip

Jeezoflip

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 651 posts
  • Interests:Computers of course!
what apps do u guys use to find ur cpu temp?

#46
justin2net

justin2net

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
570m, can manually set resolution, no qe/ci. black screen with driver.

#47
5445

5445

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
So... I am about to buy a new T61 with x3100 and the Thinkpad wireless. I should only have problems with sleeping and sound? Nothing else?

#48
Meteros

Meteros

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
from my post in july 08 in the kalyway 10.5.2 thread:

finally after a weekend of slaving away and scouring these forums, have a working leopard install on my Thinkpad T61 using kalyway 10.5.2. used the vanilla kernel only and checked both video drivers for the intel chip in the install customization. everything else was default.

System Specs:

CPU: Intel Core 2 Duo 2.2 Ghz
RAM: 2 GB
HD: Hitachi 120 GB
Audio: Intel HD Audio, AD1984
Graphics: Intel GMA X3100
Wireless: Thinkpad 802.11 a/b/g Wi-Fi

Used following guides:
Wireless: http://forum.insanel...&...st&p=238508 (still have to connect using network diagnostics every time i boot up)
Ethernet: http://techresearchinfo.blogspot.com/ (edit 10/9)
Video: http://forum.insanel...&...st&p=763465 (did not have to use sleep hot corner trick)
Audio: http://0xfeedbeef.com/osx86/ (headphone jack still not working, have not tested audio inputs)
Battery Meter: http://forum.insanel...howtopic=114105

also installed fingerprint reader from upek: http://www.upek.com/mac/download/


Biggest issue I still have is brightness control. It automatically sets it to the highest and drains my 6 cell battery in 1-1.5 hours. any fixes?
i still have issues with the webcam (only works when i take my account picture, never for apps like ichat, skype, photobooth etc)
Sleep also not working properly

#49
dingguijin

dingguijin

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
hi gus, I am working on Intel82566MM driver on my Hackintocsh (lenovo T61p).

Maybe two weeks (less or more), I can post the first version that can be working.

So far I can init the hardware and got the mac address.

I am working on the interrupt handler and output packet.

To get detail please access my blog http://techresearchinfo.blogspot.com/.

Guijin Ding

#50
myeyre

myeyre

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
;)

looks really complex to me, i'll give it a try another day.

#51
thinkmacky

thinkmacky

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

570m, can manually set resolution, no qe/ci. black screen with driver.



So you mean you can set resolution higher than 1024 x 768 ? What did you use ? I did a Kalway 10.54 - could only do 1024 x 768 max.

Cheers.

#52
kytzu

kytzu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male

So you mean you can set resolution higher than 1024 x 768 ? What did you use ? I did a Kalway 10.54 - could only do 1024 x 768 max.

Cheers.


Yeap, edit com.apple.Boot.plist and add

<key>Graphics Mode</key>
<string>1280x800x32</string>

#53
thinkmacky

thinkmacky

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Yeap, edit com.apple.Boot.plist and add

<key>Graphics Mode</key>
<string>1280x800x32</string>



Thanks Mate. It Works !

#54
kytzu

kytzu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
  • Gender:Male
I'm happy to post this message using my T61 LAN 82566MM addapter, Guijin's driver seems to be fine for T61, see kext file here :moil:

http://techresearchinfo.blogspot.com/

#55
b:z

b:z

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
For FX570m, i tried to load this NVinject kext 0.2.2 and my system graphic card display as "nVidia GeForce 8800 GT"
hope it is being completed by NVinject team.

Try this if you want to take a look.

Attached File  NVinject.kext.zip   22.81KB   75 downloads

;)

#56
gendalo76

gendalo76

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

I'm happy to post this message using my T61 LAN 82566MM addapter, Guijin's driver seems to be fine for T61, see kext file here :censored2:

http://techresearchinfo.blogspot.com/

Kytzu,
i've downloaded and installed the .kext. but i found nothing.
i used leopard kalyway 10.5.2.

is there anything i should do to make it working on my 10.5.2 box?

thx.

#57
sam w

sam w

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Kytzu,
i've downloaded and installed the .kext. but i found nothing.
i used leopard kalyway 10.5.2.

is there anything i should do to make it working on my 10.5.2 box?

thx.


You need to upgrade to 10.5.3 or higher

#58
Vampirce

Vampirce

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi there!

My intel 82566MM works like a charm. I have an Leo4All 10.5.2 installed and continued as follows:

1. Update to 10.5.5 from the thread "10.5.5 Combo Update 1.1.3a Patches is Out" - don't have the link but the handout here.
2. install the driver from http://techresearchinfo.blogspot.com. - you can use the Kext Helper b7 for the kext.

Have fun!

#59
gendalo76

gendalo76

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

You need to upgrade to 10.5.3 or higher


yupe... after upgrading to 10.5.3, it works!! thanks sam.

dingguijin, you've done a wonderful work!!! :D
:)

#60
Vampirce

Vampirce

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
a question about doble command: it says "You cannot change the DoubleCommand-preferences, because it's not possible on an intel-based Mac." (translated from German).

Do you know any way out of that? I have OS X 10.5.5 installed on a T61.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy