Jump to content

"still waiting for root device" during boot usb installer


  • Please log in to reply
13 replies to this topic

#1
Bolzo

Bolzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Venice

Hi everybody, I'm trying to install Iatkos ML2 in my notebook (acer V3-571G)

 

I made the usb installer from a virtual machine (iatkos ml2 dmg and then Chamaleon), setted up the BIOS (ACHI controller, legacy boot etc)

Anyway, when I boot the usb it's all ok, chamaleon starts, but when I launch iAtkos it hangs at "Still waiting for root device".

 

I emphasize that it crashes when I lounch the USB installer, NOT when I boot the installed system (so, it isn't a problem with the HD controller.. or not?)

 

Obviously I tryed with the basic flags like -v -x -f etc.

 

Can someone help me?

 

(Sorry for my bad english :rolleyes: )

 



#2
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,552 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

try 

 

USBBusFix=Yes

 

npci=0x2000 or 0x3000

 

and post a pic from the boot

 

good hack



#3
Bolzo

Bolzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Venice

tried, nothing changes, but now I notice that there are some other errors with USB

 

Here is the pic

 

xqe2ok.jpg



#4
Bolzo

Bolzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Venice

Any other?

 

More informations:

 

Motherboard chipset: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09) (VA50_HC_CR)

CPU Intel® Core™ i7-3632QM CPU @ 2.20GHz

Graphic: Intel HD 4000 and Nvidea Gforce 710M

 

Tried this flags:

UsbBusFix=Yes, EHCIhard=Yes, NPCI=0x2000 and 0x3000, -v -x etc



#5
Onixs

Onixs

    Since 2007

  • Members
  • PipPipPipPipPipPipPip
  • 749 posts
  • Gender:Male
It has nothing to do yet with your ahci controller since you are booting off a usb. My suggestion would be for you to try another USB stick

#6
Bolzo

Bolzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Venice

It has nothing to do yet with your ahci controller since you are booting off a usb. My suggestion would be for you to try another USB stick

 

I'll try, I will inform you

Anyway, I tried the key also in other computers, it works without problems..



#7
Onixs

Onixs

    Since 2007

  • Members
  • PipPipPipPipPipPipPip
  • 749 posts
  • Gender:Male

incompatibility indeed. try other stick



#8
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

try UseKernelCache=No  -v 



#9
Bolzo

Bolzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Venice
incompatibility indeed. try other stick

 

Ok, now I'll try to make it.

 

try UseKernelCache=No  -v 

 

always stuck at the same point



#10
Bolzo

Bolzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Venice

I made another stick with Pandora and a clean OSX ML (no iAtkos etc)

Now it gets a panic, here is a pic.

Obviously I tried -x -f -v ecc

330qnf9.jpg



#11
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

install NULCPUPowermanegement.kext to Extra/Extensions or SLE, boot with -f -v



#12
Bolzo

Bolzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Venice

Now it don't give panics
but it stucks at "still waiting for root device"

 

I tried USBBusFix=Yes, but nothing change



#13
Allaп

Allaп

    Staff Member

  • Local Moderators
  • 3,075 posts
  • Gender:Male
  • Interests:Yosemite Final Version

try enable AHCI in your BIOS setup.



#14
PimentelX86

PimentelX86

    InsanelyMac Deity

  • Local Moderators
  • 2,445 posts
  • Gender:Male
  • Location:Area 51

Hello

 

If your mobo doens't has AHCI mode, you can download this kext and put in S/L/E: http://www.insanelym...rvell-88se6121/

 

boot with -v -f







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy