Jump to content

XRadeonFB


  • This topic is locked This topic is locked
70 replies to this topic

#21
^kaneda

^kaneda

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
loli get an moni with edid but i cant make it work now, owner/permissions denied... wtf?

#22
Koffein

Koffein

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:sweden
Could someone plz post install instructions i have tried the callisto way but didnt get it to work..
I have an ATI Radeon 9600, Display supporting EDID

thx
Chris

#23
joe75

joe75

    Renegade

  • Retired
  • 2,207 posts
  • Gender:Male
  • Location:Rochester, NY
I installed just like Callisto with no problem= chown -R root:wheel and chmod -R 755 etc... ;)

#24
tyre777

tyre777

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
woot nice joblo!! hope support for notebook lcds will be available soon- cant wait to test this on my 9700 lappy.. :) hope you can get osx to support 1400x1050 coz previously on callisto with qe ci enabled i got severe window tearing.. ;)

#25
Zealot

Zealot

    Zealot FTWeed!!!

  • Members
  • PipPipPipPipPipPipPip
  • 901 posts
  • Gender:Male
  • Location:Santiago ,Chile .
  • Interests:Gamez pc, manga,craks n over cloks
a question?
this mean atacking the problem from a whole new way .
is this some kind of replace of what callisto did or is it a complement to
the other efforts of people like omni and your self.
sorry if i am a litle offopic but its just to get the big picture of this

#26
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male

is this some kind of replace of what callisto did or is it a complement to

This replaces Callisto

#27
graphic Design

graphic Design

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 430 posts
Anybody tried this one?
I didn't try because I dont have much experience about it!
I hope this one work better than Callisto's one!
So If someone tried already, please post the result!

Thank you...

#28
joe75

joe75

    Renegade

  • Retired
  • 2,207 posts
  • Gender:Male
  • Location:Rochester, NY
I tried it and posted all results :idea:

#29
tyre777

tyre777

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
so far hows ur xbench joe? accelerated opengl? i mean much like those of intel gmas? or faster.. :idea:

#30
greenman100

greenman100

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
I take it this work work for an ATI RAGE XL?

#31
joe75

joe75

    Renegade

  • Retired
  • 2,207 posts
  • Gender:Male
  • Location:Rochester, NY
I'm stuck with only half screen. The top half is my desktop x5 and the bottom is the end of the startup log that hasn't gone away :thumbsdown_anim:

#32
graphic Design

graphic Design

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 430 posts
So, it works good? QE&CI supported?
Joe75, how U feel? This one better than Callisto's one? Should We replace Callisto with this XRadeonFB?
Thanks

#33
joe75

joe75

    Renegade

  • Retired
  • 2,207 posts
  • Gender:Male
  • Location:Rochester, NY
No replaceing yet :) Installation is a success but I cant test or see anything because "I only have half screen" and have explained that four times. The build is still early and should be tested be someone with a real monitor :( joblo10 still has work to do on this and testing and feedback will only help to speed things up :angel:

#34
StarForge

StarForge

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts
I'm not sure if its something I did, but I removed Callisto, changed the FrameBuffer entry in ATIRadeon9700GA.plugin/Contents/Info.plist to 'XRadeonFB' and after reboot, my display showed the grey Apple screen then after that went to a black screen?

#35
Koffein

Koffein

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:sweden
Tried to install it screen went black.. had to remove the file..
do i have to edit something in the file to get it to work ???

some info about my system
Intel 845G Chipset
Intel P4 2,53Ghz SSE2
512MB Ram
Ati Radeon 9600 256MB
AC97 Sound
17" Lcd Screen

cheers
Chris :)

#36
joe75

joe75

    Renegade

  • Retired
  • 2,207 posts
  • Gender:Male
  • Location:Rochester, NY

I'm not sure if its something I did, but I removed Callisto, changed the FrameBuffer entry in ATIRadeon9700GA.plugin/Contents/Info.plist to 'XRadeonFB' and after reboot, my display showed the grey Apple screen then after that went to a black screen?



This is not Callisto and there is no need to edit in framebuffer in 9700GA

joblo said you need to remove Callisto to keep it from loading before XRadeonFB and that would mean to put 9700GA back to original too;)

#37
StarForge

StarForge

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts
Ahh thanks joe75, I'll try again ;)

#38
tyre777

tyre777

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
dont forget to repair permission too.. ;)

#39
StarForge

StarForge

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts
  • I removed Callisto
  • Reverted ATIRadeon9700GA.plugin/Contents/Info.plist (removed the FB entry)
  • Repaired permissions
  • Rebooted
... and my monitor went immediately into powersave mode after the grey apple screen.

I've a Radeon 9800 AH

#40
tyre777

tyre777

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
what does it say when you enter -v on bootup?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy