Jump to content

Switchable Graphics Problem 10.8.2

switchable graphics intel ati radeon gpu

  • Please log in to reply
6 replies to this topic

#1
Andrea Z

Andrea Z

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Italy

Hi to everyone, 

I'm trying to install iATKOS ML2 on an HP G62 with the switchable graphics card.

Everything seems fine except this:

if I boot with GraphicsEnabler=No, the PC boots up, in system info it shows an unknown ati gpu with no kext loaded, no QE CI and everything is laggy. But at least all the rest works fine.

if I try to boot with GraphicsEnabler=Yes, it shows the attached errors.

I'd like to totally kill the Radeon card, I'd be happy to use just the integrated Intel HD gpu, but I tried million ways (changing DSDT, kext's and all the possible boot flags..) without success.

What could I do?

Thanks for your help

 

UPDATE:

I tried changing the booting frame buffer using the flag AtiConfig followed by the name (ex. Langur).. Still nothing.. I always get the same error.

My CPU is an Intel i3 M350 and the Radeon is a 6370M.

Attached Files


Edited by Andrea Z, 18 October 2013 - 03:40 PM.


#2
Sainath

Sainath

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Bangalore
  • Interests:Game developer for Apple and intern at Makuta VFX

Is your GPU 5470m or 6370m ? I thought HP G62 comes with 5470m ! 



#3
Andrea Z

Andrea Z

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Italy

Is your GPU 5470m or 6370m ? I thought HP G62 comes with 5470m ! 

6370m, I just checked... G62 got something like 30 / 40 versions.. I'm hating this.. Got any idea on how to solve this?

I need to enable the flag GraphicsEnabler...



#4
Sainath

Sainath

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Bangalore
  • Interests:Game developer for Apple and intern at Makuta VFX

6370m that comes with HP 68e4 has aticonfig=Eulemur



#5
Andrea Z

Andrea Z

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Italy

6370m that comes with HP 68e4 has aticonfig=Eulemur

Ok, so this is the string I will put in the aticonfig.. What more do I need to do? EDID modifying no?

Update: Radeon Monitor says "Unknown device ID"....



#6
Sainath

Sainath

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Bangalore
  • Interests:Game developer for Apple and intern at Makuta VFX

Check this : http://www.insanelym...tain-lion-qeci/



#7
Andrea Z

Andrea Z

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Italy

I'm starting to exclude a kext config problem. It has to be something different.. cause it stops just after the kernel starts..


I will check this out and let you know.. Thank you :-)







Also tagged with one or more of these keywords: switchable, graphics, intel, ati, radeon, gpu


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy