Jump to content

AMD Build help


  • Please log in to reply
7 replies to this topic

#1
Jonty!

Jonty!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

Hey guys,

Been away from the Hackintosh scene for a while now, couple of years.

Basically this is my spec, would I be able to install Lion at least on it?

 

Asus M4A78LT-M 760G Motherboard

AMD Phenom II X4 850 3.3GHz

ATI Radeon HD 5850 1024MB

 

I just need help in which distro/method would be the best, there's so many different ways of installing OSX now, I can remember back in 'day there was about 3 distros and that was it :)

 

Thanks,

Jonty.



#2
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 3,016 posts
  • Gender:Male
Yes, and will work like a charm. Maybe iCloud services and FaceTime give you a real challenge, but other than that, it will be close to perfection. Follow the AMD section in the Developers Corner subforum.

All the best.

#3
Jonty!

Jonty!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

Thanks for your reply :)

Still a bit unsure on how to patch the kernel. Do I get a vanilla dvd image and patch it (and how :P)? Is there a link to a guide at all?

Thanks again!

Yes, and will work like a charm. Maybe iCloud services and FaceTime give you a real challenge, but other than that, it will be close to perfection. Follow the AMD section in the Developers Corner subforum.

All the best.



#4
blipotech

blipotech

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Have you taken a look here:

http://www.osx86.net...12-kernels.html

for any related/patched kernels ?



#5
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 3,016 posts
  • Gender:Male

Check the downloads section here on Insanelymac for the latest Lion kernel for AMD (and legacy Intel).

 

All the best!


P.S.: for a guide, use this: http://www.insanelym...erimental-only/

 

Yeah, it's deprecated, and you'll have to follow slightly different instructions: first, don't use -legacy as a boot flag. Second, don't use the kernel linked there, but the one i suggested to you instead. Third, you don't have to replace Finder.app or patch XPCHelper or anything suggested in the comments.

 

Good luck.



#6
Jonty!

Jonty!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Hey,
Thanks for your help so far :)

Managed to get iAtkos ML2 installed. However on first boot I've got the metal slate screen and the cursor I can move about. Native res etc but I'm stuck on it? I can move my mouse all the way to the left and it disappears so I'm thinking it could be something to do with incorrect settings of a multiple display?
Tried changing res in chamelon settings but it just defaults to native res once booted

Thanks.

#7
blipotech

blipotech

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Congrats Jonty!

 

Maybe double check your res settings in your .plist boot file, to verify your changes  are being applied? If not change them manually either in text or as a boot argument. 



#8
Jonty!

Jonty!

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

Hey,

Tried changing the screen rest EVERYWHERE but it still boots in 1600x900 :/

Chameleon boot.plist, main boot.plist, everywhere :/ Even boot flags won't bypass it. Would it be because I installed the 1600x900 resolution package on install?

 

Thanks.

Congrats Jonty!

 

Maybe double check your res settings in your .plist boot file, to verify your changes  are being applied? If not change them manually either in text or as a boot argument. 







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy