Jump to content

AMD APU mountain lion support

APU AMD Pavilion

  • Please log in to reply
299 replies to this topic

#41
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

Do you have an 'Extra' folder on your usb disk?
You need to put a ps2 kext in the 'Extra/Extensions' folder on your usb stick, if you do not have those folders, create them, then put this kexts from the link below in the Extensions folder and reboot:
http://www.insanelym...ttach_id=111821

going to try right away ;b
EDIT: didnt work..maybe i did something wrong :/

#42
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building
did you include the -f flag?
when you decompressed the zip file, did you copy the actual kext files into the /Extra/Extensions folder or the containing folder?

#43
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

did you include the -f flag?


Now I did..I did not knew I had to :P lets wait **

EDIT: And....did not work :/

did you include the -f flag?
when you decompressed the zip file, did you copy the actual kext files into the /Extra/Extensions folder or the containing folder?

The kexts.

#44
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building
you need different ps2 kexts then, what is your laptop model number? do you have any usb 3.0 ports? do you plug in your usb mouse into the usb 3.0 port?

#45
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

you need different ps2 kexts then, what is your laptop model number? do you have any usb 3.0 ports? do you plug in your usb mouse into the usb 3.0 port?

I only have USB 3.0 :P only found out that a month ago after having the laptop so many times xD and I'd like to use the keyboard and touchpad :/ and the usb mouse doesnt work either

#46
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building

I only have USB 3.0 :P only found out that a month ago after having the laptop so many times xD and I'd like to use the keyboard and touchpad :/ and the usb mouse doesnt work either

what is the model of your laptop?

#47
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

what is the model of your laptop?


HP Pavilion g6-2151sp :D

EDIT: I got news..had to make it work with the clover method..but now it is installing :P Just fear disk utility {censored}ed up my windows installation..but ill see that later :P cuz I had 4 partitions.. one for ML another that was windows and another one that was RECOVERY and SYSTEM.. windows and recovery became one :( and that means I dont have a recovery method anymore :( damnit! but ill try to boot windows..

EDIT2: Graphics appear to be a bit Glitchy on the installation..but that means maybe its missing something? :P and wifi..I thought Atheros was automatically recognized :/ but well I'll wait 14 mins :P and how the hell am I going to put the kernel in the system if my windows is gone? oh god :shock:

Edited by pmmc, 03 April 2013 - 02:44 AM.


#48
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building

HP Pavilion g6-2151sp :D


delete the ones from the link I sent you before and try these ones, put them in the same folder '/Extra/Extensions/' and do not forget the -f flag :)

http://h10025.www1.h...cname=c03384193 shows that you have 1 USB 2.0 port, is that the one you are using to load the installer?

Attached Files



#49
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

delete the ones from the link I sent you before and try these ones, put them in the same folder '/Extra/Extensions/' and do not forget the -f flag :)

http://h10025.www1.h...cname=c03384193 shows that you have 1 USB 2.0 port, is that the one you are using to load the installer?


I have no Idea dude :P it is already installing ** I have Clover..so that my CPU works :P I putted in EFI/Kexts/10.8 ,the PS2 ones that u had given to me :P and until now..100 per cent responsive ;D first bloody APU laptop to HAVE Mountain Lion being Instaled :D hehe :P and PROBABLY reaching the desktop :P hihi

EDIT: And I thought this laptop was impossible..I KNEW THERE WAS A WAY :P HAHA :D btw: will it install the mach_kernel I have currently? If so..AWESOMMEEEE :P

EDIT2: 7 Minutes to go..History being made here :P hehe

EDIT3: I might be using a USB3 xD Its the one I use for Data transfer to my External HDD that has 3.0 :P and the transfer rates are fast :P more than usual hehe

Edited by pmmc, 03 April 2013 - 02:56 AM.


#50
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,826 posts
  • Gender:Male
Congrats!

Now that you made it with our help, could you be nice enough to write a guide for your fellow APU users and post here on the forum? That way, you could also be the first to teach others to install Mountain Lion on an AMD APU machine. :D Of course, i'm not asking you a full tutorial, only a brief description of the method you used to successfuly install OSX on your computer, the tools (kernel, bootloader etc) and what's working and what's not. Post here: http://www.insanelym...ds/page__st__40

All the best!

#51
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building

Congrats!

Now that you made it with our help, could you be nice enought to write a guide for your fellow APU users and post here on the topic? That way, you could also be the first to teach others to install Mountain Lion on an AMD APU machine. :D

All the best!


I have an APU but it does not seem to work, mine is an a6-3410mx, it does not have ssse3 and sse4.1/4.2 like pmmc's does

#52
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

Congrats!

Now that you made it with our help, could you be nice enought to write a guide for your fellow APU users and post here on the topic? That way, you could also be the first to teach others to install Mountain Lion on an AMD APU machine. :D

All the best!


Once I get it up and running it would be my Honor :P 4 minutes ** cant wait..Im Stoned I wanna sleep xD I can hear Thunders..Its rainning high as "{censored}" :P

I have an APU but it does not seem to work, mine is an a6-3410mx, it does not have ssse3 and sse4.1/4.2 like pmmc's does


Maybe yours works..but only with sse3? (Try sinetek's kernel "mach_sse3_only") ?
Oh and USE CLOVER TO BOOT :P Its the biggest part of the puzzle to work ;b

#53
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building

I have no Idea dude :P it is already installing ** I have Clover..so that my CPU works :P I putted in EFI/Kexts/10.8 ,the PS2 ones that u had given to me :P and until now..100 per cent responsive ;D first bloody APU laptop to HAVE Mountain Lion being Instaled :D hehe :P and PROBABLY reaching the desktop :P hihi

EDIT: And I thought this laptop was impossible..I KNEW THERE WAS A WAY :P HAHA :D btw: will it install the mach_kernel I have currently? If so..AWESOMMEEEE :P

EDIT2: 7 Minutes to go..History being made here :P hehe

EDIT3: I might be using a USB3 xD Its the one I use for Data transfer to my External HDD that has 3.0 :P and the transfer rates are fast :P more than usual hehe

You might need to install the USB 3.0 ports, I am not sure for mountain lion but for Lion and SL you have to...
You need to copy the mach_kernel you used into the root of your new installation...

Once I get it up and running it would be my Honor :P 4 minutes ** cant wait..Im Stoned I wanna sleep xD I can hear Thunders..Its rainning high as "{censored}" :P



Maybe yours works..but only with sse3?
Oh and USE CLOVER TO BOOT :P Its the biggest part of the puzzle to work ;b

Attached File  apu.gif   23.31KB   4 downloads

#54
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,826 posts
  • Gender:Male

I have an APU but it does not seem to work, mine is an a6-3410mx, it does not have ssse3 and sse4.1/4.2 like pmmc's does


It could work, because the amd_kernel of the first page of Mountain Lion Kernel Testing topic has a built-in opcode emulator which provides all the modern simd instructions. Depending on the GPU, though, graphics might as well be buggy. I think you should try for the sake of testing it. :)

All the best!

#55
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P
ALright..I lost windows :( and Recovery.. can I UNDO this? :( ..and..also..there was an error at the end of the installation HELP :'(

#56
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,826 posts
  • Gender:Male
Nevermind the error: try to boot! Most of these error messages are fake.

About Windows and recovery, they're gone: you'll have to reinstall Windows, and the recovery partition is really lost forever.

#57
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building
Lemme g

ALright..I lost windows :( and Recovery.. can I UNDO this? :( ..and..also..there was an error at the end of the installation HELP :'(

Try this: http://social.techne...19-8253c4d79243

It could work, because the amd_kernel of the first page of Mountain Lion Kernel Testing topic has a built-in opcode emulator which provides all the modern simd instructions. Depending on the GPU, though, graphics might as well be buggy. I think you should try for the sake of testing it. :)

All the best!

Will give it a try when I get the chance, I have a bit of reading to right now, maybe later in the day. I have run SL and Lion before


ALright..I lost windows :( and Recovery.. can I UNDO this? :( ..and..also..there was an error at the end of the installation HELP :'(

Try this: http://social.techne...19-8253c4d79243

#58
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,826 posts
  • Gender:Male
Oh, he just lost the ability to boot Windows then? I thought he meant he wiped the partitions out :P

#59
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

Nevermind the error: try to boot! Most of these error messages are fake.

About Windows and recovery, they're gone: you'll have to reinstall Windows, and the recovery partition is really lost forever.


alright then..but I have to put the mach_kernel on the partition? how will I do that? can I do it inside the Instalation? ..And that means I lost my stuff on Windows..Holly {censored} :/

EDIT: NO i didnt WIPE them.. I formatted the one for moutain lion and at the end.. RECOVERY and WINDOWS United.-- (wtf? ) all of nowhere..oh well..

#60
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building

Oh, he just lost the ability to boot Windows then? I thought he meant he wiped the partitions out :P

Yeah, just the ability to boot, and Microsoft is stupid, they do not have a guide to solve the problem, you have to do it manually, but reinstalling is another option, I would avoid it and use the guide in the link I posted in my last post

alright then..but I have to put the mach_kernel on the partition? how will I do that? can I do it inside the Instalation? ..And that means I lost my stuff on Windows..Holly {censored} :/

EDIT: NO i didnt WIPE them.. I formatted the one for moutain lion and at the end.. RECOVERY and WINDOWS United.-- (wtf? ) all of nowhere..oh well..

DO NOT FORMAT YOUR DRIVE, Windows and all your documents are still there, we just have to get you to be able to boot into it, by installing mountain lion the installation played with the mbr, making your Windows partition unbootable.
First we need to get you to copy your mach_kernel from the installation disk to the MAC OS X ML partition

Oh, he just lost the ability to boot Windows then? I thought he meant he wiped the partitions out :P

theconnactic,
can you please help pmmc with a simple guide to use the terminal to delete the current mach_kernel on his hard drive and copy the one from his installation disk? I would do it but I have to read a bit.





3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy