Jump to content

RT5370 ralink wireless usb not work in 10.8

rt5370 ralink wireless

  • Please log in to reply
10 replies to this topic

#1
devilmj

devilmj

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hello everyone, I bought a wireless pen with ralink RT5370 chip because I read that it was compatible with hackintosh 10.8 mountain lion.

I downloaded the drivers from here: http://www.mediatek....dows.php?sn=502

I installed the pkg, then after several attempts the wireless card was on, found the net, and I'm connected but not sail.

I made many trials, many of installing kext utility but without success. I set the dhcp automatic, manual, and changed my wireless (from 3 to 6 and then to 11-13 channel)

To do these tests now not working again, can anyone help?

I have tried both with mac 10.8 distro with Niresh and with iATKOS

Now I tried it also on mac 10.6.6 with leohazard but even here I do not work ...

the VID/PID is 148f:5370

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
you need edit your info.plist of the kext with device id of your USB Wifi

#3
devilmj

devilmj

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

you need edit your info.plist of the kext with device id of your USB Wifi


how can i do?

#4
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
download app Text Mate and edit in the infoplist of kext for your USB Wifi, look this example mine kext and my USB WIFI, here is my example, the root for the kext , put device id /Produt id in decimal values, look this

/System/Library/Extensions/RT2870USBWirelessDriver.kext/Contents/Info.plist


Attached File  Captura de pantalla 2013-04-16 a la(s) 20.52.29.png   93.12KB   172 downloads

#5
devilmj

devilmj

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

I tried the key on mac lion 10.6 of my brother, I installed the drivers mediatek site and it went the first time. After giving him the dns, navigate safely and without any problems.

Speedtest by a low ping and good response. So the pen works and also the drivers.

Now I just have to remember how I did it I go, I guess I should do a clean install of hackintosh ..

even though I have 10.8 and certainly will be more difficult but I definitely remember that I succeeded to make it go, installing many kext sooner or later I had it done.

i have a dmg and a pkg installer, not a kext for my device.

I installed this http://www.mediatek....ail.php?sn=5004 and with my original mac 10.6 it works, with my hackintosh 10.8.3 not working...

the utility show the wireless, but when i try to connect with my wpa2 wlan, not connect



#6
kashmere01

kashmere01

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

hello,i know this is a old thread,but wondering why i dont have the rt5370 kext in my s/l/e folder to edit? my usb wifi shows up in system profile..

thanks ahead of time if you can help!!!!



#7
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,035 posts
  • Gender:Male
  • Location:Brazil

If you haven't installed the driver then there's no kernel extension to edit.



#8
kashmere01

kashmere01

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

thanks for getting back to me!!!

i installed the V5 install package from ralink,so i would have thought it would install the kexts itself no?

downloaded one from kexts.com too,but it had no installer,and no kexts in it..

i have been doing this for awhile,and this wifi worked great on lion,but im stumped here...lol

feel like a noob!!



#9
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,035 posts
  • Gender:Male
  • Location:Brazil

Yes I suppose so.. If it didn't end up in /System/Library/Extensions then I don't know where it is. I have a stick with the 3070 chip that I had working, but it's in use elsewhere at the moment and I don't remember anything..

 

Maybe you can find something in this topic:

http://www.insanelym...or-ralink-2870/



#10
kashmere01

kashmere01

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

thanks for the quick response!!!

yea doesn't make sense right? no kext,not in extra folder also...

i'll give that thread a look now



#11
kashmere01

kashmere01

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Yes I suppose so.. If it didn't end up in /System/Library/Extensions then I don't know where it is. I have a stick with the 3070 chip that I had working, but it's in use elsewhere at the moment and I don't remember anything..

 

Maybe you can find something in this topic:

http://www.insanelym...or-ralink-2870/

THANK YOU GRINGO!!!!!!!!

found my fix on page five

i really appreciate it!!







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy