Jump to content

[SOLVED] verbose boot without any flag (-v) after 10.8.3 update

mystical..

  • Please log in to reply
7 replies to this topic

#1
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 886 posts
  • Gender:Male
  • Location:France
Hello fellas,

I am rebutting on a minor problem. Recently, i have updated my Mountain Lion partition. After the classic restart procedure, i have manually booted in verbose mode at the chameleon boot screen as i don't have any flags relative to verbose in the different boot.plist :



/Library/Preferences/SystemConfiguration/com.apple.Boot.plist : empty string relative to verbose mode confirmed




/Extra/org.chameleon.Boot.plist : empty string relative to verbose mode confirmed



Chameleon r2187 is installed on the main partition, no USB key is plugged with any kind of bootloader.

So after the tweaks (rollback, patch, etc,.), the installation is functional but now boot always in verbose mode ! As i have already checked the boot sequence and confirmed everything is fine, i don't need it anymore, besides i don't have any idea why and how it boots in verbose mode.

There is a bit of mystical here to me, so if a Mhack guru enlighten this, i would appreciate :)


Nicolas

#2
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Hmm, -x maybe? I never don't boot verbose so sounds like a good problem for me :)

#3
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,429 posts
  • Gender:Male
  • Location:Tru, Venezuela
I think is a "feature" or maybe "bug" in recent revisions of Chameleon 2.2svn, it also happened to me in the prior r2183 because the bootloader keep always executing the last flag manually typed. So, in the boot prompt write another flag (just one) than you usually have in /Extra/o.c.B.p, I mean GraphicsEnabler=Yes for example, then press enter, and that will be the last flag effective for the next restarts, of course apart of the other flags that have from the /Extra/o.c.B.p. I hope this helps.

Edited: Tested and worked also by deleting the flag (-v for example) in the boot prompt, and enter. I have installed Chameleon 2.2svn r2187.

#4
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
in terminal: sudo nvram boot-args=""

That will fix it.

#5
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 742 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod
Methods above should work fine :D
It seems its related to the latest patch for imessage.

#6
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 886 posts
  • Gender:Male
  • Location:France
It's a bug ? No, it's a feature. :thumbsup_anim: Sounds very Apple. Thanks a lot for the prompt help :wink2:

Problem solved :moil:

#7
Manwe

Manwe

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Bačka Palanka, Serbia

bumped onto this problem with build 2377! nyolc8's solution worked perfectly... Even after a year same bugs dig out to the surface. 



#8
legends74

legends74

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

 Sweet mercy, thank you nyolc8. I can boot without -v every time. From cold boot to desktop in under 20 seconds now!







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy