Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
The Real Deal

[SOLVED] verbose boot without any flag (-v) after 10.8.3 update

8 posts in this topic

Recommended Posts

Hello fellas,

 

I am rebutting on a minor problem. Recently, i have updated my Mountain Lion partition. After the classic restart procedure, i have manually booted in verbose mode at the chameleon boot screen as i don't have any flags relative to verbose in the different boot.plist :

 

 

 

/Library/Preferences/SystemConfiguration/com.apple.Boot.plist : empty string relative to verbose mode confirmed

 

 

 

 

/Extra/org.chameleon.Boot.plist : empty string relative to verbose mode confirmed

 

 

 

Chameleon r2187 is installed on the main partition, no USB key is plugged with any kind of bootloader.

 

So after the tweaks (rollback, patch, etc,.), the installation is functional but now boot always in verbose mode ! As i have already checked the boot sequence and confirmed everything is fine, i don't need it anymore, besides i don't have any idea why and how it boots in verbose mode.

 

There is a bit of mystical here to me, so if a Mhack guru enlighten this, i would appreciate :)

 

 

Nicolas

Share this post


Link to post
Share on other sites

I think is a "feature" or maybe "bug" in recent revisions of Chameleon 2.2svn, it also happened to me in the prior r2183 because the bootloader keep always executing the last flag manually typed. So, in the boot prompt write another flag (just one) than you usually have in /Extra/o.c.B.p, I mean GraphicsEnabler=Yes for example, then press enter, and that will be the last flag effective for the next restarts, of course apart of the other flags that have from the /Extra/o.c.B.p. I hope this helps.

 

Edited: Tested and worked also by deleting the flag (-v for example) in the boot prompt, and enter. I have installed Chameleon 2.2svn r2187.

Share this post


Link to post
Share on other sites

bumped onto this problem with build 2377! nyolc8's solution worked perfectly... Even after a year same bugs dig out to the surface. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×