Jump to content

Installing SL on Dell 630M

  • Please log in to reply
44 replies to this topic



    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
For 10.5 or 10.6 it can also be placed in /Extra/Extensions/

Zero Shadow

Zero Shadow

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
After being a few days away I attempted more work on this and made some headway so I was able to get the Dsmos error fixed I put a copy of FakeSMC in both the /E/E and S/L/E then I discovered that the dsmos.kext was totally missing. After finding one from my successful previous attempt and putting it in S/L/E I was able to get past the error. :thumbsup_anim:

Then I was presented with another error an panic error dealing with the apple.iokit.IOATAFamily kext I was able to figure that out by removing and updating the kext and got past that hurdle.

Now this is where I am stuck at

Attached File  IMG_6558.JPG   135.7KB   3 downloads

It gets stuck here at: launchtl : Please Convert the following to launchd : /etc/mach_init.d/dashboardadvisoryd.plist

So far I have attempted basis on research
fsck -fy
mount -uw /
autodiskmount -va
diskutil repairPermissions /

and trying to use the DU on the install disk to repair the permissions but still to no avail.

Getting Closer I hope

Zero Shadow

Zero Shadow

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
I have an idea I would like to try but need someone's help who has a copy of Snow Leopard installed on their pc already could you send me this file or folder


Obviously the version I have is not working and I have checked my install Cds but cant seem to find it I thinking if I replace that file it should bypass the error above right?

Zero Shadow

Zero Shadow

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
So after doing a bit more research I tried something different i was using the Chameleon 2.1 boot CD to boot into SL with the tags -x -v arch=i386 GraphicsEnabler=No but I would get stuck at the error above. So what I did was change the boot cd, I tried both the ##### CD and the Nawcom Mod CD and below are the results.
*Note: The reason I am using the BootCD as I have Windows XP on the same drive with Macdrive so that I edit and change the files on the SL partition however when I installed SL it did not install the bootloader correctly so the PC boots into XP hence the use of the bootCds.

This one pointed out a number of panic errors SleepEnabler and AppleIntelCPUPowerManagement I removed the SleepEnabler and founded a updated version of CPUPower as if I removed it I recieved an error that it was missing. However even with that I would get stuck here.
Attached File  IMG_6579.JPG   125.55KB   2 downloads

Nawmod BootCD
I didnt have any panic errors when using this method and whether i use the bootflags I mentioned above or not I get the same results. I noticed that using this method it gives some errors about the ktexts are blacklisted I can only assume since the installer adds these files on its own and the fact that I dont have any of the hardware for these kexts is the reason for the error.

Attached File  IMG_6577.JPG   151.58KB   3 downloads

If you notice that its mentions the Intel950, Geoforce etc I have also removed what I found are ktext related to ATI video drivers so hopefully that will help. I'll report back on my findings.

Zero Shadow

Zero Shadow

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Well after a long fight I was able to do it I installed Snow Leopard :thumbsup_anim:
Attached File  IMG_6583.JPG   81.47KB   1 downloads

What I ended up doing was installing the Hazard 10.6 distro without any options then installing the Iatkos S3 v2 with a few options (i cant remember them atm) the installation didnt completed however the bar was full for about 3 hours before I finally quit the installer and decided hey why not try it. After getting stuck on Waiting for Dsmos again and knowing how to fix that I booted using the nawmod CD and without any tags and it booted.

Obviously this is a huge step in the right direction now I have to figure out:

Not Working:
Display / Graphics Card - GMA 900
Sound - SigmaTel STAC9200
CD Drive wont eject but reads the disc thats currently in the drive.

Wireless (using a Airlink Wireless Adapter)

Havent tired
Card Reader
*dont really care about these maybe the card reader but have a usb I can use if all else fails

So for the Graphics Card
I found these threads

So hopefully I'll be able to figure it out

I have heard that Voodoo works better than AppleHDA in my case with the SigmaTel STAC9200 which would be better to use?

I'll report my findings as I go .

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy