Jump to content

Lion 10.7.5 on Acer 5950G Problem


  • Please log in to reply
6 replies to this topic

#1
diginix

diginix

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Here is info of installing Lion (10.7.5) as second OS on my Acer 5950G
Configuration at first:
CPU i7 2630QM

RAM 6Gb
HDD:
- 1st partition for Win
- 2nd partition for Mac

Video: AMD Radeon HD 6650M - working on LDVS (not tested VGA HDMI, sleep yet)
Audio: Realtek ALC670 - not working
WiFi: Atheros AR9285 - working
LAN: Realtek RTL8168/8111 - not tested
USB3.0: Renesas - not working
Firewire - not tested

STEP 1 Making system run
I've downloaded preinstalled Lion and restored image to the 2nd partition of my HDD (you may make USB installer I think with the same params/kexts);
To run system you need GraphicsEnabler=No (with some bootloaders you also need AtiConfig=Ipomoea but framebuffer doesnt matters now) parameter for your Chameleon/Chimera bootloader and some kexts:
AppleACPIPlatform, AppleACPIPS2Nub, ApplePS2Controller, FakeSMC, NullCPUPowerManagement (attached).

STEP 2 Make your video work
2.1 After you can get into system install latest Clover bootloader to USB stick (FAT32 formatted)
NOTE: Clover don't use Extra/Extensions so copy kexts to S/L/E folder
2.2 Edit your config.plist (my is attached) with EDID and Framebuffers data (there is more information over inet)
2.3 Boot from flash (Note: my clover starts only after PC turned off, not restart) and start Lion
Now we should have video on LVDS

STEP 3 Devices
3.1 WiFi - my wifi adaptor has ID 002b:168c and I've just added my ID to IO80211Family.kext
Add your ID to file: IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/Info.plist
<key>IONameMatch</key>
- <array>
.......
<string>pci168c,2b</string>
</array>
3.2 Battery - AppleACPIPlatform.kext and AppleACPIBatteryManager.kext (attached)

Thats all for the moment
Next step is sound (VoodooHDA hangs system from time to time).
I will post when smth will be done.

Attachments (kexts and config for Clover): Attached File  ACER 5950G.zip   666.09KB   6 downloads

At first topic looked like:

What was done:
Tried to install from USB with no luck (Still waiting for root device)
So copied preinstalled Lion to HD partition

It runs with AtiConfig=Hoolock string but have some problems:

1) Displays only on VGA port (internal display don't work)
2) Trackpad, USB Mouse, USB Flash don't work
3) Keybord seems to work partially (for example F12 works, Power btn works, but combination Ctrl(Win)+N don't work)

Help to resolve USB than I could do smth with video...



#2
diginix

diginix

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Now I removed some kexts and USB start working

#3
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,653 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

the ati don't work , only intel hd 3000 so read about how to enable it

good hack

#4
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,944 posts
  • Gender:Male
Unless you really want to work with an external monitor (desktop replacement). Otherwise, you can start by disabling the ATI card in the BIOS if you can.

All the best!

#5
diginix

diginix

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
For the moment system boots every time, but there is no output on main LCD display.
VGA output - ok
HDMI output - ok
I have edited ATI6000Controller kext, but it did't help

So I have 2 thoughts:
1) I need to change smth with ATI kexts
2) Need to inject internal monitor, but can't find how to get EDID from Windows (all links I've found are broken)

Have some ideas?

#6
diginix

diginix

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Ok. I think that problem is of bootloader, I'm using. It is R2050
In ati.c http://forge.voodoop...6/libsaio/ati.c
there is no my card id's (Should be 0x6741, 0x050b1025)
I Cant update bootloader, because it panics when boot with CPUPowerManagement...
After update I changed boot file with old one and situation is the same.

In R2187 (I can't boot with) there is no device too. But i can't compile bootloader. Can Someone help me with panic and device inject?

#7
diginix

diginix

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Yeah!!! Video now is working. I've spend 4 days to make it work, so now I intend to post information about how to install "Lion on Acer 5950G Laptop progress".
Maybe admins shoud rename this topic? thanks.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy