Jump to content

AppleIntelHDGraphicsFB fixed (SL 10.6.8)


  • Please log in to reply
272 replies to this topic

#81
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

I got the same one.


Yes, but you have i3-380M cpu. Now I have the appleintelhdgraphics.kext loaded and my res is 1366x768x32. Try to use my res module customized by RemC and the appleintelhdgraphics.kext from this post:

http://www.insanelym...el-hd-graphics/

It's the Mountain Lion DP2 and not the Mountain Lion 10.8.2 kext.

Cheers

Attached File  hdgraphics.tiff   65.46KB   35 downloads
Attached File  Resolution.dylib.zip   9.57KB   19 downloads

#82
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
@ calmesal and lorius89. You have LVDS panel.

Pentothal

#83
lorius89

lorius89

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:milan
Thank you Pentothal, I've a problem, when I install all kext and boot my computer wont start, only if boot in safe mode i can access using vnc in my other pc, but if i boot without safe mode it stop work and cannot access in any way.
Have you or someone else any idea?
Thanks in advance.

#84
white_eagle

white_eagle

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Macedonia

@ calmesal and lorius89. You have LVDS panel.

Pentothal

Have I made a mistake in my post by saying I have eDP? I'm suspecting I might have LVDS panel like the others here. Here's the reg dump: http://pastebin.ca/2331108

Meanwhile I'm rebooting, I've now removed the FB kext and use only your resolution.dylib & the HD kext

Wish me luck!

#85
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
Good Luck!

P.S. I have graphics enabler set to yes in chameleon and graphics mode set to 1366x768x32

#86
lorius89

lorius89

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:milan

Have I made a mistake in my post by saying I have eDP? I'm suspecting I might have LVDS panel like the others here. Here's the reg dump: http://pastebin.ca/2331108

Meanwhile I'm rebooting, I've now removed the FB kext and use only your resolution.dylib & the HD kext

Wish me luck!

what is the HD kext you mean?

#87
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Thank you Pentothal, I've a problem, when I install all kext and boot my computer wont start, only if boot in safe mode i can access using vnc in my other pc, but if i boot without safe mode it stop work and cannot access in any way.
Have you or someone else any idea?
Thanks in advance.


Not sure how to help you. Do you have native resolution and Core Image working? If you don't follow this post:
http://www.insanelym...el-hd-graphics/

Cheers
Pentothal

#88
white_eagle

white_eagle

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Macedonia

Good Luck!

P.S. I have graphics enabler set to yes in chameleon and graphics mode set to 1366x768x32

Here's what happens, I have successfully booted and kext wizard says AppleIntelHDGraphics (8.1.0) is loaded (since that's the only kext I put in), but I have now lost the resolution (currently am on 1024x768). The difference is this time system preferences states that my graphics card has 128 MBs of memory (see the screenshots).

I am now going to restore ONLY my resolution.dylib to see what happens. I will not restore any other kexts until later.

oops forgot the screenshots

Attached File  Screen Shot 2013-03-12 at 6.45.39 PM.png   104.48KB   52 downloads

Attached File  Screen Shot 2013-03-12 at 6.46.35 PM.png   101.27KB   52 downloads

what is the HD kext you mean?

the appleintelhdgraphics.kext

#89
lorius89

lorius89

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:milan

Not sure how to help you. Do you have native resolution and Core Image working? If you don't follow this post:
http://www.insanelym...el-hd-graphics/

Cheers
Pentothal

Yes I've CI and the correct resolution..

#90
white_eagle

white_eagle

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Macedonia
Okay, so booting with MY Resolution.dylib and the appleintelhdgraphics.kext returned a kernel panic. What I am going to do now is re-use Pentothal's resolution.dylib and load all the other intel kexts, then if it isn't working I will try some combinations of them, and hopefuly it will work. Wish me luck! :)

#91
lorius89

lorius89

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:milan

Okay, so booting with MY Resolution.dylib and the appleintelhdgraphics.kext returned a kernel panic. What I am going to do now is re-use Pentothal's resolution.dylib and load all the other intel kexts, then if it isn't working I will try some combinations of them, and hopefuly it will work. Wish me luck! :)

Good Luck :) I'm in your same situation!

#92
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Okay, so booting with MY Resolution.dylib and the appleintelhdgraphics.kext returned a kernel panic. What I am going to do now is re-use Pentothal's resolution.dylib and load all the other intel kexts, then if it isn't working I will try some combinations of them, and hopefuly it will work. Wish me luck! :)


Remember to set parameters in chameleon Graphics Enables yes, graphics mode 1366x768x32

#93
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 667 posts
  • Gender:Male
  • Location:Italy
I'm sorry, but have you (pentothal, lorius and white_angle) installed Natit.kext? It contains lots of values for the graphics card

#94
lorius89

lorius89

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:milan
yes giofrida I tried all of natit.kext but I cannot get QE
I see that when I install boot intelHd and FB my fb is not loaded

Edited by lorius89, 12 March 2013 - 06:38 PM.


#95
white_eagle

white_eagle

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Macedonia

I'm sorry, but have you (pentothal, lorius and white_angle) installed Natit.kext? It contains lots of values for the graphics card

I do use Natit.kext

Anyways

This operation was a no go :(

I either got black screens or kernel panics when I used any kext in combination with Pentothal's Resolution.dylib.

I am getting frustrated that I am not at least even getting CI support so I'd be able to watch videos (though I suspect during one installation I was able to watch a youtube video without glitches but didn't really pay attention to it at the time - I may have borked something up afterwards - I curse myself for having to do something else at that moment), let alone QE support!

I have attached the Resolution.dylib I use currently as it may help some other folks to at least get their resolutions right.

This will probably make me backup most of the kexts that work for me (except the video kexts) and do a completely fresh new installation the following days. I am currently using iAtkos ML2 (though the initial installation was without any drivers, so I supposed it was like a vanilla installation) and will look into completely other methods (any suggestions?).

Then I will look into following the guide http://www.insanelym...el-hd-graphics/ completely as it is without any other modifications and report back in the following days.

Thanks a lot guys.

Attached Files



#96
white_eagle

white_eagle

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Macedonia
UPDATE: It seems I was able to somehow get (partial?) CI support because I am able to play flash videos without skips (which wasn't possible before even though I had the same kext loaded). I repeat, I can play youtube but do not have QE support.

OpenGL says I'm using Apple's software renderer so I don't know what happened here. Any hints?

Attached Files



#97
warraisraw

warraisraw

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
Someone has resolved sleep and brightness control issues?
I enabled the slider but without changes of brightness in screen...

Regards

#98
calmesal

calmesal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts

OK, here they are, for Mountain Lion.

pentothal: use the SingleLink version.


Hi Verteks!
I blive is something wrong withe this zip file. When I download it and extrakted, I am getting as single file and not as kext package. If I add a .kext extension I still cant open it like right click show package contents. Can you please explane it what is wrong?
Thanks.

#99
iWin32

iWin32

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male

Hi Verteks!
I blive is something wrong withe this zip file. When I download it and extrakted, I am getting as single file and not as kext package. If I add a .kext extension I still cant open it like right click show package contents. Can you please explane it what is wrong?
Thanks.

Nothing is wrong. Here's what you need to do:
First, copy OS X 10.8.2's version of AppleIntelHDGraphicsFB.kext over to your desktop. Right click that, and click Show Package Contents. In there, locate Contents -> MacOS -> AppleIntelHDGraphicsFB. Delete that file and empty the trash. Copy over in that directory the unzipped file you downloaded. Rename it so it exactly reads "AppleIntelHDGraphicsFB" (without the quotes). This will modify the kext to enable it to run the patched code. Finally, use Kext Wizard or Kext Utility to install the new, modified version of the kext to /System/Library/Extensions. I hope this helps!
... rea .

#100
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 401 posts
  • Gender:Male

Someone has resolved sleep and brightness control issues?
I enabled the slider but without changes of brightness in screen...

Regards


This is more of a DSDT issue. I don't think we ever needed QE/CI to make it go to sleep and wake up. However we still get a black screen when waking up. As for the brightness, I'm not sure why but if I press FN+Brightness Up/Down keys, it does change brightness. I don't get a little sun icon popup on OS X though.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy