Jump to content

[GUIDE] ML on HP Envy 17-3200 CTO

* * * * * 2 votes

  • Please log in to reply
126 replies to this topic

#21
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California

the DVD player if you insert a disk sometimes sees him at times no!
As I have a hd 3000 video card + a 6850M.
For the battery I tried more kext always with negative results.


Have you updated to 10.8.3? I just installed ML onto a new partition and the battery didn't work until I had updated to 10.8.3 and had repaired permissions.

After I changed the resolution and removed the key/string. It still gives me the same buggy screen. What else could prohibit the graphics kexts from loading?

EDIT:

OK I'll remove the drop line next

EDIT:

I removed the Drop SSDT lines and I got...a kernal panic: http://d.pr/i/oap0

and here's the org.chameleon.Boot.plist that possibly gave the panic:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1600x900x32</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>-f</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>SSDT</key>
<string>Extra/ssdt.aml</string>
<key>SystemType</key>
<string>2</string>
<key>Theme</key>
<string>LoginToLion</string>
<key>busratio</key>
<string>30</string>
</dict>
</plist>


You said you removed the SSDT but you show it in that boot.plist as being in you Extra folder. If you took out of that folder and aren't using it, you shouldn't have it in your boot.plist.

#22
Rufus Sweetwater

Rufus Sweetwater

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:United States

You said you removed the SSDT but you show it in that boot.plist as being in you Extra folder. If you took out of that folder and aren't using it, you shouldn't have it in your boot.plist.


sorry, in the updated boot.plist I do not have it listed and I get the same KP.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1600x900x32</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>-f</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>SystemType</key>
<string>2</string>
<key>Theme</key>
<string>LoginToLion</string>
<key>busratio</key>
<string>30</string>
</dict>
</plist>

it seems to only KP when I remove the DropSSDT string, and when I add it back it goes back to the fuzzy screen. I have also tried the "Graphics" & "GraphicsEnabler=No & Yes" boot commands and it still KPs or Fuzzy Screens... :(

#23
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California
You didn't have any KP before you removed the SSDT.aml. Maybe you should put that back and put in the references to it in the boot.plist.

#24
Rufus Sweetwater

Rufus Sweetwater

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:United States

You didn't have any KP before you removed the SSDT.aml. Maybe you should put that back and put in the references to it in the boot.plist.


I added back the SSDT.aml into the Extra Folder and here's my boot.plist now:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1600x900x32</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>-f</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>SSDT</key>
<string>Extra/ssdt.aml</string>
<key>SystemType</key>
<string>2</string>
<key>Theme</key>
<string>LoginToLion</string>
<key>busratio</key>
<string>30</string>
</dict>
</plist>

Should I even add back the DropSSDT key/string as well?

RESULT:

I went ahead with the boot.plist above and added the SSDT.aml in the "extra" folder and I got a new KP: http://d.pr/i/WK1e

#25
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California

I added back the SSDT.aml into the Extra Folder and here's my boot.plist now:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1600x900x32</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>-f</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>SSDT</key>
<string>Extra/ssdt.aml</string>
<key>SystemType</key>
<string>2</string>
<key>Theme</key>
<string>LoginToLion</string>
<key>busratio</key>
<string>30</string>
</dict>
</plist>

Should I even add back the DropSSDT key/string as well?

RESULT:

I went ahead with the boot.plist above and added the SSDT.aml in the "extra" folder and I got a new KP: http://d.pr/i/WK1e


Yeah, wrong SSDT for your system.

#26
Rufus Sweetwater

Rufus Sweetwater

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:United States
Well I'm currently using a VMware version of Lion to get all this done... Is there another way to create my dsdt and ssdt files?

#27
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California

Well I'm currently using a VMware version of Lion to get all this done... Is there another way to create my dsdt and ssdt files?


Sure, you can get them in Windows. I've used Aida64 for that.

#28
jrccomputer

jrccomputer

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Minneapolis, MN
  • Interests:Computers, Programming, Cars, And Dogs.
Does this guide still work?? I have a hp envy 17 3277nr.

#29
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California

Sure, give it a try.  You may need to make some modifications since we have different models but, basically, it should work.



#30
jrccomputer

jrccomputer

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Minneapolis, MN
  • Interests:Computers, Programming, Cars, And Dogs.
What modifications need to be made??;)

#31
amjsez

amjsez

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hi, alll.

I have Niresh ML 10.8 installed on my HP Envy17 3077nr. It boot up with cpus=1, but all my USB Port are not working. The 3.0 have current only and the 2.0 do not respond at all. Furthermore my trackpad can scroll but no click or tap...Can anyone help please??



#32
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California

For cpus=1, you can try NullCPUPowermanagement.kext, but the real solution is to use the CPU patch module in Chameleon (it's also in Clover) and to select the right SMBios for your laptop.  Mine gets native speed stepping using the MacBookPro8,3.  Your's may be different.  

 

For USB, you need to modify the AppleXHCI plugin in IOUSBFamily.kext to put your USB's product and vendor IDs into the Info.plist. If you are using a different USB3 kext, remove it.

 

For clickpad, use Rehabman's modified voodoops2controller.kext.  You can find it here:  https://code.google..../downloads/list

 

Good luck



#33
amjsez

amjsez

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Thanks, 

Rehabman voodoops2controller.kext worked for my trackpad and clicking.

The Universal USB3.0 kext from mutli beast worked. But my usb2.0 is still not working.

I still have to use cpus=1 as NullPowermanagemnt.kext does not work and there's no MacbookPro 8.3 from #####.



#34
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California


Thanks, 

Rehabman voodoops2controller.kext worked for my trackpad and clicking.

The Universal USB3.0 kext from mutli beast worked. But my usb2.0 is still not working.

I still have to use cpus=1 as NullPowermanagemnt.kext does not work and there's no MacbookPro 8.3 from #####.!

 

#####!?! Are you serious?  If you want to learn about OS X, try my tutorial and make your own custom installation.  If you want to use crapware, stick with ##### and see if you have any better luck over at the Tonymacx86 website.  I can't help you with your ##### installation.



#35
mimose0815

mimose0815

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Hannover, Germany

Hi, first of all I will say thx 4 this great guide. Will it works on a Envy 17 2080ez?

 

greetz from Germany



#36
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male

Hi, first of all I will say thx 4 this great guide. Will it works on a Envy 17 2080ez?

 

greetz from Germany

Please put your relevant hardware in your signature, like many others have done this.

 

Have a look at Pandora in Downloads. Pandora guides you with tips during install.

 

If you have time,  you can also read this: http://www.insanelym...-for-beginners/

 

You should try the install in any case.

 

Have fun.



#37
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California

Hi, first of all I will say thx 4 this great guide. Will it works on a Envy 17 2080ez?

 

greetz from Germany

 

Wie gehts mimose0815! 

 

You should be able to install ML on your HP Envy but you have the second generation version and mine is the third generation.  I think you have the Sandy Bridge and HD3000 while I have the Ivy Bridge and the HD4000.  Therefore, there will be differences in the kexts and settings we use.  PLEASE disregard what styrian posted above - I do not recommend that you use PandoraBeast.  It will take away the learning element from your installation.  You should learn what makes ML work on your laptop and why.  I am glad to help you as best as I can.  Please start out with the package of kexts I have provided.  From there, you will likely need to make modifications from what I provided.  There is nothing so exciting as getting your laptop to run ML well without using a pre-made installer app.

 

Viel Gluck!



#38
mimose0815

mimose0815

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Hannover, Germany

Hi again

 

Can u plz reupload the Files, because there is nothing to download.

 

Thx



#39
mimose0815

mimose0815

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Hannover, Germany

HI it's me again. Now I finished the ML-Installation Stick. I Removed the two DSTS-files like you wrote, but at the boot-process, before the setup starts, the system still freeze. Is it recommend to built my own post-installation files or does it work without them. And you were right it's a sandy-bridge, but i thik i got a intel-hd 4000. What kind of information do you need?

 

Thanks for your help.



#40
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Location:Southern California

HI it's me again. Now I finished the ML-Installation Stick. I Removed the two DSTS-files like you wrote, but at the boot-process, before the setup starts, the system still freeze. Is it recommend to built my own post-installation files or does it work without them. And you were right it's a sandy-bridge, but i thik i got a intel-hd 4000. What kind of information do you need?

 

Thanks for your help.

 

I am assuming that this is your hardware configuration: 

 

Attached File  Untitled.png   100.36KB   1 downloads

 

If that's the case, there is a huge difference between our laptops but really only as to graphics.  HP disabled graphics switching in the BIOS so I can only use the onboard HD4000 GPU.  HP has disabled the onboard graphics on your laptop so you can only use the Radeon GPU (which has higher performance but uses up more battery power.)  You will have to look elsewhere on this board to figure out what you need to do to get your video working, but I can assure you that the Radeon version you have should work fine so long as you use either the Chameleon or Clover bootloaders.  Beside that, you will need to replace your wifi card with an Atheros wifi card.  That costs only about $10 USD on eBay. 

 

In order to see why your installation stick is freezing on boot up, please post a photo of your screen (boot in verbose mode -v).  It is likely due to the need to patch the kernel (which is the case for most HP laptops).  There is a module in Chameleon that does that for you, and you need to select that module when you install Chameleon on your installation stick.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy