Jump to content

[solved] SystemId, SMsystemid not working

chameleon systemid

  • Please log in to reply
2 replies to this topic

#1
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
Sorry if I posted this on wrong section, but I trying to change my system-id to get imessage working, and I found out that there is an option called "SystemId" for org.chameleon.boot.plist, to change the system id manually.

My system id now: 0000000000000000000000XXXXXXXXXX (XXXXXXXXX = my MAC address)

This looks odd with the many zeros, I thought that maybe this is the problem and this is the reason why imessage doesn't working for me.

I tried to make a "SystemId" key into my org.chameleon.boot.plist file and generated an own uuid and set that up, but my system-id stays the same with the zeros. It just ignores this setting...

I also tried "SMsystemid" in smbios.plist, but it's ignored too.

Anyone knows how to change the system-id value? Is it possible?
(I'm using chameleon 2181)

Edit: I changed the org.chameleon.boot.plist > "SystemId" from Windows (macdrive), and since then, I can change my systemid to anything. (from osx too)

#2
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,121 posts
  • Gender:Male
  • Location:Brazil
Chameleon's automatic System ID injection (and its manual override) doesn't work for everybody, it's a rare occurence but you're not the first person to report this issue.

Also apparently some PCs have their UUID set as all zeros from the factory. I don't know what Chameleon does with that. That might be the case with your PC, but that doesn't explain why you're not able to override it. Maybe a syntax error. Have you tried setting it both with - between the numbers and without?

Use this page to generate a random UUID for your override.

For future forum searchers I'll confirm here that the correct flag (like you say) is "SystemId" in org.chameleon.Boot.plist

SMsystemid doesn't seem to exist.

Another important thing to remember is that the "Hardware UUID" that you see in System Profiler is generated from the "System ID" you set, or the System ID Chameleon sets for you automatically. They are not and will never be identical:
http://www.insanelym...20#entry1359776

Make sure that all three files that make up the Chameleon boot loader (boot, boot1h, boot0/boot0md or whatever you use) are from the same version. Some "upgrade" Chameleon just by replacing /boot, but that is a bad idea.

Make sure your plist files aren't corrupt, that can cause all sorts of unpredictable behavior. Recreate them from scratch, you can use Library/Preferences/SystemConfiguration/com.apple.Boot.plist as a template.

#3
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
Thanks for the reply, I tried it with "-" between the numbers and tried without it, but it doesn't change. I checked everything multiple times already, and everything seems okay, but "SystemId" flag is just not working.
Is it need to be "string" if I set it like "<key>SystemId</key><string>UUIDNUMBER</string>", or it should be "number" or "data" maybe?

edit: I tried again the same thing as before, and now it works as should :|
But imessage still not working... so it didn't change anything...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy