Jump to content

Trying to install OSX on a Dell XPS 14 Ultrabook "still waiting for root device" error


  • Please log in to reply
30 replies to this topic

#21
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,468 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

if u use a usb install.. remove from the usb all appleintelhd*.kext

reboot again with

-f -v GraphicsEnabler=No

if u install, must read about enabling u intelhd4000

good hack

#22
djm20

djm20

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

hello

if u use a usb install.. remove from the usb all appleintelhd*.kext

reboot again with

-f -v GraphicsEnabler=No

if u install, must read about enabling u intelhd4000

good hack


Hello, and thank you for your response.
I tried what you suggested and im still receiving the same error.
one thing i did notice though, was that after it loaded all the files, it initialixed the nullcpupower kext, but i didnt see any line where it initialized the fakesmc kext. on other attempts, ive seen it load that kext but now it isnt and it is in S/L/E folder

#23
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,468 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello


try to use another version of fakesmc if don't load fakesmc never work, fakesmc is mandatory to run mac os x in a hack

if not work u must inject by device properties efi string the platform id for hd4000, in org.chameleon.boot

-f always to not read the caches

good hack

#24
djm20

djm20

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

hello


try to use another version of fakesmc if don't load fakesmc never work, fakesmc is mandatory to run mac os x in a hack

if not work u must inject by device properties efi string the platform id for hd4000, in org.chameleon.boot

-f always to not read the caches

good hack


I've tried 3 different FakeSMC kexts and neither of them seem to load when i read the script when running in -v -f GraphicsEnabler=No. I added IntelCPUMonitor kext and that one loads fine.i don't know why its not initialising fakesmc

#25
djm20

djm20

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
can anyone point to a good fake smc that worked for their dell laptop?

#26
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
This is one of the few that worked.

Attached Files



#27
djm20

djm20

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
ok, i dropped this project a while back but i dont like to quit so im back to give it another try.
I never deleted my install usb i made a while back so i tried the fakesmc kext thats posted above and now i actually see a line where it says it was initialized
but i am still getting the "still waiting for root device" error

I tried various boot flags and no luck.
it gets stuck after it prints out the line that says com.AppleCompressionTypeZlib load succeeded or something like that
if anyone has had any success with this laptop, please reply and inform me what i am doing wrong or how you did it.thank you

#28
djm20

djm20

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
i just attempted the myhack method and still gets stuck at that same spot and displays "still waiting for root device"

#29
kvonlinee

kvonlinee

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
you can try this way it work for me.
you can partition one small boot like 8 Gb for boot from window, and one for OSX like 30Gb on the same hard drive of a laptop. then take that laptop hard drive and you can connect it via USB enclosure to a working "mac". you would use disk utility to erase the 2 new partition to "mac os extended" journal, then myhack installer to that 8 Gb,
when done you need you can swap it back to you laptop and boot with PciRoot=1.

that is my case. Same hard drive for boot install and run OSX on a laptop.

#30
djm20

djm20

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

you can try this way it work for me.
you can partition one small boot like 8 Gb for boot from window, and one for OSX like 30Gb on the same hard drive of a laptop. then take that laptop hard drive and you can connect it via USB enclosure to a working "mac". you would use disk utility to erase the 2 new partition to "mac os extended" journal, then myhack installer to that 8 Gb,
when done you need you can swap it back to you laptop and boot with PciRoot=1.

that is my case. Same hard drive for boot install and run OSX on a laptop.


the problem isnt about making the install usb, its about initializing the installer.

#31
kvonlinee

kvonlinee

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
yes to initializing the installer that is its work, why, I don't know from deep info, because I try many way and that is worked, you don't have to follow what is that advice but it is not harm to try, and if it is successful who earn the benefit.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy