Jump to content

Keyboard and mouse don’t work during Mountain Lion installation, i need your knowledge

mouse keyboard usb installation myhack

  • Please log in to reply
5 replies to this topic

#1
flowflowz

flowflowz

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hello guys,
Sorry for my bad English.
I need your help to solve this problem:

I can’t move my mouse and my keyboard don’t work on installation screen of Mountain Lion 10.8.2

This is my config :

• Gigabyte P55-UD3L (AHCI and HPET64bits configured bios)
• CPU I5-760
• ATI4830 or NVIDIA GTX450 (I can swich)
• USB mouse
• I have a USB keyboard and a PS2 keyboard (I can swich too)

I have a fully working (sound, Ethernet, video, keyboard and mouse) snow leopard OS on my 500GB western digital hard drive.
I tried to install mountain Lion with ######, with legacy USB option, but I’ve got the grey screen freezed. With –v I cannot see the last line before the Pc (hackintosh) reboot…
So I tried with MyHack. And it worked with ATI4830 without any boot command I can go until this screen http://www.cachem.fr...s-x-10.8-pc.jpg
I cannot move my Mouse and keyboard

Before asking for your help I tried by myself to do this :

• Putting the GTX450 but I have the Grey Freezed screen and as far i can the installation screen with the ATI card I think its not a PCI card problem. The GTX450 is brand new and fully working on windows8.
• I tried with the PS2 keyboard-> nothing changes
• I tried –x -> nothing changes
• PCIRootUID=1 -> nothing changes
• GraphicsEnabler=No -> nothing changes
• Cpus=1 -> nothing changes
• USBBusFIX -> I can’t move my keyboard or mouse
• Turn Off Legacy USB in bios -> The USB KEY cannot boot, nothing happen
• I putted two kext in Extra folder of MyHack USB key hopping that it wil lunch this as drivers but othing more: IOUSBFamily.kext (but as my USB key is recognized it was ok) and VoodooPS2Controller.kext but nothing changes…
• I putted my P55-UD3L DSTD (renamed in DSTD.aml) in this folder and lunched it in the boot command DSTD=/Extra/DSTD.aml -> Grey Screen with the black centered spinning weel during hours…

Do you think buying an APPLE keybord would do something ?
If you have any solution even weird even difficult I will try.
If ti works you will have my eternal gratitude and the feel that you helped a man somewhere on earth.

Florian.



#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
Attached File  Voodoo Keyboard.zip   85.04KB   107 downloads


for your problem this is Graphics kexts NVDIA, delete all kexts NVDIA from USBInstaller and boot with -f -v , don't use DSDT from other Machine

#3
flowflowz

flowflowz

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Thank you very much for answering me.
Ok so i will
remove kexts NVIDIA from usb
add the kext files you gave me in the usb
boot with -f -v

I will try and let you know what happen

Florian.

#4
flowflowz

flowflowz

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Attached File  Voodoo Keyboard.zip   85.04KB   107 downloads


for your problem this is Graphics kexts NVDIA, delete all kexts NVDIA from USBInstaller and boot with -f -v , don't use DSDT from other Machine


Ok i did what i have to and the problem is still here :

there is my -v when PS2 keyboard plugged
http://www.freeimagehosting.net/5q368

-v with USB keyboard
http://www.freeimagehosting.net/rdtrr

If you have any other ideas... thank you

#5
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
this is a problem with graphics kext, delete all graphics kexts, NVDIA, ATI, INTEL, and use keyboard usb, boot with: -f -v npci=0x2000 cpus=1 USBBusFix=Yes don't use keyboard PS2

#6
flowflowz

flowflowz

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
YEAH !!!
i managed to do it ! i used ###### finally, NVIDIA and ATI drivers delted from USB, GraphicsEnabler=No -f with the ATI4830.
Then i had to install ########, kext and NVIDIA drivers to It was hard to Now i have to boot with VGA and plug my second screen in HDMI when i am on the desktop.
So it was not a USB problem but a graphic Problem, very weird since i could reach the installation screen.
Now i dont have sound, but it's an another problem in an another topic !!!
thank you very much for your help and for the time you take to answering me. you were right it was a graphic problem
Peace





Also tagged with one or more of these keywords: mouse, keyboard, usb, installation, myhack


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy