Jump to content

[Guida] Installazione Mountain Lion su AMD

Installazione Montain Lion 10.8 AMD

  • Please log in to reply
63 replies to this topic

#21
barrux

barrux

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Bene!! aspetto la guida :thumbsup_anim:

Bene!! aspetto la guida :thumbsup_anim:

#22
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma
Ho scritto la guida per AMD e postata nel primo post : http://www.insanelym...ion-108-su-amd/

carlo_67

#23
Alex//3oo1

Alex//3oo1

    Cheesecake Destroyer

  • Pandora Team
  • 11,629 posts
  • Gender:Male
  • Location:Lodi
ciao carlo,ottimo lavoro,complimenti
senti un moderatore o sposta la guida nella sezione Guide E Trucchi per PC Desktop,

ancora complimenti

a presto

#24
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 8,915 posts
  • Gender:Male
  • Location:Italy
Complimenti :)

Sposto nella sezione Guide e Trucchi pc Desktop

Aggiornato al primo post

Fabio

#25
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma
Grazie ragazzi
ho ancora qualche problema con il boot lento e la mia asus 5770 che sia in hdmi e dvi fa artefatti

ma almeno qui nella sezione italiana essendoci una guida
gli utenti AMD possono anche loro provare e migliorare il tutto

#26
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma
Aggiornamento 10.8.2 e aggiornamento 10.8.3 :trumpet:
Riusciti :thumbsup_anim:

#27
matteolel

matteolel

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Grazie per la guida! Anche con la mia hd 5750 ho lo stesso problema di artefatti.. :(

#28
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma
ciao matteolel

ho risolto il problema
scarica mlion dp 1
usa sempre la stessa guida
non mettere corecrypto metti solo atiata.kext in extra

kernel usa questo

avvio flag; arch=x86_64

Attached Files



#29
Gioele97

Gioele97

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Ei ciao ho provato la tua guida come suggerito ma una volta che tento di accedere a ML appena installato mi da un errore del tipo -O (qualcosa) can't find magic number, o qualcosa di simile, da cosa potrebbe essere causato?

Edito: sono stato un po' impulsivo nello scrivere :wallbash: é evidente che manca il fakesmc! Dovrei estrarre la cartella Extra e portarla sull'hd dove risiede ML perché ho la possibilità di accedere in scrittura da Windows sulla partizione del mac, solo che devo accendere hackintosh, che ricordo essere un netbook :angel_not: , copiare la cartella extra e sperare, ma tutto questo domani, poi posterò il risultato.

#30
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma
devi mettere il tuo hardware

al boot fai -v e posta qui la foto

hai rimesso il kernel dove hai istallato?

#31
Gioele97

Gioele97

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Il kernel é dentro nella partizione. Son sicuro al 99% che sia il fakesmc perché come detto nella guida da te devi poi rimettere la cartella extra cosa che non posso fare dato che non parte.
uso questi bootflags: busratio=20 (Essendo un processore FX ho dovuto cercare un kernel adatto, che funziona perché l'ho testato con Iatkos ML2) UseKernelCache=No GraphicsEnabler=No npci=0x2000 -v

E poi fa vedere un secondo delle scritte in cui c'é anche:
Mach-0 File Has Bad Magic Number

E poco dopo che ho postato mi son ricordato che c'era sto fakesmc che era indispensabile per avviare os x.
Probabilmente il mio hardware lo installerò con calma quando riuscirà almeno a partire. Ma cì guarderò meglio doma

#32
Gioele97

Gioele97

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Tutto funziona e come avevo intuito mancava proprio tutta la extra che ho importato da windows.
Rimane purtroppo quel bug maledetto della grafica, quando apri una nuova scheda in safari comincia a laggare tutto! e se installi i kext per le hd 7xxx presumo faccia come ha fatto con la distro ovvero artefatti. Sarà per via che la mia hd 7850 non é pienamente supportata.

#33
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma
se vuoi un consiglio per ora istalla il montai lino che ho in firma

Mountain Lion DP 1
e il kernel mach_kernel_ML_DP1_rc1
quella funge bene
c'è il kernel sia x phenom che x FX
scaricala e ti posto il kernel

fatti una copia del Ati7000Controller.kext prova ad istallarlo
dovrebbe andare la tua scheda video

usa sempre la guida e lo stesso procedimento

Attached Files



#34
Gioele97

Gioele97

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Perfetto Quando averò tempo ci provo

#35
VicVance

VicVance

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:Roma - Italia

Installato senza problemi sulla mia configurazione hardware ma purtroppo ho il problema degli artefatti visivi non appena ho messo i kext per la mia 5450 :(



#36
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma

prova ad aggiornare alla 10.8.3

e metti questo kernel

 

ricorda di rinominarlo come quello che togli


ha me ha migliorato molto

Attached Files



#37
charial

charial

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Ciao a tutti, ottima guida! Ho solo due domande:

 

 

 

(nb: l kext AtiAta solo per chi ha chipst ati, da sostituire con chipset consono alla vostra scheda

1) con una asus M5A78L con le due porte usb 3 e con un AMD-FX 4170 che kext devo usare?

 

2) So bene che non si può chiedere ma per quanto mi sforzi con google a ricercare il chameleon  Enoch 2164 non riesco a trovarlo da nessuna parte...



#38
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma

usa quello che tutto quello che ho postato dovrebbe andare con il tuo hardware


enoch

usa anche la ultima versione

Comunque che scheda video hai?

Montain Lion finora crea artefatti grafici



#39
charial

charial

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Ho una Ati Radeon 3000 incorporata nella motherboard.

 

Ho provato a fare la procedura

sostituito il mach_kernel con il kernel della amd (che ho chiamato mach_kernel)

da /System/Library/Extension ho eliminato i due kext come da guida

Ho spostato tutti i kext che c'erano della cartella da scaricare in /Extra

Ho avviato Kext Wizard è ho selezionato Mac OS X Base System e poi ho selezionare la 1,3,4 delle opzioni 

ho fatto il boot da USB configurando il firmware come SATA configuration "AHCI", Virtualizzation "Yes", Suspend Mode "S3", Legacy USB "Yes, mi è partito chameleon e ho fatto i flaq -v npci=0x2000

 

 

Mi da errore 

 

Memory Allocation Error! Addr:0xdeadbeef, Size 0x0, File Ati.c, Line 1584

This is a non recoverable error! System HALTED!

 

Dove ho sbagliato?



#40
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,094 posts
  • Gender:Male
  • Location:Roma

ADDIORNAMENTO GUIDA IN PRIMA PAGINA

 

Risolti problemi artefatti grafici aggiornando alla 10.8.5

con il nuovo kernel 

Bronya_mach_kernel







Also tagged with one or more of these keywords: Installazione, Montain Lion, 10.8, AMD


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy