Jump to content

GeForce 9600GT 512MB 0x0622


  • Please log in to reply
11 replies to this topic

#1
parcival39

parcival39

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
hi all,
need help with a 9600GT 0x0622 and Chameleon_2.1svn_r1820_trunk_10.8.
EFI string on org.chameleon.Boot.plist not work, also tested with NVDANV50Hal.kext from 10.7.0, but all this works on 10.7.3 (chameleon 2.0Rc5).
Also not help GraphicsEnabler -> Yes and edit info.plist on NVDANV50Hal.kext.
Nvidia kext loaded in MT-Lion, but only 1024 x 768 screen resolution and one screen.

any idea
thx
parcival

#2
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,880 posts
  • Gender:Male
  • Location:Stuttgart / Germany
I also have same 9600 GT 512MB, 0622.
No probs here with Lion + ML. No .plist (ID) adding in NV.kext needed,
I only need the chameleon Graphicsenabler = Yes. All native drivers, unpatched and no other NV injectors.
No EFI string .
I would check if you have any non native gpu injector.kext in /SL/E or /ETRA !
Go back to orig. NV.kext from 10.8 unsing KextWizard (install) -.
Repair volume rights. be sure to delete /System/Caches before reboot.

#3
parcival39

parcival39

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
Hi mitch_de,
Thanks for the fast answer.
Which version of Chameleon use you?

#4
Leon Hong

Leon Hong

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
The one screen problem of NV9600GT seemed to be driver-pending. In fact, only NVDA,display-B,1 is normally functional, while NVDA,display-A,0 is always reported as "not usable" in the system log.

I personally make 2 dsdts with different display-cfgs and NVCAPs to fully use my LVDS and VGA output independently on the NVDA,display-B,1 port, and use DSDT=/Extra/xxx.aml to manually select the desired display at the boot screen.

I really hope the codes of NVDAHal50.kext and NVDAResman.kext can be re-written by Apple to correct this problem . However, we will find out if they think it a problem when DP2 is out next month.

#5
ricola

ricola

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
My 9600GT 0622, works in 10.8 DP1 with GraphicsEnabler=Yes only.

#6
parcival39

parcival39

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
OK, which can i say is the following.

1) latest svn Chameleon Version with ML Support and original nvidia kext from ML
-GraphicsEnabler=Yes will not work only 5MB RAM, 1024x768, two Displays but all needed nvidia kext loaded.
-DSTD.aml with 9600GT, will work but choppy and flickr.
-org.com.apple.Boot.plist with efi string, does not work, because it is not loaded from Chameleon(?).

2) latest svn Chameleon Version with ML Support and nvidia kext from 10.7.0 or original NVIDIA
-GraphicsEnabler=Yes will not work only 5MB RAM, 1024x768, two Displays but all needed nvidia kext loaded.
-DSTD.aml with 9600GT, will work but a "little" choppy.
-org.com.apple.Boot.plist with efi string, does not work, because it is not loaded from Chameleon(?).

2) Chameleon RC5 752 Lion+Snow (work with ML) and nvidia original nvidia kext from ML
-GraphicsEnabler= Yes will work but choppy and flickr.
-DSTD.aml with 9600GT, but choppy and flickr.
-org.com.apple.Boot.plist with efi string, does not work, one second after login black Displays and no Signal.

3) Chameleon RC5 752 Lion+Snow (work with ML) nvidia next from 10.7.0 or original NVIDIA
-GraphicsEnabler = Yes will work but a "little" choppy.
-DSTD.aml with 9600GT, but a "little" choppy.
-org.com.apple.Boot.plist with efi string, does not work, one second after login black Displays and no Signal.

If i see this, the support for (this) 9600GT 0x0622 under ML (also 10.7.2(3)) is bad.
9600GT works fine under 10.7.3 with efi string (Chameleon 2.0Rc5, and 10.7.0 nvidia kext)

parcival

#7
xmath279

xmath279

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
AFAIK, the file replacing com.apple.Boot.plist is org.chameleon.Boot.plist

#8
Flashe

Flashe

    Flashy ~ Flasheu

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Location:93 Carats
Hi everyone,
My 9600 GT 0622, works in 10.8 DP1 with GraphicsEnabler=Yes only too,but QE/CI don't work for me and for you ?
I have try this app (lecteur DVD),the app crash.Because the QE/Ci don't work.



Posted Image

#9
everdone

everdone

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
The later versions of Chameleon (past 1000 or so) no longer recognize the com.apple.boot.plist. They use org.chameleon.boot.plist.

I have several 9600GT video cards and they all work using GraphicsEnabler=Yes for Chameleon versions later than around 700. I have since switched to 5770 ATI cards and they work the same Chameleon versions as do the 9600GT cards. I have just installed ML using Chameleon 1820 and the 5770 works with GraphisEnabler=Yes. I am sure the install would work with a 9600 card.

Note that if you expect to use any kexts from Extra/Extensions you must set KernelCache=No. If you set KernelCache=Yes Chameleon will ignore the Extensions folder. If you boot in verbose mode (-v) and set KernelCache=No there will be a long boot time as the boot process will be slow as it writes all loaded kexts to the screen. Not using verbose mode, boot time will only be slightly longer than when using the cache.

#10
ToroLoco

ToroLoco

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

OK, which can i say is the following.

1) latest svn Chameleon Version with ML Support and original nvidia kext from ML
-GraphicsEnabler=Yes will not work only 5MB RAM, 1024x768, two Displays but all needed nvidia kext loaded.
-DSTD.aml with 9600GT, will work but choppy and flickr.
-org.com.apple.Boot.plist with efi string, does not work, because it is not loaded from Chameleon(?).

2) latest svn Chameleon Version with ML Support and nvidia kext from 10.7.0 or original NVIDIA
-GraphicsEnabler=Yes will not work only 5MB RAM, 1024x768, two Displays but all needed nvidia kext loaded.
-DSTD.aml with 9600GT, will work but a "little" choppy.
-org.com.apple.Boot.plist with efi string, does not work, because it is not loaded from Chameleon(?).

2) Chameleon RC5 752 Lion+Snow (work with ML) and nvidia original nvidia kext from ML
-GraphicsEnabler= Yes will work but choppy and flickr.
-DSTD.aml with 9600GT, but choppy and flickr.
-org.com.apple.Boot.plist with efi string, does not work, one second after login black Displays and no Signal.

3) Chameleon RC5 752 Lion+Snow (work with ML) nvidia next from 10.7.0 or original NVIDIA
-GraphicsEnabler = Yes will work but a "little" choppy.
-DSTD.aml with 9600GT, but a "little" choppy.
-org.com.apple.Boot.plist with efi string, does not work, one second after login black Displays and no Signal.

If i see this, the support for (this) 9600GT 0x0622 under ML (also 10.7.2(3)) is bad.
9600GT works fine under 10.7.3 with efi string (Chameleon 2.0Rc5, and 10.7.0 nvidia kext)

parcival


It's been quite a long time that you have made this post but I am facing a similar problem with 10.8.0 official installation.

I have installed perfectly 10.8.0 on my Asus P5K-E / Wifi, but at the beginning I had a black screen during the start up process with my 9600 Gt 512Mb. After many changes I injected the Dev ID to NVDAHa50.kext and had access to the desktop, but only with 1028 x 768 and 5Mb ram.

Then yesterday I updated chameleon and have full resolution, but very flicky graphics.

Do you have any result with your installation?

#11
xyu_v_palto

xyu_v_palto

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
I got everything working with DSDT, but it starts up normally only half time - anothe half i get white screen with black mouse on it and nothing more. I used DSDT part from here http://macpronet.ru/...0gt-512-mb.html (it's in Russian, but you need only dsdt code ;))

Any ideas how to fix it?

#12
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,880 posts
  • Gender:Male
  • Location:Stuttgart / Germany
i think something went wrong patching some of the nvidia drivers (adding dev id 0622) and or using some prepatched nvidia drivers or you have some other nvidia / gpu injectors left in /extra or /S/LE which sould not used.

The orig. Nvidia drivers know 0622 dev id (by their dev id masc for 0620) so you must NOT patch any nvidia drivers!
Also chameleon works to inject right QE/CI working.

I would go back to vanilla ML (only patch that kext you really need to patch like AppleHDA+RTC) and use Combo Update 10.8.2 to get nvidia drivers again vanilla.
Recheck if you forgot to delete any other gpu related .kext which is not from apple.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy