Jump to content

[Guide] Getting XFX HD6850 connectors to work

ati hd6850 6850

  • Please log in to reply
110 replies to this topic

#101
MontMac

MontMac

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

That's awesome you got it to work. It would be even more awesome if you uploaded your ATI6000 Kext so others could benefit too.


I would have but never figured out how to upload the kext. I have sold the ATI card anyhow and installed the Zotac Nvidia GT640 Silent graphics card. Works OOB without any drivers or hacks. I am using FCP and handbrake without issue. Works great!

#102
MikBe

MikBe

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

I would have but never figured out how to upload the kext. I have sold the ATI card anyhow and installed the Zotac Nvidia GT640 Silent graphics card. Works OOB without any drivers or hacks. I am using FCP and handbrake without issue. Works great!


Bummer. I've been trying to get mine to work with all the ports with no luck. Guess it's time to post and ask for help.

#103
sollarman

sollarman

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Yalta
Here is the one, patched for ASUS EAH Radeon 6850 for 10.8.3 in case if you need it.

https://dl.dropbox.c...kext_10.8.3.zip

#104
hawk2212

hawk2212

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Here is the one, patched for ASUS EAH Radeon 6850 for 10.8.3 in case if you need it.

https://dl.dropbox.c...kext_10.8.3.zip


Can you make one for Gigabyte HD6850 compatible with 10.8.3?

Here is my bios dump
https://www.dropbox....a58vm/Barts.rom

#105
sollarman

sollarman

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Yalta

Can you make one for Gigabyte HD6850 compatible with 10.8.3?

Here is my bios dump
https://www.dropbox....a58vm/Barts.rom



Sorry, it involves a lot of testing and tweaking. Can't do that without the card. Its not that hard to do, lots of tutorials over here on insanely.

#106
fffeee

fffeee

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
10.8.3 has made a pretty big dent in my extra days off from a vacation — anyone else having some problems with edits to the kexts? My 10.8.2 bundle didn't work as expected on 10.8.3, and doing edits to the 10.8.3 bundle(s) have resulted in some odd hotplug/port behavior.

I'm presently limping along with using DVI-D and DVI-S but DVI-S won't become active unless I plug in an HDMI cable, so I think I know where the problem is but my combinations of trans/plug/port haven't come up with a magic combo yet.

#107
PoisonDrop

PoisonDrop

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Just an update, if not for anyone else, then just for the sake of remembering how I got this working again!

As of 10.8.4, my Gigabyte 6850 OC works OOB, including triple monitors with an active adapter. The only issue is the framebuffer selection. This card requires Duckweed (and AtiPorts=4). Currently, it appears that the Duckweed personality needs NO editing to run this card.

I have found that framebuffer selection varies depending on which bootloader is used. I am using Chameleon r2069 now and I have to manually set it to Duckweed. Previous Chameleon versions selected Duckweed on their own. I don't mess around with my OS drive that often, so when this issue popped up, it had me stumped for a bit. Hopefully I will remember to re-read this post down the line and save myself a few headaches during the next clean install...

#108
Jedi

Jedi

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

Hey guys. I have the exact same hardware as Alex and was wondering if this guide would also apply to modifying the updated kexts in 10.7.5, 10.8.5 etc. Or has Alex posted updated kexts somewhere?



#109
hugeschnauzer

hugeschnauzer

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts

Hi Guys.

 

I've installed my 7970 adding rampaged code to my DSDT + Sleeptrick at startup.

 

I guess im missing the frame buffer install inside AMD7000Controller.kext

Is that necessary? Im getting 41fps at Cinebench 11.5

 

The steps are a little bit confusing for me:

 

http://rampagedev.wo...er-personality/

 

Tks!!

 

Rodrigo



#110
OSXGuy

OSXGuy

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Santa Clarita, CA
  • Interests:Computer Networking Systems and Computer Technology

I NEED DRIVERS FOR IT! I have a HIS 6850 Fan 1GB GDDR5 PCI-E HDMI/2xDVI/DP Specifications for it are as follows

spacer.gifModel Name HIS 6850 Fan 1GB GDDR5 PCI-E HDMI/2xDVI/DP spacer.gifChipset Radeon HD 6850 PCIe Series spacer.gifASIC RadeonTM HD 6850 GPU spacer.gifManu. Process (Micron) 40nm spacer.gifMemory Size (MB) 1024 spacer.gifMemory Type GDDR5 spacer.gifEngine CLK (MHz) 775Mhz spacer.gifMemory CLK (Gbps) 4Gbps spacer.gifMemory Interface (bit) 256 spacer.gifPower Supply Requirement 500 Watt or greater power spacer.gifMax. Resolution 2560*1600 spacer.gifBus Interface PCI Express x16 spacer.gifDisplay Port Yes spacer.gifHDMI Yes spacer.gifDVI Upper Single-link DVI-D + Bottom Dual-link DVI-I spacer.gifVGA No

HD 6850 System Requirement

  • PCI Express ® based PC is required with one X16 lane graphics slot with 2 slots space available on the motherboard
  • 500 Watt or greater power supply recommended
  • Certified power supplies are recommended. Refer to http://ati.amd.com/certifiedPSU for a list of Certified products
  • Minimum 1GB of system memory
  • Installation software requires CD-ROM or DVD-ROM drive, a keyboard, a mouse, and a display
  • DVD playback requires DVD drive and a DVD
  • Blu-ray™ playback requires Blu-ray drive and a Blu-ray disc
  • For an AMD CrossFireX™ system, a second AMD Radeon™ HD 6800 Series Graphics card, an AMD CrossFireX™ Ready motherboard and one AMD CrossFireX™ Bridge Interconnect cable is required

 

Please help get DRIVERS for this card.



#111
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 421 posts
  • Gender:Male
  • Location:Austria

Okey, so I had my card working perfectly in Lion and Mountain Lion. It's still working under Mavericks and Yosemite, but gives me a major problem:

 

With RadeonFramebuffer it works with Full Res but obviously there is no acceleration

But when I enable patched driver (Same hexed patch as before) I don't get any signal on VGA. What can I do?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy