Jump to content

[GUIDE] Lion 10.7 on Asus X58 (LGA 1366) i7 9xx

Lionize ASUS X58 LGA1366

  • Please log in to reply
865 replies to this topic

#681
vonmolk

vonmolk

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Sorry guys... but I'm really busy! ML AppleHDA for AD2000b --> #70 Enjoy

Hi ErmaC,

I know you are busy, but when you have a moment could you please let me know why when I edit the HDEF per your instructions the line changes to
"layout-id",
Unicode ("c"),
after I compile and save the dsdt?

#682
cressi65

cressi65

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Ciao a tutti scusate la mia ignoranza sono nuovo.. Ho seguito tutta la procedura fino a quando non mi dice processo completato .premesso che ho una rampage III extreme i7 950 nvidia 460 e mentre crea la USB riconosce tutto. Arrivato al passaggio 6 se non ho capito male dopo che mi dice processo completato riavvio il pc da USB e mi vede la penna e l hd faccio partire la penna e alla schermata della mela si blocca e non va più avanti... Dove sbaglio ? Grazie di eventuali consigli.

#683
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

Hi ErmaC,

I know you are busy, but when you have a moment could you please let me know why when I edit the HDEF per your instructions the line changes to
"layout-id",
Unicode ("c"),
after I compile and save the dsdt?

Maybe didn't edit properly. I have different audio, but would think This:
"layout-id",
						    Buffer (0x04)
						    {
							    0x0C, 0x00, 0x00, 0x00
should be changed to this:
"layout-id",
						    Buffer (0x04)
						    {
							    0x63, 0x00, 0x00, 0x00


#684
maltba

maltba

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Hey guys,

Just wanted to share the outcomes of my work with you. got my rampage 2 extreme fully working !with! Audio.

Instructions:
1.Use the MLionize Script to make your boot medium.
2.Install(maybe you will need GraphicsEnabler=No)
3.don't run the finalize thing
4.start again with the usb stick
5.install chameleon: Chameleon-2.1svn-r2042.pkg.zip
**maybe you don't need this step**
6.make a new folder called Extra on the root of your installation hard drive
*******************************************
7.copy this into it:Attached File  DSDT.aml.zip   18.3KB   56 downloads
8.generate a smbios.plist place it in /Extra too(or just use the one from the usb stick)
9.generate a com.chameleon.boot.plist place it in /Extra too(or just use the one form the usb stick)
(Chameleon Wizard is a good tool for 8. & 9.)
For Audio
-Download this:Attached File  Kext Utility.zip   267.76KB   27 downloads
and this: ***wrong one look at the bottom****AD2000b-ML-10.8-AppleHDA.kext patch credits to ErmaC here post #70****

-Extract both and just drop the AppleHDA.kext at the Kext Utility App
make you you've installed the correct DSDT(the one from 7.)

-reboot and enjoy :)

proof:Attached File  Bildschirmfoto 2012-08-14 um 03.06.21.png   1.42MB   67 downloads

everything seems to work now. though i don't tested sleep yet. I'll report back when i've tested it. sleep works well.

maltba

edit:// who the {censored} changed the AD2000B kext? THIS IS THE WRONG ONE! this kext is missing the Info.plist at AppleHDA.kext/Contents/PlugIns/AppleHDAHardwareConfigDriver.kext/Contents/Info.plist! if you don't believe me check it yourself. i've fixed that problem. thats why its working for me -.-
here is the CORRECT File: http://freakshare.co...A.kext.zip.html
CREDITS GO to ErmaC! but i've fixed the kext he provided here: patch credits to ErmaC here post #70

#685
banini_jeque

banini_jeque

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
Finally got 10.8 installed on my P6T WS Pro. I seem to be able to boot with the vanilla AppleACPIPlatform, although it does take awhile, and verbose booting reveals that it is hanging on the vector error. After a minute or so it gets past it. Gonna try for sound next. Hopefully we can figure out exactly what in the DSDT needs to be fixed to get rid of the vector error. Sleep worked (took awhile to go to sleep), but after a wake I had a graphics glitch in Safari that froze the system. I have a GTX 460, so not sure if it's got bad vram or what. It does in it 10.7 sometimes too.

#686
artix123

artix123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
Hey maltba, I'm on R2E motherboard too. Just wondering how did you boot your ML without running finalize, after installation? My installation just doesn't boot if I don't run finalize, and if I do, my audio will be broken (even when I try to install your AppleHDA.kext over the old one).

Also having problems with dual-booting - Chameleon just doesn't boot even after I installed it. Might have something to do with my Mountain Lion partition being the 5th one..

#687
maltba

maltba

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
i've just took the installation stick and booted up the Mountain Lion Partition with it.I think your problem is dual booting related. are you on a mbr drive? if not try to unconnected all other drives beside the mac os x drive and then try booting up with the installation usb stick(just choose the Mountain Lion Partition when Chameleon appears) and if it boots then try reinstalling chameleon. also make sure you select the correct drive in bios boot orders.

for qe/ci - if its not working oob - check this here:
Attached File  QE_CI Exotic patch Mountain Lion GM.zip   1.63MB   12 downloads
just drag both kext files into the kext utility app. i have a radeon 4890.
to get the garbled gui at first i had to boot with GraphicsEnabler=No.

for the audio. make sure you install the kext with the Kext Utility app i've provided. Also make sure you've installed the DSDT.aml i've provided.Furthermore make sure you don't use that one they've inserted into my post. download this one:

http://freakshare.co...A.kext.zip.html
and install it with the Kext Utility App

if you can't follow my instructions just say it.if you want i can make a video for you,but i'm on vacation for a week first.also i could help you with team viewer or vnc if you want to.you write a pm and i'll gladly help you in a week.

hope this crappy english helps you.

maltba

#688
banini_jeque

banini_jeque

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
Alright, well, I got sound going on my P6T WS Pro now too. Still have really long boot times due mostly to the hang at the vector error. I'm puzzled why I just hang on the error, while other people completely KP from it. I'll just keep using it like this until someone figures out how to fix the WS Pro dsdt. I don't want to use the ACPI.kext rollback.

#689
artix123

artix123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

i've just took the installation stick and booted up the Mountain Lion Partition with it.I think your problem is dual booting related. are you on a mbr drive? if not try to unconnected all other drives beside the mac os x drive and then try booting up with the installation usb stick(just choose the Mountain Lion Partition when Chameleon appears) and if it boots then try reinstalling chameleon. also make sure you select the correct drive in bios boot orders.


I'm on GUID and I always only have 1 hard disk installed when I attempt an installation, I'm sure I booted up the correct partition (through the Chameleon on my Mountain-Lionized install stick), and I'll always get errors pertaining to SMC (if I don't run finalize), and booting freezes here:

Posted Image

I'm on 4870 and video works oob. :)

for the audio. make sure you install the kext with the Kext Utility app i've provided. Also make sure you've installed the DSDT.aml i've provided.Furthermore make sure you don't use that one they've inserted into my post. download this one:

http://freakshare.co...A.kext.zip.html
and install it with the Kext Utility App


Yep I'm using your file, I've installed DSDT.aml.

I think I need to figure out how to make my ML boot up without running finalize.
Did you select the options pertaining to making an ASUS X58 install when making the USB stick through Mountain-Lionize?

It's ok btw, I wanna try to figure it out too haha.

#690
barnum

barnum

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:france

Did anyone figure out what the exact issue with 10.7.4 is so we can use fixed DSDTs or patch our own instead of using patched kexts? I have the P6T ws pro, so I can't use the P6T se DSDT.

Hi,

Do you have find a 10.7.4 dsdt for p6t ws pro ?
I have this motherboard with a xeon e5540 and I have a kernel panic when I upgrade to 10.7.4

Regards,
Barnum

#691
banini_jeque

banini_jeque

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
Here's the DSDT I'm using right now. It has a CPU section for an i7 950 so if you have a different CPU you'll need to change that. I can't guarantee it will work on 10.7.4 because I haven't tested it with that, but it does let me boot into 10.8 without panicking, so I would imagine it will work. It does boot slowly though as it still hangs on the vector error that normally causes the panic for other people.

I also seem to have this other problem with mine where it cycles in and out of sleep. I'll put it to sleep, it stays asleep for a minute or so, then it wakes up except for the screens for 30 seconds (sleep walking?), then goes back to sleep again. If I click the mouse when it's "sleep walking" it will drop any USB connections and sometimes freeze, but if I wake it up when it's actually asleep, it's fine.

Attached Files



#692
RobLans

RobLans

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
ErmaC, the latest DSDT ‘P6T Deluxe (V1/V2/P6TD Deluxe) i7 950’ from posting #566 seems to be working on ASUS Rampage III Extreme with Intel Core i7-520 CPU.
Used Chameleon (svn-r2042). (nothing changed in DSDT except HDEF settings)

- Booting OSX 10.7.4 with origin 10.7.4 AppleACPIPlatform.kext, OK
- Boot time normal within 20 sec, OK
- Sleep/Wake functionality with patched AppleRTC (w/o sleepenabler), OK
- Autosleep, OK

BDMSG info w/o Generate P-states and C-states:
SSDT with CPU C-States generated successfully
P-States: min 0xc, max 0x16
SSDT with CPU P-States generated successfully
RSDT: Added 2 SSDT table(s)

Suppose it’s not the idea to have a General DSDT, but it seems to be working on RAMPAGE III Extreme at first sight ;)

#693
banini_jeque

banini_jeque

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
Damn maybe I'll try that one on my WS Pro!

Edit: Nope. I tried it, wouldn't boot. Didn't try verbose to see why yet though.

Edit #2: I also think I figured out what my sleep cycling issue is. I think it has to do with WOL. I know AT&T recently updated my router firmware, and now that I think of it, it started cycling a lot around the same time they said they were gonna do that. I'll have to test it when I get home.

#694
viitols

viitols

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
Everything works OK for a couple of days, but then I get Invalid Node Structure error on boot.
Restore everything and all is fine. After a while same thing happens again...

Any idea what might be causing this?
I'm running a Kingston SSD from SSDnow series and it seems to be fine.

Thanks!

#695
RobLans

RobLans

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Everything works OK for a couple of days, but then I get Invalid Node Structure error on boot. Restore everything and all is fine. After a while same thing happens again... Any idea what might be causing this? I'm running a Kingston SSD from SSDnow series and it seems to be fine. Thanks!


Viitols, try searching on google 'Invalid Node Structure' there is an article about on 'african-heart.blogspot.nl'.


You have a 'P6T Deluxe v2' your problem is not related to the consistency of the DSDT file :idea: good luck!!



#696
viitols

viitols

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
Thanks Rob,
I will try to run the comman next time it happens, however I'm more interested as to why this keeps happening over and over again?

#697
RobLans

RobLans

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Thanks Rob,
I will try to run the comman next time it happens, however I'm more interested as to why this keeps happening over and over again?



Well, I’m sorry to say, SSD drives (not all) are not as consistent as they seem. After a period of time, they often get corrupt due to poor quality of the memory chips, which means corruption of data in your case.

You can try to get a new one under warranty by your dealer, I got a brand new one after more then a half year of using. :worried_anim:


Ps> You can try TRIM setting to ‘ON’ to add support for non-Apple SSD drives, which means a patched IOAHCIFamily.kext.
You can see if this helps in your case. good luck!!

#698
barnum

barnum

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:france

OK guys.
We start with this.
Is for a test purpose.

P6T SE

I need to know... (USE the 10.7.4 AppleACPIPlatform.kext)
- SS work w/o CStates and PStates Generator in org.chameleon.Boot.plist
- Sleep Wake Restart works w/o any SleepEnabler (Of course you need to patch the AplleRTC.kext take a look at rayap topic for this)
- The boot time from Chameleon GUI to Lion Desktop Login (Set the KernelCache=Yes in org.chameleon.Boot.plist) normally between 4(SSD HD) sec to 20(Normal HD).
- Audio (Vanilla so AppleHDA.kext) some kind of scratch?
- Other things not normal with "universal" DSDT

THX
Fabio


Hi Fabio,

can you tell us what modification you have done on the DSDT ?
I need to do the same on the P6TWS pro for a xeon e5540 cpu

regards,
Barnum

#699
pantheman

pantheman

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Is there someone out there who has a Asus P6X58D-E working with 10.7.4, who could give us a copy of your dsdt and or extra file? I tried the one listed here, which work for 10.7.3 but doesn't for 10.7.4 I've tried many of the fixes out there on the forums but still can't get it up and running with the app store and iclouds. Everytime I fix one issue another pops up.

My build is this:
P6X58D-E
i7 950
GTX 470
12gb ram
sata 2 HD

Thanks so much.

#700
RobLans

RobLans

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Is there someone out there who has a Asus P6X58D-E working with 10.7.4, who could give us a copy of your dsdt and or extra file? I tried the one listed here, which work for 10.7.3 but doesn't for 10.7.4 I've tried many of the fixes out there on the forums but still can't get it up and running with the app store and iclouds. Everytime I fix one issue another pops up.

My build is this:
P6X58D-E
i7 950
GTX 470
12gb ram
sata 2 HD

Thanks so much.


Hi Pantheman,

Just a thought, did you also use the latest Enoch-rev.2050.pkg.zip (for GTX 470) from here http://www.insanelym...pic=231075&st=0

I think it's a combination of the DSDT from post #566 and latest Chameleon, otherwise try this; use AppleACPIlatform.kext from OS X 10.6.8 with the DSDT from #1 post must be working on P6X58D-E with 10.7.4, Finally, use Lionize_V1.07 (10.7.4 compatible described in post #543), success !! :wink2:







Also tagged with one or more of these keywords: Lionize, ASUS X58 LGA1366


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy