Jump to content

OSX on Dell Latitude E6520...


  • Please log in to reply
55 replies to this topic

#21
GrimmVarg

GrimmVarg

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Okay, so I tried to install Lion anyway, and the isntaller loads a bunch of packages. and then failes at "no DSDT found" and reboots. Pleaze to help the noob. I've been reading my {censored} off, but I cant seem to get my head around this install.

#22
tarekibrahim83

tarekibrahim83

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Here are the specs:

Dell Latitude 6520
Intel Core i7-2720QM 2.20GHz
8.0 GB DDR3 RAM
nVidia NVS 4200M 512MB
Dell Wireless 375 Bluetooth
Dell Webcam
Dell Wireless 1530 802.11 a/b/g/n
OSX Lion GM

I worked on this last night. What I have now is a working laptop in Lion but its not 100% perfect yet. The video works (with GraphicsEnabler=yes) but remains "unknown" inside the OS (I have full resolution and access to all screen savers). Bluetooth worked out of the box. Wireless is completely undetected. Webcam works without modification. Audio works with Voodoo audio but all volume levels are the same level (audio on the highest setting is just as loud as one-notch above mute although that volume level is acceptable and neither blasts the room nor is too quiet to hear).

Keyboard works including the separate volume keys. Trackpad works including "tap to click" but no other trackpad gestures are available and Lion sees it as a mouse. To get keyboard and trackpad working, I used the latest "PS2 Keyboard/trackpad" extensions recently posted to our favorite kexts site. You'll still need a USB keyboard and mouse, though, to get past the installation as they WORK with the installer and the first-time configuration wizards but the OS thinks you don't have either. You need to plug in the external ones to get through the "please connect a keyboard" etc. screens and then you can unplug them and continue to use the internal kb/trackpad. Once you're done installing the OS, you can go into the bluetooth settings and turn off the advanced option of prompting for a keyboard/mouse.

I'm using the MacBookPro 8.1 SMBIOS settings.

Ethernet works with the Intel driver from #####. Voodoo Battery get's the battery recognized and gives you the two different power settings and battery display on the menu bar.

Not working at all: wifi, sleep. Wifi is annoying but OK right now since I can use Ethernet although that does really tie down a laptop. Sleep, of course, will be necessary if I'm ever going to use this on the battery.





So what about wifi? Is it impossible to get the 1530 to work?

#23
littledragon

littledragon

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Does anyone know how to properly install Chameleon? I was using the guide which worked great on my D620 but on the E6520, I'm getting the boot0: error... I've tried everything I could find on the internet. It works fine if I boot off the Chameleon USB stick..

#24
Theta

Theta

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Phoenix, AZ
I'm still having no luck with the WIFI.

For Chameleon, try using Champlist. It also has the ability to install/update Chameleon and configure the boot file settings.

#25
littledragon

littledragon

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
I spent all weekend and I can't get any boot loader onto the HD... maybe it's one of those drives that Chameleon doesn't like... it's a 500gb Scorpio Black. I'm going to try another drive and see what happens. I've already tried #####, champlist doesn't seem to want to run, chimera gives the same error... too bad this laptop can't boot off the SD card..

#26
mayhemm88

mayhemm88

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
OK, so i have everything up and running but I am having a couple of issues

1. How does one get shutdown to work properly with this laptop... it is not powering down the laptop all the way

2. does anyone have a DSDT file for this particular laptop/is it possible to run with AppleCPUPowerManagement.kext instead of NullCPUPowerManagement.kext

3. How do you get the OS to dim the screen automatically, or get the Fn Key on the laptop working to dim the display in battery mode

Other than those issues, it appears I have a rather nice hackintosh laptop.

#27
Aim

Aim

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hey guys,

I have managed to install Lion on my work laptop, which is an E6520 (obviously!) but I can't get the HD3000 to work. I don't have any discrete graphic card unfortunately, only the crappy Intel HD setup.
I managed to have 1024x768 w/o QE/CI.
My e6520 has a Quadcore I5-2520M 2.5Ghz which means Intel HD3000+.
Given that the HD 3000+ device id is 0x126, it should work out of the box, since similar to the new Mac mini setup.
I tried a couple of fixes like hex editing the hex editing the AppleIntelSNBGraphicsFB kext to modify the number of connectors but it didn't help. I tried only enabling the LVDS connector for instance ... didn't help.

I'm curious to know if anybody else managed to get it to work...

Cheers,

Happy hacking.

#28
Veeper

Veeper

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Just got a E6320 with no Nvidia, only Intel HD graphics.

Lion is installed and updated to 10.7.1

Not working:

Wireless
Keyboard mouse (will try other kext here shortly)
Graphics are detected but I'm getting tearing.
Haven't tried power or CPU settings testing yet.

I'm a huge noob at this so I'll keep my chatter to a minimum here and let you guys know if something does/doesn't work as I go at this.

Thanks.

#29
Aim

Aim

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hey,

I'm wondering if you didn't anything specific to get the graphics to work.
Do you have native resolution and QE/CI?
If so, what smbios did you use? Any DSDT mods?

Thanks,

C.

Just got a E6320 with no Nvidia, only Intel HD graphics.

Lion is installed and updated to 10.7.1

Not working:

Wireless
Keyboard mouse (will try other kext here shortly)
Graphics are detected but I'm getting tearing.
Haven't tried power or CPU settings testing yet.

I'm a huge noob at this so I'll keep my chatter to a minimum here and let you guys know if something does/doesn't work as I go at this.

Thanks.



#30
Veeper

Veeper

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hey,

I'm wondering if you didn't anything specific to get the graphics to work.
Do you have native resolution and QE/CI?
If so, what smbios did you use? Any DSDT mods?

Thanks,

C.


Greetings!

I used TonyMac's install method for 10.6.3 -> 10.6.7 Then I set the system identifier to MacBookPro 8,1 and Lion had no issues installing after that, and it automagically saw that I had an Intel 3000. Initially I had some graphics tearing, but today it hasn't shown up yet. I'll see if it shows up again.

EDIT - Screen tearing is still a huge issue. I must have the wrong device ID or something?

QE/CI seems to be working aside from that. Res shows up as native 1366x768. I'll paste a screenshot on here from that notebook shortly. Hope this helps. (Me being such a hackintosh n00b, you may need to be more specific with your question, or ask me for screenshot or information from the console.)

Anyone (6420, 6520, 6320) have a sleepenabler or power kexts/edit/config suggestion for me?

EDIT - going to see if I can get a DSDT from Maldon.

Attached Files



#31
Veeper

Veeper

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I forgot to reply to this and add that 10.7.1 and Chimera 1.5 seemed to fix all of my video issues. Also there's an extra PCIe slot in the 6320 which allowed me to add a BCM94322 which seemed to work OOB in Lion.

Still no sleep. Anyone have luck with sleep on their 6320/6420/6520?

#32
328ti

328ti

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I have an E6420 with NVS4200s, installed lion and updated to 10.7. I've got everything working except sleep and external display, also it does not shutdown completely.

I replaced the wireless card to an AR9280 to make wifi work.

#33
tarekibrahim83

tarekibrahim83

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Everybody with the Nvidia NVS4200 video card. WHen you launch iPhoto does the slideshow work?

ANd when you launch iMovie and assemble a clip can you preview it properly?

If so what do you have installed.

#34
Random Hajile

Random Hajile

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

I used these files (attached). Be sure to put them in /System/Library/Extensions and rebuild the cache or boot with the -x option once.


This works great for getting the keyboard/trackpad working. However, the trackpad is so sensitive (and huge) that I'm constantly moving my cursor accidentally. The trackpad isn't recognized as an actual trackpad and so doesn't show up in the system preferences, but does anybody know how I might temporarily disable the trackpad? I'd still like to use the keyboard on the laptop, but would rather stick with a mouse when possible.

#35
GrimmVarg

GrimmVarg

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

This works great for getting the keyboard/trackpad working. However, the trackpad is so sensitive (and huge) that I'm constantly moving my cursor accidentally. The trackpad isn't recognized as an actual trackpad and so doesn't show up in the system preferences, but does anybody know how I might temporarily disable the trackpad? I'd still like to use the keyboard on the laptop, but would rather stick with a mouse when possible.



Any progress for you guys? :)

#36
Theta

Theta

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Phoenix, AZ

Any progress for you guys? :rolleyes:

Unfortunately, I left my position with my company so I no longer have this laptop. I apologize, but there's nothing more I can offer.

#37
willpower101

willpower101

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
Bump, If there's no progress on this then I'm thinking of selling it and getting the hp probook 4530s instead. Most stuff works out of the box.

#38
willpower101

willpower101

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
Well, I've done some cursory research on this and it looks the dell latitude E series refresh, while a really nice set of hardware, simply doesn't have the following that some other laptops have. Fortunately they fetch a pretty penny on ebay.

#39
Baddy_FX

Baddy_FX

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi,

I have an Dell E6520 laptop too. I try to install Lion for hours now.
No matter how I try to install lion (the tutorial from this post, #####, rboot, . . .)
I get this error:
unable to open var db bootcache.playlist 2 no such file or directory

I googled alot but nothing I found helped me.
Any ideas?

Regards
Felix

#40
jmac_qld

jmac_qld

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Does anyone know how to properly install Chameleon? I was using the guide which worked great on my D620 but on the E6520, I'm getting the boot0: error... I've tried everything I could find on the internet. It works fine if I boot off the Chameleon USB stick..


I use Chimera (installed through #####).





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy