Jump to content

OSX Lion 10.7 DP4/GM/RETAIL on VirtualBox 4.0


  • Please log in to reply
67 replies to this topic

#61
myhobby

myhobby

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
So far I've a booting LION 10.7.2 and functional Virt Machine in Vbox under linux (headless). Works great, but I've issues with my mouse pointer. Downgraded IOUSBFamily.kext to 10.7.0 but without succes. NIC/Audio is also for the moment not working but that can be resolved as soon as my mouse is100% functional

Any ideas anybody ?

#62
Curlyman

Curlyman

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

First, thanks for the great guide! Got everything up and running until the change from using the boot cd to efi. When I boot with EFI I get the following problem, I am running on an Sandy Bridge i5 if that is of any help.

Has anyone got a clue how to fix this, besides continuoulsy booting with the boot cd?



Same problem here... how u solve it?

[EDIT]
If i disable the audio from VB it will boot without problems.

#63
dennismoore

dennismoore

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
The link to Hackboot is broken. Should I use Hackboot v6.2 to boot Lion? I can't find it! Strangely I checked mald0n posts and I've just found V5 and V7 (no luck with the last one).


EDIT: Ok, I've found v6.2 somewhere else, and almost everything went perfect. The only thing: after installing the kexts, rebooting with EFI didn't worked (a text screen with a message telling EFI not supporting
this version of MAC OSX). I'm on Virtual Box 4.1.8. I'll stick to hackboot iso to boot.

Thanks a lot, great guide.

#64
wawabaobao

wawabaobao

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Dear all, I got 10.7.3 installed on VirtualBox and can boot with Hack Lion.iso. However, when I tried to use efi for booting, I got the panic, please refer to the snapshot I attached for details. Anyone has a solution for this?

Another problem is that "Messages Beta" cannot login. The password is right but it prompted cannot login and let me try again, this process repeated endless.

Attached Files



#65
kopfpilot

kopfpilot

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Installation
Installation of Lion 10.7.2 iAtkos L2 is working in Virtualbox 4.1.18 without having a mac at all (not even a hackintosh).
Just mount the dmg image and boot without efi - no need to prepare own installer, all modification are allready included.
Sound is working out of the box in ear phone mode, which still passes audio to line-out from host computer :)

Just graphic hardware accelleration is still missing.

I updated the system to 10.7.4 and ran myHack 3.1 to ensure that my system still works after a reboot...

worked like a charm :)

Only drawback, efi boot is not working out of the box.


Afterwards i created my own 10.7.4 from vanilla image using myHack 3.1 - installation went fine aswell.
Graphics seem to be a tad faster on the vanilla image... sound also worked directly.


Enable efi boot
1. Boot Lion
2. sudo rm /System/Library/CoreServices/PlatformSupport.plist
3. Google, find and download PlattformUUID.key, extract it to /Extra/Extensions/
4. If exists rebuild Extension.mkext for the "/Extra/Extensions" direcotry
$ sudo kextcache -m /Extra/Extensions.mkext /Extra/Extensions
5, Rebuild Extension.mkext for the “/System/Library/Extensions” directory:
$ sudo kextcache -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions


Efi Boot Args
Virtualbox has hardcoded nvram which is set to boot args: keepsyms=1 -v -serial=0x1
The arguments can't changed in Lion in any way (same for freebsd)

File: \src\VBox\Devices\EFI\Firmware2\VBoxPkg\VBoxAppleSim\VBoxAppleSim.c
static const CHAR8  vDefBootArgs[]	  = "keepsyms=1 -v -serial=0x1";

If one could recompile virtualbox with removed arguments i believe we could set the arguments inside osx!
I believed they change the compiled binary files VBoxEFI32.fd and VBoxEFI64.fd, which could be easily spread afterwards :)


Change Resolution without EFI-Boot
Either use the method mentiond before using vboxmanage or directly eddid vbox file (mine is MACOSX.vbox)

<VirtualBox xmlns="[url="http://www.innotek.de/VirtualBox-settings"]http://www.innotek.d...ualBox-settings[/url]" version="1.12-windows">
  <Machine uuid=... name="MACOSX" OSType="MacOS_64" >
   ...
	<ExtraData>
   ...
	  <ExtraDataItem name="CustomVideoMode1" value="1440x900x32"/>
	  <ExtraDataItem name="CustomVideoMode2" value="1600x900x32"/>
   ...
   </ExtraData>
   ...
  </Machine>
<VirtualBox>

Then the reflecting setting to Lion
sudo vi /Extra/com.chameleon.Boot.plist
...
<plist>
<dict>
  ...
  <key>Graphics Mode</key>
  <string>1600x900x32</string>
  ...
</dict>
</plist>


VirtualBox guest-addition at MacPorts
See http://www.macports....bstr=virtualbox

I installed MacPorts, then installed xcode 4.4 from apple developer programm (free registration and download), then i used port install virtualbox-guest-addition, which installed some hundreds of megabyte sourcecode from macports and compiled it afterwards. Though the guest-addition.iso DID NOT include any Mac OSX guest Installations.

I am a little curious because on freebsd the guest addition package is used to install freebsd guest addition (see http://wiki.freebsd.org/VirtualBox). While MacPorts is a port of FreeBSD port i assumed it should be the ported version to OSX (even though maybee just with acceleration/clipboard for x11), including all necessary Kext to enable SharedDirectory and probalby Kext for Graphics and Sound?

Unluckily there is no documentation about that package :/

If you are going to try it be patiend, this will take a while (~3h?)

<EDIT>
It is just a copy of the guest-additions.iso which is shipped with the common extension-package.
FreeBSD has an addition package called virtualbox-ose-additions, which does not exist at MacPorts
</EDIT>

<EDIT2>
I found a patch here: https://forums.virtu...hp?f=10&t=43330
I tried to apply the patch to the latest sources from svn and to the given revision 40897, both failed in osx.
Then i used TurtoiseSVN in Windows and appied the patch in there.

Next step is to compile it using xcode 4.4 in osx - i'll keep you people informed about my progress.
Dunno what dependencies are needed to have the full compile tool chain...

If someone has hints, you're welcome!
</EDIT2>

Virtualbox in FreeBSD 64 Bit mode
Efi boot arguments use the same implementation like osx does. Actually i just found the difference, that ear phone sound is not available anymore and shutdown/reboot are not stuck at the powerdown screen anymore. While rebooting no reset is needed (ctrl+r), on shutdown no manual shutdown is needed (ctrl+q).

Prefering sound of comfort made me change back to Mac OSX Server Mode

#66
kopfpilot

kopfpilot

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Yesterday i managed to complete the build chain :)
I'm using a lion 10.7.4 64Bit vanilla installation in VirtualBox 4.1.18 running on Win7 64Bit / CPU: Intel Core i5 - M240

Prerequirements
1. xcode_4.3.3_for_lion.dmg (~2GB, includes 10.7 OSX SDK,http://developer.app...tools/download/, needs apple-ID, registration is free)
2. command_line_tools_for_xcode_june_2012.dmg (~200MB, http://developer.app.../tools/download/, needs apple-ID, registration is free)
3. MacPorts 2.1.1 (~2MB, https://distfiles.ma...1-10.7-Lion.pkg, free download)
4. Qt 4.8.2 OpenSoure Mac Binary (~168MB, http://qt.nokia.com/...ent-on-mac-os-x, free download)
5. VirtualBox OSE Sourcode from SVN (there are some free svn-client available for mac, if you are firm with Xcode - use the build in svn-client)

Precondition: Install Xcode and Xcode command line
1. mount xcode dmg image, open dmg and drag&amp;drop Xcode to Application folder. Install on first run!
2. mount xcode command line and install

Precondition: Install Qt
3. install Qt 4.8.2 OpenSoure Mac Binary

Precondition: Install MacPorts and needed libraries
4. install MacPorts 2.11
5. shell: sudo port selfupdate
6 shell: sudo port install libidl +universal

Precondition: create needed smylinks for OSX SDKs
7. shell: mkdir -p /Developer/SDKs
shell: ln-s /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk /Developer/SDKs/MacOSX10.7.sdk
shell: ln-s /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.6.sdk /Developer/SDKs/MacOSX10.6.sdk

Build VirtualBox
8. change to vbox folder
9. shell: ./configure --disable-hardenening --disable-docs
10. shell: source env.sh (otherwise kmk is not available)
11. shell: kmk

Run VirtualBox
12. shell: change to vbox folder/out/darwin.x86/release/dist
13. shell: ./loadall.sh
14. shell change to vbox folder/out/darwin.x86/release/dist/VirtualBox.app/Contents/MacOS
15. shell: ./VirtualBox

Needed Kext are load in Step 12/13

Seems to be important to have both symlinks from step 7, otherwise strage compile errors appear.
I compiled revision 40987 that way which seems to be build 4.1.51 if i check the about dialog. The GUI seems much more modern that in VB-4.1.18 for Windows
When i tried to use HEAD revision, which was 41961, i noticed that open watcom is missing. Unluckily it is not availabe to Mac OSX yet - but they annouced a possible future release without ETA.
Anyhow i was able to build r41941 aswell and it's up and running.

After succesfull OSE is compiled without problems, next step is to compile the patched sourcecode... Hope there will be any benefit at all!

Todays HEAD revision is 42003, which builds perfect aswell, just VBoxUSB.kext is not working.. means no usb support.

#67
Engrish

Engrish

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
The link to

Mald0n's guide is dead so I don't know which hackboot.iso is referring to. I looked around the Internet and I found v6 and v7 which doesn't indicate if it works for Lion.


** Found a copy of it from Sysprobe and using that one right now. However I'm getting the "Still waiting for root device" message. I'm using 10.7.4 retail app store download and built the ISO according to the Easy Guide.

#68
kopfpilot

kopfpilot

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Engrish: i would suggest to use Atkios L2 for your first Hackintosh installation.
Just boot straight from Atkios L2 dmg and go for it. After installation you have a modified 10.7.2 which can be updated to 10.7.4 without any problem.

If you prefer vanilla installation. You can create you own 10.7.4 installation parition using a vanilla dmg and myhack 3.1





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy