Jump to content

Lenovo Thinkpad T420/T520/W520


  • Please log in to reply
13 replies to this topic

#1
san_

san_

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Toulon (France)
Hi, just received the new thinkpad W520, and I wondered if OSX would run on it ?
Has anyone tried ?

#2
digdugbug

digdugbug

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hi, just received the new thinkpad W520, and I wondered if OSX would run on it ?
Has anyone tried ?


I have not tried. But I am very interested. So much so that I am purchasing a GT 430 to test out in my desktop hackintosh to make sure I can get QE QC plus OpenCL to work first before getting a W520. There will be other issues but that looks like the biggest one. I am willing to purchase a W520 from lenovo and return it if is doesn't work. I am willing to go Ubuntu on it, possibly. My fav desktop Unix is still OSX.

Others have reported success with the GT 430 (Quadro 1000M ish) so I am hopeful.

The current MacBook Pros only support 8GB and a single drive which is ridiculous. The W520 supports 32GB of ram and 3 drives! 32GB isn't possible with the DRAM that is in the channel. So the only sane setup is 16GB, that is what I would populate it with. RAID 0 2XX MB SSD with a 1TB backup drive (rsync cron job). Please VMWare port Workstation to the Mac, Fusion is a toy!!

I currently run a MacBook Poly as my main machine with an SSD is the optibay and an 640GB HD in the main slot. The SSD is my main drive.

I haven't used them but look at ##### and #####. It might take some magics to make work. Please report back if the boot discs get very far.

...

bug.

#3
neckcutta

neckcutta

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

Hi, just received the new thinkpad W520, and I wondered if OSX would run on it ?
Has anyone tried ?


If I was in your shoes (with a W520 chilling there), I wouldn't be doing anything other than trying to OSX it. :D

If anyone has either a T420/520/W520, please contribute! i'll probably have access to a W520 this weekend. will report back here.

#4
neckcutta

neckcutta

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

If I was in your shoes (with a W520 chilling there), I wouldn't be doing anything other than trying to OSX it. -_-

If anyone has either a T420/520/W520, please contribute! i'll probably have access to a W520 this weekend. will report back here.


Ok, so I got a chance to mess with a friend's W520...
I've tried booting it into iAtkos s3v2, didn't work. Went into BIOS (F1 @ startup) and changed graphics mode to discrete (default was set to optimus which fluctuates between integrated & discrete). Booted up OK. Installed OSX onto an external USB HDD. Install failed.

Swapped out that HDD for the one in my friend's W520. I forget the exact phrasing, but it said that the installation was successful & I now need to reboot. Upon reboot, the white apple screen briefly flashes & the comp then restarts.

My first install attempt was with all disk options set to default. The few following attempts were to change the bootloader. All unsuccessful till I ran out of time. I've also tried booting with a Leo4All disc & Kalyway disc (that worked on my dell SXPS 1645). Both are ancient (from around 2009) & both did not work. Also tried booting with Snow Leopard by Hazard. Nothing.

The reality of the situation is.... I'm too newb for these experiments, but nonetheless, if anyone has any input or ideas, chime in!

#5
JazJon

JazJon

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I just ordered a new W520 and should have it in a few days. I too am curious if I can get MAC OS X Lion running on my new Thinkpad. (either VMWare or Dual Boot)

The main thing I would like to use is iMovie if possible. I actually just posted some questions about it here if anyone knows.
http://www.insanelym...howtopic=264525

But yeah, I'd love to try and get it working with the help of other experts. I'm just starting to learn about OSX86 and looking forward to collaborating with other Thinkpad users.

#6
JazJon

JazJon

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

I just ordered a new W520 and should have it in a few days. I too am curious if I can get MAC OS X Lion running on my new Thinkpad. (either VMWare or Dual Boot)

The main thing I would like to use is iMovie if possible. I actually just posted some questions about it here if anyone knows.
http://www.insanelym...howtopic=264525

But yeah, I'd love to try and get it working with the help of other experts. I'm just starting to learn about OSX86 and looking forward to collaborating with other Thinkpad users.



That's strange looks like someone deleted the post I created yesterday???
I'm new so my history shows I had 2 posts total. When I click the link above it says it doesn exist. (same if I click on my name to view history, does show my long detailed post I made)

#7
crashnburn_in

crashnburn_in

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
Any updates on OSX/ Hackintosh compatability for the T420?

#8
waldojim

waldojim

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I am new here, so please bear with me.
I have a Lenovo W520 with Intel i7 2620 and Quadro 1000.

After locking down the video card to just the Nvidia card, and using ##### Legacy, you can install the Snow Leopard retail DVD. I can get the system to boot into single user mode. So far, I have no network access, wireless, nor graphic interface. As it stands I am still trouble shooting the basic install. As the installer fully starts up, I see no reason that SL cannot work to some degree on the W520.

I will post back with more information when I can.

edit: Any hints/tips for trying to get this thing to load into the graphic interface?

#9
waldojim

waldojim

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Ok, it looks like the included Nvidia drivers are what was borking things up. After deleting the related files from super user mode, the graphical loader fired right up.

The wired network works flawlessly out of the box. So far, no network support. Will investigate more later.

As to the question of will it work, that answer appears to be a definite YES.

EDIT: Cannot update system to 10.6.8. The system goes into a double panic (I wish I made that up) over the network card apparently. Since the install didn't complete successfully, I had to start over.

So you know, forcing the video card to Intel ONLY also works in safe mode, and doesn't require deleting the nvidia extensions after that to finish the install.

So far still working in safe mode trying to make it at least mostly functional.

#10
devfom

devfom

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Russia
waldojim, hi.
What about latest news about 10.6.8 on your laptop?
I have similiar laptop, so can you write me the steps to start working with Snow Leopard, or may be have you tried to install Lion? Also, we can dive together to install and bring the OS works in this laptop.

#11
Will520

Will520

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hi, just received the new thinkpad W520, and I wondered if OSX would run on it ?
Has anyone tried ?


W520 Lion Guide

I've been looking for some time now and just found this! I haven't tried it yet (i'm waiting for a second hard drive i ordered and am going to put in the optical drive slot) but it seems pretty straightforward. I've had some trouble trying to install by myself and following other guides, but i'm very hopeful for this guide.

#12
devfom

devfom

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Russia

W520 Lion Guide

I've been looking for some time now and just found this! I haven't tried it yet (i'm waiting for a second hard drive i ordered and am going to put in the optical drive slot) but it seems pretty straightforward. I've had some trouble trying to install by myself and following other guides, but i'm very hopeful for this guide.


Thank you Will520 I will try to use this guide as soon as possible, and I will write about results.

#13
neckcutta

neckcutta

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
what's up everyone, just got my own w520. almost entirely working. here's what i've done:

set BIOS to NVIDIA only, used nawcom's Mod CD to boot.

installed iAtkos L1.

using Lion Boot after that to boot up (not sure if I'm doing something wrong here or it's just Lenovo's semi-custom BIOS that's not letting me boot from HDD). Lion 10.7.2 update worked. btw, once i'm through testing & verify that it's possible to get a somewhat-stable OS on the w520, i intend on buying a copy of the Lion & encourage you to do the same. If anyone knows how to get a Lenovo to boot without a boot cd, please post!

used ##### & kext wizard to install additional kexts.

what works: graphics, sound, all USB, cam, keyboard, trackpad, LAN... pretty much everything other than: WIFI, sleep, brightness, booting without LionBoot cd
not sure how the processor is behaving... whether it's speed-stepping/turbo-boosting - if anyone knows how to check, please post!

also: i loaded a battery indicator kext which works (enable "show battery status in menu bar" under System Preferences > Energy Saver).
the e-SATA/USB combo port worked for hooking up HDD's, but now doesn't & even when it worked, it seemed to be a roll of the dice.

hope this helps & please keep this thread going!

#14
gothic860

gothic860

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
  • Gender:Male
  • Location:Germany, Bavaria
http://thinkpad-foru...f-ThinkPad-W520

German i know, but maybe Google-Translator is making a good job here.

http://translate.goo...ad-W520&act=url

If you have any questions feel free to ask :).





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy