Jump to content

[Guide] Dell XPS 15 L502X (Early 2011) Snow Leopard Install (possibly L702x too)

* * * * * 5 votes

  • Please log in to reply
2978 replies to this topic

#1841
scrappy_coco

scrappy_coco

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
@birdibird

Hmm exactly, I was going for that but then apple released macbook pro 15 retina. So thin so light, yet a 2.6GHz core i7, 8GB DDR3 1600Mhz, GT650 1GB DDR5(2.5x faster than GT540M), 512GB SSD and the retina screen offcourse. So i thought its better to buy new laptop.

#1842
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
Again, you're comparing a mid entry laptop to a desktop. An developing iOS apps doesn't mean you need NASA grade servers. You're also over judging the MBP Retina. Retina display actually eats from the CPU/GPU power because it's not natively generated but rather composed using vector like technique. The CPU is pointless in that laptop, it's not that much better than what we have. The only real advantage of the new MBP laptop is the SSD. Which can be equipped to our laptops as well.

Since you're studying computer science you should be familiar with Moore's law and taking into consideration we are talking about laptops here, the time spawn proposed gets cut in half. So yeah, there are newer models with 10% more computing power, but the user won't even feel the difference, because a 2.9GHz cpu is slower than a 3.1ghz cpu by 2 seconds, depending on the job. You should also take into consideration that most software are not even created with quad core in mind, a dual core desktop will outbeat a quad core one if the software is developed with dual core in minds. Like CUDA only helps certain programs.

#1843
scrappy_coco

scrappy_coco

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
ok ok guys just chill. I meant no offence. And i will keep using XPS 15 as 2nd laptop.

#1844
birdibird

birdibird

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
I deleted the bluetooth pan and 802.11n adapter from the prefpane and added a new 802.11n one and now it show it correct :)

#1845
markmac81

markmac81

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
@Doix

The download link for the lion 1.2 package installer links to lion 1.1 package download...

So I can restore ML to a sd card and then boot from it?!

#1846
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@markaman, thanks for reporting the link. DOWNLOAD HERE here's the correct one.

Yep, you can restore it to a SD card, as long as you got a working card reader.

#1847
birdibird

birdibird

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
I'm trying to create a solution to boot and install ML on a laptop which doesn't have any osx installed yet.
Somehow we need to copy fakesmc and nullpowercpu to the new created osx installation.
I had the idea to boot back into the installer usb, go to terminal and copy it by hand.

I tried to mount the partitions as readwrite and the cp -r the kexts
by using
mount -a -u -w

it didn't work
I cp -r the kexts but they didnt appear in the target folder

what is wrong with the mount syntax?

Even better: couldn't we get the install procedure to automatically copy these kexts?

#1848
markmac81

markmac81

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

@markaman, thanks for reporting the link. DOWNLOAD HERE here's the correct one.

Yep, you can restore it to a SD card, as long as you got a working card reader.


Thanks!

#1849
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.

I'm trying to create a solution to boot and install ML on a laptop which doesn't have any osx installed yet.
Somehow we need to copy fakesmc and nullpowercpu to the new created osx installation.
I had the idea to boot back into the installer usb, go to terminal and copy it by hand.

I tried to mount the partitions as readwrite and the cp -r the kexts
by using
mount -a -u -w

it didn't work
I cp -r the kexts but they didnt appear in the target folder

what is wrong with the mount syntax?

Even better: couldn't we get the install procedure to automatically copy these kexts?


Uhm, i don't exactly understand what you mean. So you made a bootable stick/dvd/whatever and installed ML on that laptop. But you can't boot because you lack FakeSMC and NullCPUPM, right?

Simply boot with rBoot LE.. it's the easiest method. Then just install the kext necessary to make the laptop boot ok from within the OS.

Even better: couldn't we get the install procedure to automatically copy these kexts? < Not without modifying the installer, then it just isn't retail anymore and it would be like iAtkos DVD.

#1850
birdibird

birdibird

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

Uhm, i don't exactly understand what you mean. So you made a bootable stick/dvd/whatever and installed ML on that laptop. But you can't boot because you lack FakeSMC and NullCPUPM, right?

Simply boot with rBoot LE.. it's the easiest method. Then just install the kext necessary to make the laptop boot ok from within the OS.

Even better: couldn't we get the install procedure to automatically copy these kexts? < Not without modifying the installer, then it just isn't retail anymore and it would be like iAtkos DVD.

Yes I was thinking the same.
Forgot all about the rBoot LE option! thanx :)

edit: rBoot LE on a cd doesn't work: Mach-0 file has bad magic number
This happens with trying to boot both my existing mac partition as the new one

hmm, no time now anymore. will continue further in the week

what did you think about my mount frase, did I make a mistake?

#1851
maxey

maxey

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts

@markaman, thanks for reporting the link. DOWNLOAD HERE here's the correct one.

Yep, you can restore it to a SD card, as long as you got a working card reader.


A working SD card reader, you mean an external one right? The one built into our laptops does not work for booting as far as i experienced?

#1852
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
@birdi, mount -uw /diskXsX should be enough to read/write. I think it's better to boot using -s and type there /sbin/mount -uw / and cp -R /path-of-kext-from-installer /Volumes/Name-of-disk-where-osx-is-installed/System/Library/Extensions/ then chown -R root:wheel /Volumes/HD/path to kext and chmod -R 755 /Same-thing.

@maxey, external yes. Personally i never got the internal one to work, although it does work for some people.

#1853
Cisar Alexandru Marius

Cisar Alexandru Marius

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Medias, Sibiu
  • Interests:web design, programming
@scrappy_coco

i just tested battlefield3 (with max settings) today while watching a movie (1080P), having photoshop and dreamweaver opened and all ran flawless, with no lag. Maybe you should check your nvidia settings.

#1854
Ahmed_shiko

Ahmed_shiko

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:EGYPT
Thanks a lot DioX, now the boot of OSX start!!!

I can not enter in lion because command:-v GraphicsEnabler busratio = No = 23does not enter. The last written on the screen is : My Data 2 Nfts

please help

#1855
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.
Ahmed... i don't understand what you mean. "Does not enter" "My Data 2 Nfts" how/where?

What did you do to break your install?

#1856
Ahmed_shiko

Ahmed_shiko

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:EGYPT
install success
in boot -v
NTFS driver 3.8 [Flags: R/W].
NTFS volume name , version 3.1.
NTFS volume name win 7, version 3.1.
NTFS volume name My data, version 3.1.
NTFS volume name My data 2, version 3.1.

stop boot

#1857
Alex DeWolf

Alex DeWolf

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 313 posts
  • Gender:Male
  • Location:San Diego California USA
I followed Pcwiz13's install for ML and got the "Still waiting for root device" message. What have I done wrong?

#1858
pcwiz13

pcwiz13

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

I followed Pcwiz13's install for ML and got the "Still waiting for root device" message. What have I done wrong?



I dont have this problem with my install but apparently it is fairly common. Try booting with UseKernalCache=No if that solves the problem check out this link DoiX posted a couple pages back:http://www.insanelym...dpost&p=1834431

#1859
Alex DeWolf

Alex DeWolf

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 313 posts
  • Gender:Male
  • Location:San Diego California USA

I dont have this problem with my install but apparently it is fairly common. Try booting with UseKernalCache=No if that solves the problem check out this link DoiX posted a couple pages back:http://www.insanelym...dpost&p=1834431

Nope still same thing.

#1860
scrappy_coco

scrappy_coco

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male

I followed Pcwiz13's install for ML and got the "Still waiting for root device" message. What have I done wrong?


Boot with -v GraphicsEnabler=No PCIRootUID=1





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy