Jump to content

Guide to enable QE/CI on Dell Studio 1555 with Mob 4570


  • Please log in to reply
26 replies to this topic

#1
leo90

leo90

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Italy
1)Install Snow Leopard 10.6.6. and during installation select in the graphic section driver "Aty_init"
2)Install Chamelion bootloader RC5
3)Boot the fresh installation of your Snow
4)Under /System/Library/Extensions delete Atiframebuffer.kext and Ati4600controller.kext
5)Install Atiframebuffer.kext and Ati4600controller.kext that I have posted below
6)Repair permissions
7)Go to / and delete the "boot" file. Replace it with the "boot" in the archive
8)Open /Extra and paste com.apple.boot.plist and Smbios.plist that you find in the archive
9)Reboot
10)Enjoy

If you upgrade to 10.6.7. you have to boot in safe mode (-x) and reinstall Ati4600controller.kext and Atiframebuffer.kext and Aty_init, repair permission and reboot

To have speedstep and graphic power management you have to patch your DSDT ( I used DSDTpatchergui) and inject it with Chamelion. Than delete NullCpupowermanagement.kext and Disabler.kext

Attached Files



#2
andrek

andrek

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
How does patching DSDT look like, especially for dell studio 1555?

Thanks!

#3
leo90

leo90

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Italy

How does patching DSDT look like, especially for dell studio 1555?

Thanks!


Use DSDTpatcher gui

#4
tiksa1985

tiksa1985

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Thanks for the steps leo90 !

Can you also tell which kexts are you using for Battery, Power Management and touchpad 32/64 bit?

#5
spvc500vn

spvc500vn

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi Leo90 very thanks for your guide to enable QE/CI for mobility 4570 on dell studio 1555. I have success on my laptop but still a little problem that the logo of apple on the top left change color to green not black. Do you have any ideas to fix it? Thanks

#6
Muhammad Adnan Asim

Muhammad Adnan Asim

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:UK

1)Install Snow Leopard 10.6.6. and during installation select in the graphic section driver "Aty_init"
2)Install Chamelion bootloader RC5
3)Boot the fresh installation of your Snow
4)Under /System/Library/Extensions delete Atiframebuffer.kext and Ati4600controller.kext
5)Install Atiframebuffer.kext and Ati4600controller.kext that I have posted below
6)Repair permissions
7)Go to / and delete the "boot" file. Replace it with the "boot" in the archive
8)Open /Extra and paste com.apple.boot.plist and Smbios.plist that you find in the archive
9)Reboot
10)Enjoy

If you upgrade to 10.6.7. you have to boot in safe mode (-x) and reinstall Ati4600controller.kext and Atiframebuffer.kext and Aty_init, repair permission and reboot

To have speedstep and graphic power management you have to patch your DSDT ( I used DSDTpatchergui) and inject it with Chamelion. Than delete NullCpupowermanagement.kext and Disabler.kext


After trying everything I lost hope of enabling QE/CI and everbody use to say that it is not possible but here u comes. Thanks mate for enabling QE/CI.

But now I am having a problem, my audio and internet is not working. R u having this probelm or not. If not how u solved it?

Thanks again mate.

#7
lynbluefire

lynbluefire

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

1)Install Snow Leopard 10.6.6. and during installation select in the graphic section driver "Aty_init"
2)Install Chamelion bootloader RC5
3)Boot the fresh installation of your Snow
4)Under /System/Library/Extensions delete Atiframebuffer.kext and Ati4600controller.kext
5)Install Atiframebuffer.kext and Ati4600controller.kext that I have posted below
6)Repair permissions
7)Go to / and delete the "boot" file. Replace it with the "boot" in the archive
8)Open /Extra and paste com.apple.boot.plist and Smbios.plist that you find in the archive
9)Reboot
10)Enjoy

If you upgrade to 10.6.7. you have to boot in safe mode (-x) and reinstall Ati4600controller.kext and Atiframebuffer.kext and Aty_init, repair permission and reboot

To have speedstep and graphic power management you have to patch your DSDT ( I used DSDTpatchergui) and inject it with Chamelion. Than delete NullCpupowermanagement.kext and Disabler.kext


leo90, thanks for your method, but i was able to get Full Resolution but QE/CI is not enabled. Im using Dell 1555 as well and used Hazard 10.6.6i..... am i missing something here?

#8
Muhammad Adnan Asim

Muhammad Adnan Asim

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:UK
After following your steps my audio and Ethernet was messed up. Now I just change kernel flags from -v to arch=i386 in com.apple.boot.plist file in EXTRA folder and now my audio and Ethernet controller is working perfect. I did not even install Chamelion bootloader RC5, I am still using MYHACK bootloader. Except my wireless now my mac is full functional.

Cheers to you mate. I have waited one year to enable QE/CI for my video card.

Cheers again.

#9
Muhammad Adnan Asim

Muhammad Adnan Asim

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:UK

1)Install Snow Leopard 10.6.6. and during installation select in the graphic section driver "Aty_init"
2)Install Chamelion bootloader RC5
3)Boot the fresh installation of your Snow
4)Under /System/Library/Extensions delete Atiframebuffer.kext and Ati4600controller.kext
5)Install Atiframebuffer.kext and Ati4600controller.kext that I have posted below
6)Repair permissions
7)Go to / and delete the "boot" file. Replace it with the "boot" in the archive
8)Open /Extra and paste com.apple.boot.plist and Smbios.plist that you find in the archive
9)Reboot
10)Enjoy

If you upgrade to 10.6.7. you have to boot in safe mode (-x) and reinstall Ati4600controller.kext and Atiframebuffer.kext and Aty_init, repair permission and reboot

To have speedstep and graphic power management you have to patch your DSDT ( I used DSDTpatchergui) and inject it with Chamelion. Than delete NullCpupowermanagement.kext and Disabler.kext


Would these kext works in 10.6.8 update? Has anyone tried update to 10.6.8?

I treied update to 10.6.8 but i get grey screen and no spinning circle. If I use -x -v, system stop at PCI Configration.

Any help plz.....

#10
Gilj

Gilj

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I also updated to 10.6.8 but I don't think the drivers work for graphics with this release.

#11
Benjz

Benjz

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Bolton, UK
Would this work on other laptops with a Mobility Radeon 4570? Namely the Sony Vaio NW11S? Only minor differences in specs, same graphics card though.
Installed iDeneb a long time ago and had everything functioning but the Wireless (not gonna attempt that again) and QE/CI.
Also, what install method should I use? Just vanilla 10.6.6? Not taking any risks haha.
Thanks!

#12
Westie.

Westie.

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
I tried with these kernel extensions on my Studio 1555, but they don't get me anywhere.

I can get native resolution, however no QE/CI.

Could someone give me any suggestions on how to enable this? I'm at my wits end here.

Regards,


I forgot to include the other ATI Framebuffer kexts.

Silly me.

Anyone got a fix for the OpenGL problem?

#13
hari.iiitb

hari.iiitb

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
  • Gender:Male
  • Location:India
I am going to try this today! Thanks for giving me hope.

EDIT: Got my Graphics card working in just 5 minutes. As I already had Mac OSX installed, I merely copy pasted three kexts into Kext helper and installed them. Then pasted boot under /. Then the two .plist files into Extra. Rebooted and that's it. Worked like charm with the translucent QE/CI. Installed Xcode and saved myself from buying a Macbook Air worth $1600 [I use Tata Docomo 3g for internet, so WiFi/Ethernet is not essential :)]

#14
Hamkrik

Hamkrik

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
But this solution works in LION Mac OS ?

#15
soulcopy

soulcopy

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I wonder if this trick works in Lion too!

I have found a couple of ATI Mobil 4570 Pack in this Forum.

But None of them give me a information about OSX Lion.

#16
Pr8ik

Pr8ik

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I currently have lion 10.7 dp4 installed on my studio 1555 with no qe & ci . And I don't have any hope of getting it done, so I want to ask if I install 10.6.6 as per this guide with working qe & ci , and then upgrade it to lion .....will I still have qe & ci activated on my dell studio 1555.😨😨😨

#17
restafora

restafora

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
is that working on 10.7.2??

#18
JamerTheProgrammer

JamerTheProgrammer

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:In the zone
  • Interests:Programming, mucking about with Linux and making Hackintoshes!
For me when I install it on my VAIO NW11s it just displays a grey screen. I did not update or anything. Help?

#19
ghostanime2001

ghostanime2001

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
What is the "/" directory ? Do you mean the partition I have mac installed on ? My mac partition is called "mac" it's this gray hard disk looking thing on my desktop. I cannot paste my boot file. The error msg that came up said "The item "boot" can't be replaced because it's invisible"

#20
Silent785

Silent785

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Belgium

What is the "/" directory ? Do you mean the partition I have mac installed on ? My mac partition is called "mac" it's this gray hard disk looking thing on my desktop. I cannot paste my boot file. The error msg that came up said "The item "boot" can't be replaced because it's invisible"


Yes it's the name of your partition(for me it's called Snow Leopard). It should already contain an existing boot file.
http://cl.ly/101f143p2H0b2M0i3t2R

You need to delete your existing boot file and then copy over the one from the archive, otherwise it will display the error that it's invisible.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy