Jump to content

[Guide] P6X58D Premium. Retail 10.6.4 Install. :)


  • Please log in to reply
246 replies to this topic

#121
tj_jackson

tj_jackson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts
  • Gender:Male
  • Location:Brasil - SP
have kexts for chip Marvel 9128 (sata 3)?

link for download?

#122
Pher9999

Pher9999

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I can't seem to get the Optical Audio port to show up and beable to use. I tried following the Tony's blog stuff. But I fear I'm missing something basic. I didn't try to edit the DTST, I'm still trying to read up on that.


*** Edit, using the ##### I got Digital output to show up, but no sound or such to come out either coax or optical port, Analog speakers still working.

#123
yellowpebble

yellowpebble

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
I have tried to install accordint to this guide, but failed.

I tried to install leo on 2nd partition of raid 0 hard drive.

After inserting installation dvd, I can see "snow leopard installtion dvd", and hit enter. But no answer.

What should I do at this setp?

#124
bunzrok

bunzrok

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Kup!

Thanks for the guide man. I followed it and have no experience with Hackintoshes and got it working.

My setup is a i7 920 overclocked to 4GHZ, XFX HD 5770, and onboard audio and such.

Everything works! I of course got a lot of my video card steps from the 5770 thread but all in all everything worked out. Good job.

My only question is; I see you're overclocked too. Does OSX say you're running at 3.8ghz? Kind of takes a little bit away from me lol.

Anyways, keep up the great work.

#125
verdi1987

verdi1987

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

I can't seem to get the Optical Audio port to show up and beable to use. I tried following the Tony's blog stuff. But I fear I'm missing something basic. I didn't try to edit the DTST, I'm still trying to read up on that.*** Edit, using the ##### I got Digital output to show up, but no sound or such to come out either coax or optical port, Analog speakers still working.


I haven't been able to get the SPDIF (optical or coax) outputs working with various combinations and versions of AppleHDA.kext, Legacy889HDA.kext, and HDAEnabler.kext. VoodooHDA.kext works. You can install it with #####. You'll have to remove the other kexts. I'd prefer to use AppleHDA with SPDIF or the HDMI output of my ATI if I can get either of them working.

#126
ps2pk

ps2pk

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
Here are the simple instructions for ATI cards 5850, 5770, 5750.

1. Go here > http://www.tonymacx8...=...651&start=0
2. Download ##### ATI 5xxx-3 for supported cpus or ##### ATI 5xxx-2 for unsupported cpus
3. Burn it to a CD at the slowest settings.
4. Go into bios and set the harddrive as ACHI
5. Insert and boot from the ##### CD. Once you get to the bootloader take the ##### cd out and insert the snow leopard dvd or choose the usb which has snow leopard restored on.
6. Follow the directions from this thread. Read the 1st post by Kup.
7. After it finishes installing it will restart. Insert the ##### cd and boot from that. Once @ the boatloader choose the name of the new install you just did.
8. Enter account information/etc.
9. Once you're at the desktop follow the OP's (original posters) directions regarding the p6x58d files.
10. Restart just to be safe. Boot with the ##### cd. Once at the desktop you'll have internet working.
11. Download the 10.6.4 combo update - http://support.apple...Combo10.6.4.dmg and the snow leopard graphics update -> http://support.apple...csUpdate1.0.dmg Don't install yet.
12. Download ##### -> http://tonymacx86.bl...abel/MultiBeast
13. Install the 10.6.4 update 1st. Don't restart. Now install the graphics update. Don't restart but don't close the window where it says to restart.
14. Now move ##### to the desktop and open it.


Advanced Options > Graphics > Graphics Enables > UAKARI Enabler. For 5770 chose Vervet.
Advanced Options > Graphics > ATI > 5xxx Series Kexts
com.boot.plist - 32bit + GraphicsEnabler = no

Choose those 3 and install. Restart using one of the other windows (10.6.4 or graphics update).

That's it. Now you can boot w/out any cd. Once you get to the desktop follow Kups directions regarding sound in 10.6.4.

I didn't do any of the hardwork. To many people to thank and appreciate. Just took all the instructions and simplified it for the p6x58d for ati users. It took me ages to get 5850 not because it was hard but because the information was all over the place. Hope this helps.

#127
Bugagazavr

Bugagazavr

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 8 posts
Hi, this is work AppleHDA with mic on front, thanks BIM167
Attached File  ALC889_P6X58D_E.zip   1.2MB   64 downloads

#128
daskog

daskog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
Thanks for this guide

#129
verdi1987

verdi1987

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Hi, this is work AppleHDA with mic on front, thanks BIM167Attached File  ALC889_P6X58D_E.zip   1.2MB   64 downloads

Thanks, Bugagazavr. Have you tested the SPDIF outputs with this AppleHDA.kext? I tried it but could not get audio from the digital ports. I tried it on its own and also in various configurations with HDAEnabler.kext, Legacy889.kext, and DSDT pin configurations.

#130
Bugagazavr

Bugagazavr

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 8 posts

Thanks, Bugagazavr. Have you tested the SPDIF outputs with this AppleHDA.kext? I tried it but could not get audio from the digital ports. I tried it on its own and also in various configurations with HDAEnabler.kext, Legacy889.kext, and DSDT pin configurations.

I dont know, i dont have spdif acoustics, maybe this driver work with coaxial or optical interface only?

P.S. This AppleHDA work fine with HDMI, if you set in bios, in onboards settings "SPDIF mode" > spdif

#131
verdi1987

verdi1987

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

I dont know, i dont have spdif acoustics, maybe this driver work with coaxial or optical interface only?

P.S. This AppleHDA work fine with HDMI, if you set in bios, in onboards settings "SPDIF mode" > spdif


Hi, Bugagazavr. I have some questions:

1. Are you getting HDMI audio from your graphics card? If yes, which card do you have? Did you have to connect the SPDIF out from the motherboard to your graphics card?
2. Does the HDMI interface show up under Settings -> Sound?
3. Are you using this AppleHDA on its own or with HDAEnabler and/or Legacy889HDA?
4. Did you make any DSDT modifications?

Thanks.

#132
Bugagazavr

Bugagazavr

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 8 posts

Hi, Bugagazavr. I have some questions:

1. Are you getting HDMI audio from your graphics card? If yes, which card do you have? Did you have to connect the SPDIF out from the motherboard to your graphics card?
2. Does the HDMI interface show up under Settings -> Sound?
3. Are you using this AppleHDA on its own or with HDAEnabler and/or Legacy889HDA?
4. Did you make any DSDT modifications?

Thanks.

1. Yes, im get HDMI sound with my card Palit GeForce 9600gt. Yes im connect SPDIF out with motherboard and graphics card.
2. Four inreface in outputs
Attached File  __________________________2010_09_11____23.21.20.png   65.37KB   37 downloads
3. Im using this AppleHDA + DSDT, HDEF section
4. Yes

P.S. Sorry my bad english

#133
daskog

daskog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts

Here are the simple instructions for ATI cards 5850, 5770, 5750.

1. Go here > http://www.tonymacx8...=...651&start=0
2. Download ##### ATI 5xxx-3 for supported cpus or ##### ATI 5xxx-2 for unsupported cpus
3. Burn it to a CD at the slowest settings.
4. Go into bios and set the harddrive as ACHI
5. Insert and boot from the ##### CD. Once you get to the bootloader take the ##### cd out and insert the snow leopard dvd or choose the usb which has snow leopard restored on.
6. Follow the directions from this thread. Read the 1st post by Kup.
7. After it finishes installing it will restart. Insert the ##### cd and boot from that. Once @ the boatloader choose the name of the new install you just did.
8. Enter account information/etc.
9. Once you're at the desktop follow the OP's (original posters) directions regarding the p6x58d files.
10. Restart just to be safe. Boot with the ##### cd. Once at the desktop you'll have internet working.
11. Download the 10.6.4 combo update - http://support.apple...Combo10.6.4.dmg and the snow leopard graphics update -> http://support.apple...csUpdate1.0.dmg Don't install yet.
12. Download ##### -> http://tonymacx86.bl...abel/MultiBeast
13. Install the 10.6.4 update 1st. Don't restart. Now install the graphics update. Don't restart but don't close the window where it says to restart.
14. Now move ##### to the desktop and open it.


Advanced Options > Graphics > Graphics Enables > UAKARI Enabler. For 5770 chose Vervet.
Advanced Options > Graphics > ATI > 5xxx Series Kexts
com.boot.plist - 32bit + GraphicsEnabler = no

Choose those 3 and install. Restart using one of the other windows (10.6.4 or graphics update).

That's it. Now you can boot w/out any cd. Once you get to the desktop follow Kups directions regarding sound in 10.6.4.

I didn't do any of the hardwork. To many people to thank and appreciate. Just took all the instructions and simplified it for the p6x58d for ati users. It took me ages to get 5850 not because it was hard but because the information was all over the place. Hope this helps.



I can't get the Boot disc work no matter what!!!? help please i have the P6X58D-Premium with XFX 5770 1GB.

I have tried every boot disc out there relevant to this board and the one Kup posted and i don't get it!? what is so different with my board! i tried the ##### ATI 5xxx-3 /##### ATI 5xxx-2 / The first boot disc in this thread from Kup none of them works! all i get is apple screen with some circle symbol in the middle.

i tried booting with all different kinds of command, busratio, arch, -v, -x, -f and so on

Can someone make a new boot disc with ATI 5770 drivers that work or something?

Cheers

#134
daskog

daskog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts

Here are the simple instructions for ATI cards 5850, 5770, 5750.

1. Go here > http://www.tonymacx8...=...651&start=0
2. Download ##### ATI 5xxx-3 for supported cpus or ##### ATI 5xxx-2 for unsupported cpus
3. Burn it to a CD at the slowest settings.
4. Go into bios and set the harddrive as ACHI
5. Insert and boot from the ##### CD. Once you get to the bootloader take the ##### cd out and insert the snow leopard dvd or choose the usb which has snow leopard restored on.
6. Follow the directions from this thread. Read the 1st post by Kup.
7. After it finishes installing it will restart. Insert the ##### cd and boot from that. Once @ the boatloader choose the name of the new install you just did.
8. Enter account information/etc.
9. Once you're at the desktop follow the OP's (original posters) directions regarding the p6x58d files.
10. Restart just to be safe. Boot with the ##### cd. Once at the desktop you'll have internet working.
11. Download the 10.6.4 combo update - http://support.apple...Combo10.6.4.dmg and the snow leopard graphics update -> http://support.apple...csUpdate1.0.dmg Don't install yet.
12. Download ##### -> http://tonymacx86.bl...abel/MultiBeast
13. Install the 10.6.4 update 1st. Don't restart. Now install the graphics update. Don't restart but don't close the window where it says to restart.
14. Now move ##### to the desktop and open it.


Advanced Options > Graphics > Graphics Enables > UAKARI Enabler. For 5770 chose Vervet.
Advanced Options > Graphics > ATI > 5xxx Series Kexts
com.boot.plist - 32bit + GraphicsEnabler = no

Choose those 3 and install. Restart using one of the other windows (10.6.4 or graphics update).

That's it. Now you can boot w/out any cd. Once you get to the desktop follow Kups directions regarding sound in 10.6.4.

I didn't do any of the hardwork. To many people to thank and appreciate. Just took all the instructions and simplified it for the p6x58d for ati users. It took me ages to get 5850 not because it was hard but because the information was all over the place. Hope this helps.



How on earth where you able to boot eather ##### ATI 5xxx-3 or ##### ATI 5xxx-2? i cant can you please verify what boot cd you used?

#135
ps2pk

ps2pk

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

How on earth where you able to boot eather ##### ATI 5xxx-3 or ##### ATI 5xxx-2? i cant can you please verify what boot cd you used?


A few things.

1. disconnect all harddrives except for the one that's being used for snow leopard
2. disconnect all cd/dvd drives except for the one that's being used
3. set hd to AHCI
4. most important - boot with only 4gb. will not install with 6gb. put it back after completing the last step from kups post (the hd audio fix with 10.6.4)


try these and let me know. the ##### 5xxx-3 should work w/out a problem.

#136
infinity16

infinity16

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
First of all, I would like to appreciate for everyone's contributions. Without you, I will never know how to build a hackintosh and give apple all my $$. And special thanks to kup and other major/key guys who spent so much time to make the easiest way for us to install the SL and answered all questions.

Last night, I successfully installed SL to my hackintosh. I follow all step in the Post #1, except I didn't use any flags, like -v, -x, busratio or anything, in my installation. However, I have a few questions and concerns.

1. Since I didn't use any flags, even though the SL was successfully installed, will I get any problem later?
2. I don't know if the system is running on 64 or 32 bits.
3. I ran Geekbench to test the system, the score is only 7500. Is it normal?

I hope someone can give me some comment, advice or answer. A million THANKS!

#137
Hozey

Hozey

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 8 posts

Tried, the one in the Extra folder & also the one found in your original bundle package that says 10.6.4. AppleHDAalc889binpatch.zip But both didn't work.

Also whenever i run kexthelper, i can't quit. I have to force quit it. SO not sure if thats the problem, maybe the kext was not install properly thats why it hung? Also i ran Kext utility to repair permission juzt in case, that didn't help too.




Edited: I tried manually putting the kext from the Extra Folder into the sys/lib/extensions , there's an error msg saying that the kext cannot be use. Also tried putting in HDAEnabler & LegacyHDA kexts, didn't work either. Maybe that error is causing KextHelper to hang.



I'm having the same problem with Kext Helper b7. Did you ever get an answer

#138
cloverbay

cloverbay

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

I'm having the same problem with Kext Helper b7. Did you ever get an answer


The answer is.... reinstall the whole OSx, there's something amiss somewhere along the line. After i reinstall SL, Helper b7 quit as normal.

Important thing to note, the audio kext will not work if you just boot up normally & replaced it with the old one, it needs to be replaced in Safe Mode & repair permission.

The only inconvenience i have is the phone jack in front of the casing not working. But the back O/P has no issue. Solution to this....

1) Buy a set of speakers that has a phone jack, so you can plug head phones into it

2) Use a headphone with longer cable (2.5m - 3m)

:thumbsup_anim:

#139
Drizz-OH!

Drizz-OH!

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Arizona

Here are the simple instructions for ATI cards 5850, 5770, 5750.

1. Go here > http://www.tonymacx8...=...651&start=0

Thanks for posting this ps2pk. Your brother linked me to this from overclock.net. I have a XFX HD 5850 and trying to make it work with OS X. But I am having some trouble getting that link to work. Is anyone else having that problem as well?

#140
kup

kup

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 319 posts

if anyone is interested in optical out audio

the legacyhda file here http://www.tonymacx8...=...686&start=0
along with the vanilla applehda.kext from 10.6.2 works great

and no popping when sound is initialized
works great

AirWalk

BTW I am running 10.6.4 on EVGA x58 SLI board. ( the audio chipset is a 889a)

From OSX86.net. Seems to work. :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy