Jump to content

[Guida] Installazione Snow Leopard retail su Asus P5QD Turbo


  • Please log in to reply
252 replies to this topic

#241
tempesta

tempesta

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 268 posts
CIAO

so' che io non centro nulla con questa scheda... ma.... mi sono accorto che io non ho l'audio funzionante e dato che vedendo le caratteristiche della mia M/S e questa ASUS P5QD Turbo

sono UGUALI sara' anche una domanda stupida ma... posso usare queste kext per far funzionare la mia scheda AUDIO ???

VoodooHDA.kext

VoodooHDA.prefPane



GRAZIE!

#242
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Prova ;)

#243
tempesta

tempesta

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 268 posts
scusami ma pecco di ignoranza...

come li installo io ho sempre scompattato il file zip ed uscito un kext e poi installato tramite kext Helper b7

qui sono in difficolta!

mi trovo VoodooHDA.prefPane in zip e lo stesso sempre dezippato credo tutto nella cartella download

poi mi trovo VoovooHDA.kext.rar che se provo a dezipparlo mi chiede di impostare l'applicazione per aprire il documento
ciedo scusa ma non so' come si installano!!!!!!

#244
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Il prefPane lo scompatti e poi fai doppio click e viene installato in Preferenze di Sistema.
Il VoodooHDA lo devi scompattare con The Unarchiver e poi installarlo normalmente come meglio credi.
Naturalmente devi installare anche l'AppleHDADisabler oppure eliminare l'AppleHDA.

#245
tempesta

tempesta

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 268 posts
Il prefPane installato con doppio click mi ha dato subito una serie di errori

The Unarchiver scaricato e installato

AppleHDADisabler DISINSTALLATO

Il VoodooHDA aperto con The Unarchiver usato kext Helper come finita l'installazione si e' bloccato il pc dandomi la solita schermata di riavvio forzato!

ho provato a far partire con -v ma e' andato in KP

::::::::::::::::::::::AGGIORNAMENTO::::::::::::::::::::::::::::::
sono entrato in win e ho provato ad eliminare manualmente AppleHDA

e' ripartito e con GRANDE STUPORE L'AUDIO c'E'

GRAZIE mrmojorisin

#246
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Io ti ho detto di installare l'AppleHDADisabler, non di disinstallarlo :D

Naturalmente devi installare anche l'AppleHDADisabler oppure eliminare l'AppleHDA.

Se usi il VoodooHDA devi o eliminare l'AppleHDA (in questo caso ad ogni aggiornamento lo devi cancellare, pena kp) oppure devi installare il disabler.

#247
tempesta

tempesta

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 268 posts

Io ti ho detto di installare l'AppleHDADisabler, non di disinstallarlo ;)

Se usi il VoodooHDA devi o eliminare l'AppleHDA (in questo caso ad ogni aggiornamento lo devi cancellare, pena kp) oppure devi installare il disabler.


si scusa ho sbagliato a scrivere..... intendevo installarlo
l'importante che ora funziona giusto ????
devo fare altro ??

GRAZIE

#248
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Volendo puoi rimettere sia l'AppleHDA che l'AppleHDADisabler e controllare all'avvio che quest'ultimo venga caricato correttamente (ti basta dare il comando kextstat nel terminale e controllare che il kext ci sia).
Se non installi il disabler devi ricordarti ad ogni aggiornamento di cancellare l'AppleHDA altrimenti andrà in conflitto con il VoodooHDA e avrai un bel kp.

#249
tempesta

tempesta

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 268 posts
ok GRAZIE per la dritta
eseguo subito !

#250
pianman

pianman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 404 posts
  • Gender:Male
Gentile mrmojorisin17,

anche se non possiedo questa scheda, ma bensì una p5q pro turbo che ha gli stessi componenti della p5qd, volevo chiederti se potevi modificarmi il mio dsdt creato con dsdt-autopacher affinchè mi venga correttamente riconosciuta in informazioni hardware la scheda audio. Al momento ho utilizzato il voodohda e l'audio funziona perfettamente.Grazie.

Ps: ho utilizzato anche le tue SSDT tranne la 1 e la 2 che con il mio dsdt non funzionano.

Questo è il mio DSDT.

Attached Files



#251
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Se anche la tua scheda madre monta come chip audio il Via VT1708S puoi semplicemente prendere il Device HDEF dalla mia SSDT è copiarlo dentro il tuo DSDT :P
[codebox] Device (HDEF)
{
Name (_ADR, 0x001B0000)
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x0A)
{
"AAPL,Slot-name",
Buffer (0x09)
{
"Built-in"
},
"device_type",
Buffer (0x16)
{
"Audio"
},
"name",
Buffer (0x28)
{
"Voodoo High Definition Audio Controller"
},
"model",
Buffer (0x25)
{
"VIA VT1708S 8-channel HDA Controller"
},
"PinConfigurations",
Buffer (0x34)
{
/* 0000 */ 0x40, 0x10, 0x01, 0x01, 0x60, 0x90, 0xA1, 0x01,
/* 0008 */ 0x90, 0x30, 0x81, 0x01, 0x10, 0x40, 0x01, 0x01,
/* 0010 */ 0x1F, 0x40, 0x21, 0x02, 0x80, 0x90, 0xA1, 0x02,
/* 0018 */ 0x70, 0x00, 0x37, 0x90, 0xA0, 0x00, 0x56, 0x18,
/* 0020 */ 0x60, 0x10, 0x45, 0x07, 0x30, 0x60, 0x01, 0x01,
/* 0028 */ 0x50, 0x20, 0x01, 0x01
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3)
RefOf (Local0)
Return (Local0)
}
}
}[/codebox]

#252
pianman

pianman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 404 posts
  • Gender:Male

Se anche la tua scheda madre monta come chip audio il Via VT1708S puoi semplicemente prendere il Device HDEF dalla mia SSDT è copiarlo dentro il tuo DSDT ;)

Device (HDEF)        {            Name (_ADR, 0x001B0000)            Method (_DSM, 4, NotSerialized)            {                Store (Package (0x0A)                    {                        "AAPL,Slot-name",                         Buffer (0x09)                        {                            "Built-in"                        },                         "device_type",                         Buffer (0x16)                        {                            "Audio"                        },                         "name",                         Buffer (0x28)                        {                            "Voodoo High Definition Audio Controller"                        },                         "model",                         Buffer (0x25)                        {                            "VIA VT1708S 8-channel HDA Controller"                        },                         "PinConfigurations",                         Buffer (0x34)                        {                            /* 0000 */    0x40, 0x10, 0x01, 0x01, 0x60, 0x90, 0xA1, 0x01,                             /* 0008 */    0x90, 0x30, 0x81, 0x01, 0x10, 0x40, 0x01, 0x01,                             /* 0010 */    0x1F, 0x40, 0x21, 0x02, 0x80, 0x90, 0xA1, 0x02,                             /* 0018 */    0x70, 0x00, 0x37, 0x90, 0xA0, 0x00, 0x56, 0x18,                             /* 0020 */    0x60, 0x10, 0x45, 0x07, 0x30, 0x60, 0x01, 0x01,                             /* 0028 */    0x50, 0x20, 0x01, 0x01                        }                    }, Local0)                DTGP (Arg0, Arg1, Arg2, Arg3)                RefOf (Local0)                Return (Local0)            }        }    }




Ho provato a copiarlo ma non sono riuscito a capire dove metterlo con dsdte, se potessi aiutarmi a faro ti ringrazierei. Inoltre vorrei poterlo fare anche per le altre SSDT.

#253
bbbaloo

bbbaloo

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
ottimaa guida tutto funziona alla perfezione solamente una cosa non mi torna dopo aver installato tutto ed aver aggiornato a 10,6,6 al primo riavvio tutto funziona una volta spento il pc provando a riaccenderlo si impalla sulla mela per farlo ripartire devo entrare in utility disco e riparare tutti i permessi come posso evitare ciò?altra domanda il pc non si spenge da solo le ventole girane e il monitor si spenge questo problema lo avevo risolto tempo fa installando la 10,6,7 ma ho paura che se aggiorno il pc continua a bloccarsi sulla mela





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy