Jump to content

atom n450 / pine trail + OS X


  • Please log in to reply
65 replies to this topic

#1
exasperation

exasperation

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
So here we are in 2010 and Pine Trail netbooks are on the shelves. After googling around, I still can't find anything more than speculation as to whether these will work with OS X or not. Supposedly the biggest hurdle is the X3150 graphics. OS X doesn't have explicit support for this card but it does for the X3100 and they are very similar.

I am looking to buy a netbook in the next few days for school and I'd really like to get one of the newer generation ones... but only if it is OS X compatible.

What's the verdict on Pine Trail ?

#2
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
Pineview has GMA 3150 without the X, its half the speed of GMA 3100. I think its incompatible with GMA 950 drivers.

#3
exasperation

exasperation

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Pineview has GMA 3150 without the X, its half the speed of GMA 3100. I think its incompatible with GMA 950 drivers.


Sorry, yes, got the terminology wrong there. It's the GMA 3150. Which is indeed a slower version of the GMA 3100. And yes, it won't run with the GMA 950 drivers. The question is though... will it run with the GMA 3100 drivers, like how the Intel GMA 945 chipsets work with OS X's GMA 950 drivers. :)

#4
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts

Sorry, yes, got the terminology wrong there. It's the GMA 3150. Which is indeed a slower version of the GMA 3100. And yes, it won't run with the GMA 950 drivers. The question is though... will it run with the GMA 3100 drivers, like how the Intel GMA 945 chipsets work with OS X's GMA 950 drivers. :)

But there isn't anything for GMA 3100? The 945xxx... Chipset is GMA 950 Graphic Solution.

#5
exasperation

exasperation

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Well I went ahead and bought a Toshiba NB305 (N450 Atom processor) and initial results are unpromising. Using Chameleon to boot Snow Leopard the same way I did with my (faulty) MSI Wind yields "Unsupported CPU: family = 0x6, model = 0x1c, steeping 0xa" and the Please Restart Your Machine screen.

#6
OSXtotheZ

OSXtotheZ

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts

Well I went ahead and bought a Toshiba NB305 (N450 Atom processor) and initial results are unpromising. Using Chameleon to boot Snow Leopard the same way I did with my (faulty) MSI Wind yields "Unsupported CPU: family = 0x6, model = 0x1c, steeping 0xa" and the Please Restart Your Machine screen.

Have you tried Mechdrew's guide using NetbookInstaller and NetbookMaker USB?

#7
debauchery1st

debauchery1st

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
:D

bought the gateway lt2104u

after some initial struggle, I've managed to get everything working with the exception of the graphics
(still stuck in 800x600)

I'm trying to compile a work-around for the graphics chipset. I've noticed that Linux uses the i915 driver for the gma 3150.
(this is the equivalent to the intelgma900 kext in apple land)

I think there may be hope.

(upgraded to 10.6.2 with patched kernel.)

#8
geigi

geigi

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
How did you get Sound, Wifi, Touchpad (Scrolling, tap to click) to work?

#9
geigi

geigi

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
ok i got sound(but no sound controll) and touchpad to work. Is there a fix for soundcontroll? wifi doesn't work until yet, also sleep and graphics.

#10
u.mass

u.mass

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hey all,

I'm usually over at hackint0sh.org but you guys seem to be the only ones investigating the Pine Trail (N450) + Mac OS X issue... thankfully I came across this forum!

I'm thinking of getting the Asus Eee PC 1005P (10", Atom N450, 250GB, Bluetooth, Wireless N, etc) but would like to know that there's a chance I can get Snow Leopard up and running on it.

To debauchery1st: how did you go about getting OS X to install on your Pine Trail N450 netbook? Do you think I could apply the same method to the Asus 1005P?

To debauchery1st and geigi: Any luck with the graphics yet? Would I be correct in assuming the graphics on the gateway would be the same as that in the Asus 1005P?

Thanks to all :(

#11
carlisle_united

carlisle_united

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hope somebody finds an solution for this soon...
I just got my Chinese Macbook AIR clone and it has the N450 CPU (Despite the promise of a N280 CPU).
And it just begs me to instal OSX on it, but I have no luck...

#12
deadsmile

deadsmile

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Having a 1005PE, tried to use the usb stick method with netbookmaker and this stuff.... but the key won't even start, it freezes the bios when the stick is in and unfreeze at hte second I take it out (really can't figure out why...)
Has anyone an Idea how to get this to work ?
I would give some impressionson the 1005PE if i get it to work... i think i will have to buy a external CD/DVD player to install it

#13
dockmckenzie

dockmckenzie

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey guys,

I have successfully gotten iDeneb 10.5.6 with the voodoo kernel 9.5 to work with the gateway lt21 (2119u) series. Everything is working (swapped the wifi card to dell 1395 card) except for graphics (gma 3150) and the ethernet (havent looked into it). Has anyone been able to get a work around for the graphics yet?

#14
r0bm2000

r0bm2000

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I would also like to know about how i can install SL on my brand new Toshiba nb305 netbook as no were online talks much about this model running mac os x and i searched all over if someone please can atleast confirmed that it does run it would be atleast helpful before I try all these step by step guides thanks

SPECS:
NB305-N410BL
250GBHD
1GBRAM
WIRELESS-N
USB: 3 2.0 PORTS

#15
Triston

Triston

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi all,

I've got iAtkos v7 (OS X 10.5.7) working on my Asus 1005P, but still had the same problem with the graphic card, only working at 800x600. Also sound and touchpad working (only with the installation, didn't update any driver, touchpad multigesture not working).

If anybody finds a solution for the graphic card or wifi, would be great to post it here!!

Thanks and regards

#16
debauchery1st

debauchery1st

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
Hello, I'm sorry that I haven't had time to work on the graphics yet, but I going to reinstall today while documenting the process. The only non-working hardware thus far is QE/CI graphics. This is not impossible. It's intel, not ati. remember that. let's not give up on the pine trail.

#17
Sheena

Sheena

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

;)

bought the gateway lt2104u

after some initial struggle, I've managed to get everything working with the exception of the graphics
(still stuck in 800x600)

I'm trying to compile a work-around for the graphics chipset. I've noticed that Linux uses the i915 driver for the gma 3150.
(this is the equivalent to the intelgma900 kext in apple land)

I think there may be hope.

(upgraded to 10.6.2 with patched kernel.)




Hey,

which version did you use to install on the LT2104U? Thanks.

#18
softice

softice

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Hello, I'm sorry that I haven't had time to work on the graphics yet, but I going to reinstall today while documenting the process. The only non-working hardware thus far is QE/CI graphics. This is not impossible. It's intel, not ati. remember that. let's not give up on the pine trail.


Great, I also have a TL2104U, this is really a good news to me. I am hoping to see your documents soon.

#19
debauchery1st

debauchery1st

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

Hey,

which version did you use to install on the LT2104U? Thanks.


I just did a complete wipe and reinstalled using "iPortable Snow x86 optimized Mac 10.6.2"
the default "chocolate" kernel seems to boot just fine, and this seems like a good default SL installation to tweak things on...
wireless drivers are included in the package.
(read the pdf included in the DMG and follow the instructions.)

I've rebuilt the Chameleon boot loader to force detection of a GMA915... However, no kext is loaded after detection. I think I may be heading in the right direction.

(note, the first install I performed was on a retail dvd using the netbook usb maker. post installation scripts need not be run)

#20
chris

chris

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
thanks for everyones hard work. i have not bought one of these, but i am looking at possibly getting one. ima follow this for updates.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy