Jump to content

i7 Hackintosh Review and Guide - With Pics!


  • Please log in to reply
104 replies to this topic

#41
Terry Tibbs

Terry Tibbs

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

What's happening when you are trying to sleep now?


Let me begin by saying your post was well written, photographed and curated. Thanks for making such a contribution. It was so impressive that I did this same build as well.

Now, to my problem ( :unsure: ):
My kexts look exactly as yours are. When the machine goes to sleep, it won't wake up. As well, when I shut down, it shuts down and then starts up again.

And, one other problem, for a dvd drive, I couldn't locate the same, so I used an OEM Lite-on 24x DVD burner (DH-24AAS) bought at newegg which doesn't register disks that I put in, though the bios sees it.

I still plan to try and find a wireless card to replace wired lan, but outside this am quite happy.

Have you started overclocking? What was your experience like with that?

#42
r15177

r15177

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

" I've been editing on this 4890 for a few days now (thanks to cindori) and HD content screams."


turtle7, thank you and Cindori for your replys. i seen that you both have a 4890.
i have looked around on the forums and some people say this matters and some say it doesn't. but
is your 4890 a xfx? if not, where did you get yours at?

im looking at a xfx 4890 video card from newegg.com

xfx 4890
http://www.newegg.co...0-438-_-Product

i just wanted to check before i went out and paid almost $200 that this card would work great for me.

anybody else have any good or bad comments about the xfx 4890 video card?

#43
Cindori

Cindori

    InsanelyMac Protégé

  • Members
  • PipPip
  • 76 posts
I really dont think that the manufacturer matters

#44
Terry Tibbs

Terry Tibbs

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Ah, I just tried to change the partition size and then turned off the machine to switch the sata channel on the dvd burner and when I turned it back on it fails to even boot!

#45
Turtle7

Turtle7

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

but is your 4890 a xfx? if not, where did you get yours at?

im looking at a xfx 4890 video card from newegg.com

xfx 4890
http://www.newegg.co...0-438-_-Product


r15177, yeah I think that is identical to the XFX card that I have. I was able to get my card at a Best Buy locally so that I could have a return option if this build didn't work. If you don't deviate from the hardware then you should be good to go.

Also another selling point to me of the 4890 were tests done by Barefeats, I can't find the exact page though. They mentioned the 4870 or 4850 doing great price/performance wise on pro apps.

#46
Terry Tibbs

Terry Tibbs

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Ah, I just tried to change the partition size and then turned off the machine to switch the sata channel on the dvd burner and when I turned it back on it fails to even boot!


Well, I fixed my problem. The monitor was not working with DVI so I switched to HDMI and am now peachy on that front. Switching the SATA ports fixed the DVD burner.

Sleep and powering off are still problematic. Any ideas?

#47
Cindori

Cindori

    InsanelyMac Protégé

  • Members
  • PipPip
  • 76 posts
@ 4 GHz


Posted Image



compared to Mac Pro benches:



Posted Image



terry, are you using my boot.plist and dsdt.aml ?




btw, I am now selling my rig. I built it mainly as a project to create a hackintosh, I don't use the computing power. I love it, but right now it's just standing on my desk :)
so if anyone would like a working rig...able to beat $3500 mac pro... pm


#48
Terry Tibbs

Terry Tibbs

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Is that benchmark score @ 4GhZ or at 2.7?

The boot.plist and .aml active are the ones in /extra, right?

Here's my com.apple.boot.plist :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>-v arch=i386</string>
<key>Theme</key>
<string>NebulOSX</string>
<key>Timeout</key>
<string>2</string>
</dict>
</plist>


and here is the DSDT.aml should be the same as yours unless the file got confused somewhere. It doesn't allow for cut and paste, so I attached it.

#49
picoByte

picoByte

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Scythe Gentle Typhoon 120mm, 4x 492kr
Corsair H50 Hydro Series CPU Cooler 714kr
Akasa Intern Memory Card Reader 3.5 95kr


Can you boot from the card reader (assuming memory card/system on it of course)?
Edit: Answer is yes! :)

According to a couple of web reviews, the Fractal Design Define R2 is kinda hot. Do you confirm?
Unless you "polar winds" :) are powerful enough?

#50
hero223

hero223

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Hello Cindori, I have followed your guide to the T and im about to go bonkers!! I have a very similar setup as yours: i7 920 ex58-ud5 and an ati 4850, i have installed everything onto my USB external drive. I use the buildcache command and reboot. When it loads back up and I select OSX Install I keep getting a socket error. I have tried a whole bunch of different methods and am getting nowhere. Im very frustrated and if you could please help it would be greatly appreciated!! Thank you so much.

I have attached the error I get! Please help

Attached Files



#51
sbeehre

sbeehre

    InsanelyMac Geek

  • Retired Developers
  • 196 posts
  • Location:New Zealand
Hi Cindori what BIOS revision are you currently using on your machine... im wondering if my problems are due to me using F9 and your DSDT which guessing could have been created from a lower revision.

#52
Thireus

Thireus

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 220 posts
  • Gender:Male
  • Location:France
  • Interests:Security
Hi,

I would like to know where you guys buy your hardware components, I started looking at Amazon but it's very expensive.

#53
Terry Tibbs

Terry Tibbs

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Hi,

I would like to know where you guys buy your hardware components, I started looking at Amazon but it's very expensive.


I got mine on newegg. Seemed a little more than in Sweden on some pieces, but that was untaxed.

Anyone else have recs on wireless cards to add?

#54
BigBat83

BigBat83

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
For this build do you HAVE to water cool or is that for added luxury?

#55
Terry Tibbs

Terry Tibbs

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

For this build do you HAVE to water cool or is that for added luxury?


Without overclocking, mine ran fine without the watercooling.

#56
hibbijo

hibbijo

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
That's a sweet tower.

#57
Cindori

Cindori

    InsanelyMac Protégé

  • Members
  • PipPip
  • 76 posts
oh sorry did not know people dug up this thread


I am using latest bios F9M

as to the Socket error I recommend you try install on a real hard drive.

#58
r15177

r15177

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
i have a ga-ex58-ud5
i7 920
6 gb corsair xms3
xfx 4890

I'm dual booting with snow leopard and win 7 x64
and noticed in "my computer"
that windows sees all 6gigs but it says (4 GB usable)

i was just wondering if anyone else had this problem?

-r15177

also, Cindori,
is your rig stable at 4Ghz?
how hot does it get with that water cooler you have on it?

#59
AviEinZur

AviEinZur

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Hey Cindori,
first, thanx for all your help here. its much appreciate...
and now for the problem that im having:
im using the same set up as yours <bought it after seeing this post>:
i7 920
mobo ud5
3*2 gigs corsair
4850 <i checked with you first to assure compability>
seagate HDs
my bios revision is 1.07.

now, ive done everything that your guide said. i have a macbook pro that has made the
restore of the dmg <10a432> to the drive of my hackintosh and everything looks just like you described,
untill the stage the machine is supposed to boot from the hackintosh it self and i should pick the
single user mode and command it to buildcache. at that stage i see the camelion bootloader running
after choosing boot from the drive instead of install osx <ive partitioned the HD with the second
partition as the dmg and the first partition as the sys with the installtion itself>, all the kext are loding
and everithing looks fine but when the load ends i get a strange doted view and the machine
restarts. somehow this process resets the bios to the original values also.
ive done the installtion a few times exactly as you mentioned and im getting the same results.
ive checked the installation on my macbook pro <choose the hackintosh drive as the startup disk>
to see if the installation went ok and on my macbook it boots up fine <looking for network and other
preferences> so the installation should be ok.

where do you think the problem is? is there something im missing in your install guide in order to get
it to boot from the hackintosh? should i set the partition as active in the camelion bootloader?


really sorry for the long post but im truely frustrated and clueless with this. wouldnt want to bother
you with this but....
again, thank you for your time.

AviEinZur.

#60
AviEinZur

AviEinZur

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
ok, ive had some more tests for the reasons it restarts after choosing single user boot and loading all the kext. after choosing the specific pci slot that my GPU card is in at the bios it stopped crashing but it holds and freezes instead of giving me the option of typing buildcache after the loading is done. quote of the last part of the loading page:

singleuserboot -- fsck not done
root device is mounted read-only

if you want to make modifications to files:
/sbin/fsck -fy
/sbin/mount -uw /

if you wish to boot the system:
exit

:/ root#




and than the freezed corsur.... cant type a thing....
PLEASE HELP!!!
and again, sorry for the mess i made to this wonderful guide...:)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy