Jump to content

*Updated 11/12* DMG mounting issues & Sandbox.kext/Seatbelt.kext


  • Please log in to reply
167 replies to this topic

#21
etiger13

etiger13

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Is the GSoD related to this? A kernel panic is when the system freezes and spits out an error message on the left of the screen right? All I get when I try to run dmg files is the box that pops up and says the computer is dead and i need to shut it down.

I have 9.6 Kernel and am using the 10.5.6 Kext from the combo update but dmgs still crash my computer at the point when they are getting mounted.

#22
eagertolearn

eagertolearn

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Is the GSoD related to this? A kernel panic is when the system freezes and spits out an error message on the left of the screen right? All I get when I try to run dmg files is the box that pops up and says the computer is dead and i need to shut it down.

I have 9.6 Kernel and am using the 10.5.6 Kext from the combo update but dmgs still crash my computer at the point when they are getting mounted.


yip that's kernel panic :) i think it's mostly related to chipset drivers.

#23
Zyke

Zyke

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I did all the above since I had problem with kernel panic when I was trying to mount a *.dmg file.
when I did the reboot I typed in "reboot [-f]" and the system restarted.. however, when it was about to start up I got the following:

System config gile /com.apple.boot.S/Library/Preferences/Systemconfiguration/com.apple.Boot.plistnot found

sooo.. now I cant start the system.
How should I solve the problem?

thanks in advance : )


hmm... I restarted the system now and got the option to chose boot options, and I chose -v and now all of a sudden it works.. strange.. well I hope it will work when I reboot as well : >

I still get the error I was talking about before, but now I get the option to chose boot options and then it starts. How can I fix so that I dont have to chose boot options each time I restart the system?

#24
eagertolearn

eagertolearn

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

I did all the above since I had problem with kernel panic when I was trying to mount a *.dmg file.
when I did the reboot I typed in "reboot [-f]" and the system restarted.. however, when it was about to start up I got the following:

System config gile /com.apple.boot.S/Library/Preferences/Systemconfiguration/com.apple.Boot.plistnot found

sooo.. now I cant start the system.
How should I solve the problem?

thanks in advance : )


hmm... I restarted the system now and got the option to chose boot options, and I chose -v and now all of a sudden it works.. strange.. well I hope it will work when I reboot as well : >

I still get the error I was talking about before, but now I get the option to chose boot options and then it starts. How can I fix so that I dont have to chose boot options each time I restart the system?


u can get com.apple.Boot.plist from someone. i would try copying it from ur installation DVD and set permissions.

#25
n0cud06

n0cud06

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
I installed iatkos5i and after installing all updates including 10.5.6 my usb thumb driver won't mount anymore, my external hard drive won't work either and I have already fixed the mounting problem - USB works for other things (keyboard/mouse). Now if I reboot the computer while both of them are still plugged in everything works fine. Any ideas???? Thank you very much!

kernel: 9.5.0 voodoo

hardware:
Intel BLKDP35DPM Core 2 Quad/ Intel P35/ FSB 1333/ DDR2-800/ RAID/ A&GbE/ ATX Motherboard

Specification

* Mfr Part Number: BLKDP35DPM
* CPU: Socket 775 Support Intel Core 2 Quad/ Core 2 Extreme/ Core 2 Duo/ Pentium Dual-Core/ Celeron Processor; FSB 1333/1066/800 MHz
* Chipset: Intel P35 & ICH9R
* Memory: 4x 240pin DDR2-800/667 DIMMs, Dual Channel, Max Capacity 8GB
* Slots: 1x PCI-Express x16 slot; 3x PCI-Express x1 slots; 3x PCI slots
* IDE/SATA: 1x ATA-133 Channel; 6x SATA2 ports, Support RAID 0, 1, 10, 5
* Audio: Sigmatel STAC9271D 8-Channel High Definition Audio CODEC
* LAN: Intel 82566DC Gigabit Ethernet Controller
* Ports: 12x USB 2.0 Ports (6 rear, 6 by headers); 2x IEEE 1394a Ports (1 rear, 1 by header); 1x Serial Header; 1x RJ45 LAN Port; Audio I/O Jacks
* Power Connector: 1x 24pin main power, 1x 4pin CPU power
* Form Factor: ATX, 12 x 9.6 inch / 30.48 x 24.38 cm
* Package: Bulk

#26
zaijian2009

zaijian2009

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Can anyone tell me where to download a kernel?

#27
balea

balea

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Hi, I have the same iPC 10.5.6 also with 9.4.0 kernel. How do I upgrade to 9.6.0 ?

Thanks.


i have got the same question
how can i update the kernel from 9.4.0 (iPC 10.5.6)

#28
Beerkex'd

Beerkex'd

    Content Provider

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,000 posts
  • Gender:Male
  • Location:Belo Horizonte - Brazil
Extract kernel from install DVD with Pacifist.

Install Kernel with OSX86Tools.

Don't forget system.kext version must match kernel version.

#29
n0cud06

n0cud06

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Hi thanks for all your help about the DMG mounting issue,

I knew this before installing so I backup my system and seatbelt then copied after installing however it's still not working. I downloaded 10.5.5 from the link you provided then follow your instructions precisely still no go.

Please help get this thing running This is my third fresh install due to the same problem.

Ps: That only happens with a few DMGs, like my iLife 09 dmg mounts fine but my xtorrent1.1 does not work and yes I've tried that same file on my macbook and fine there.


here is my kernel info:
Darwin N0cud06-X86.local 9.5.0 Darwin Kernel Version 9.5.0: Tue Oct 14 07:39:11 IST 2008; Voodoo; Beta 2c :xnu-1228.7.58/BUILD/obj/RELEASE_I386 i386


my sys info:
* Mfr Part Number: BLKDP35DPM
* CPU: Socket 775 Support Intel Core 2 Quad/ Core 2 Extreme/ Core 2 Duo/ Pentium Dual-Core/ Celeron Processor; FSB 1333/1066/800 MHz
* Chipset: Intel P35 & ICH9R
* Memory: 4x 240pin DDR2-800/667 DIMMs, Dual Channel, Max Capacity 8GB
* Slots: 1x PCI-Express x16 slot; 3x PCI-Express x1 slots; 3x PCI slots
* IDE/SATA: 1x ATA-133 Channel; 6x SATA2 ports, Support RAID 0, 1, 10, 5
* Audio: Sigmatel STAC9271D 8-Channel High Definition Audio CODEC
* LAN: Intel 82566DC Gigabit Ethernet Controller
* Ports: 12x USB 2.0 Ports (6 rear, 6 by headers); 2x IEEE 1394a Ports (1 rear, 1 by header); 1x Serial Header; 1x RJ45 LAN Port; Audio I/O Jacks
* Power Connector: 1x 24pin main power, 1x 4pin CPU power
* Form Factor: ATX, 12 x 9.6 inch / 30.48 x 24.38 cm
* Package: Bulk

#30
Lanceomni

Lanceomni

    infinitemac.com (φοίνιξ) !

  • Donators
  • 614 posts
  • Gender:Male
  • Location:Florida
So your are getting the Kernel Panic that references seatbelt?

Open Finder to the /System/Library/Extensions/ folder right click on seatbelt.kext and select "Show Package Contents" Open the Contents folder and then open version.plist in a text editor. What does it say for build version.

#31
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
hy.
but what is the sense of your suggestion?
if I have a 10.5.6 retail setup .. I still have seatbelt 10.5.6. .. so why shall I replace with yours?

thanks

may I solve usb mounting pen drive problems? (now the only issue is that they're not visible.. nowhere in the system)

#32
verdant

verdant

    InsanelyMac V.I.P.

  • Gurus
  • 5,548 posts
  • Gender:Male
  • Interests:At home, I have the following computers......
    >
    >
    >
Try running or re-installing Voodoo 9.5.0......use the .dmg installer from here......since from Voodoo 9.5.0 User Documentation:

Anyone who cannot run Apple's stock kernel (aka 'vanilla' kernel) should use the
Voodoo kernel. This includes all processors except Apple-supported Intel Core/
Core2 range and Xeon. Some people who can use vanilla kernel might want to try
the Voodoo kernel as well, which could help fix some problems, specially related to
multiple-core synchronization, restart issues etc.
All other kernels have been superseded by the Voodoo kernel so everyone is advised
to upgrade.



#33
n0cud06

n0cud06

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
no panic just a warning popup then I click ok and nothing happens again some dmg mount fine see the attached image. Here is a copy of my extension folder including my extension.mkext http://69.108.218.45/wip/

Attached Files



#34
Lanceomni

Lanceomni

    infinitemac.com (φοίνιξ) !

  • Donators
  • 614 posts
  • Gender:Male
  • Location:Florida

hy.
but what is the sense of your suggestion?
if I have a 10.5.6 retail setup .. I still have seatbelt 10.5.6. .. so why shall I replace with yours?

Open terminal and type:
uname -a
If your kernel is 9.5.0 (Kernel version from 10.5.5) then you will need to do one of the following

1. install seatbelt.kext from 10.5.5

2. install kernel 9.6.0 (kernel version from 10.5.6)


may I solve usb mounting pen drive problems? (now the only issue is that they're not visible.. nowhere in the system)


Just like with the above issue you must have the system.kext match versions with your kernel. So if you checked your kernel and it is 9.5.0 you will need the system.kext from 10.5.5 which is also version 9.5.0. This is not to say that you don't have other issues related to your chipset but it is a common problem. If you have a USB drive plugged in before you start the computer and it works fine then this is probably the problem.

So to recap both seatbelt.kext, system.kext and your mach_kernel must mesh. You see this because people are not using the vanilla kernel.

OSX 10.5.6 - Kernel version 9.6.0 - System.kext 9.6.0 - Seatbelt.kext from 10.5.6 (build 45)

OSX 10.5.5 - Kernel version 9.5.0 - System.kext 9.5.0 - Seatbelt.kext from 10.5.5 (build 14)


no panic just a warning popup then I click ok and nothing happens again some dmg mount fine see the attached image. Here is a copy of my extension folder including my extension.mkext http://69.108.218.45/wip/


It may be something else as it should give you an immediate KP. Let me look around if I come across something Ill let you know.

#35
verdant

verdant

    InsanelyMac V.I.P.

  • Gurus
  • 5,548 posts
  • Gender:Male
  • Interests:At home, I have the following computers......
    >
    >
    >

no panic just a warning popup then I click ok and nothing happens again some dmg mount fine see the attached image. Here is a copy of my extension folder including my extension.mkext http://69.108.218.45/wip/


Why have you got multiple injector kexts installed.....NVkush, Natit and Titan......?

#36
Bakk15

Bakk15

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
Hello.

I'm not good at english, but here is mt trouble.
When i mount DMG, i get the grey screen ( hold power down ) except if i mount dmg from a backup dvd.

is that the same on this thread ?

I'm on 9.4.0 Darwin Kernel
but in the 1st message, you talk about 9.5 and 9.6, what should i do ?

regards, bakk

#37
Bakk15

Bakk15

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts

I have the iPC 10.5.6 with a StageXNU 9.4.0 Kernel, so which one should I use?
Edit: Solved, manually installed a 9.6.0 Kernel
BUT: How could I possibly get the seatbelt.kext with Pacifist, if installing Pacifist requires to open up a *.dmg file?



Okay. How should i do that ? manually install newer kernel ?

regards

edit :

I installed seatbelt with osx86tools, and all is fine now. Thanks

#38
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
PERFECT
thanks!!
ugo

#39
n0cud06

n0cud06

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
that is a good question because when I installed just titan it then gave me only one resolution I think it was 1024x798 so I kept trying and when I selected those three my display works perfectly. I got a Geforce 9500 GT PCI-E

#40
Lanceomni

Lanceomni

    infinitemac.com (φοίνιξ) !

  • Donators
  • 614 posts
  • Gender:Male
  • Location:Florida

that is a good question because when I installed just titan it then gave me only one resolution I think it was 1024x798 so I kept trying and when I selected those three my display works perfectly. I got a Geforce 9500 GT PCI-E


That kind of thing generally causes problems but if your not having problems there is no reason to worry. Most likely it is one of those three that is doing the job.

Are there any other DMGs you get this issue with? Try downloading Firefox and opening it. It doesn't look like a seatbelt issue but im still curious.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy