Jump to content

[HOW TO] Getting IDT Audio Working


  • Please log in to reply
287 replies to this topic

#81
AREOS

AREOS

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts
  • Gender:Male
  • Location:Mexico City

I will try that now and hopefully have it work soon.... I get a detect on my headphone insertion however I get no sound any ideas?

P.S. can you give me a view of what your amp layout is like for that mic?


Here you go

Good luck

Attached Files



#82
bartont

bartont

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

I will try that now and hopefully have it work soon.... I get a detect on my headphone insertion however I get no sound any ideas?

P.S. can you give me a view of what your amp layout is like for that mic?

Okay I tried the method mentioned and I see it as a built in input but, I still can not get it to do anything I even entered the config data under the controller......

I am also still having issues with headphones, but that is what I am working on now....
I have attached what I have done so far so any Dell Studio guys it mwill save you some time and I will update as I get more done.

Thanks, Mark


Thank you! Internal sound is working well. No internal mic either.

#83
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
If I try a applehda.kext from leopard instead of using the one here which I believe to be a Tiger kext I get mic to work however I get a lot of appleHDA widget errors at boot....... but, I have a working mic and speakers with volume control. I get a detect on headphones but I still get no sound....... If you delete the headphones all together you can plug in and get sound through the jack but it does not mute the speakers..... Any advice or ideas is greatly appreciated.

#84
bartont

bartont

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

If I try a applehda.kext from leopard instead of using the one here which I believe to be a Tiger kext I get mic to work however I get a lot of appleHDA widget errors at boot....... but, I have a working mic and speakers with volume control. I get a detect on headphones but I still get no sound....... If you delete the headphones all together you can plug in and get sound through the jack but it does not mute the speakers..... Any advice or ideas is greatly appreciated.


I'd really like to try your Leopard version. Could you post it here? Much gratefulness .

Thanks again for your work!

Tom

#85
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL

I'd really like to try your Leopard version. Could you post it here? Much gratefulness .

Thanks again for your work!

Tom


Tom, you will probably get a lot of widget errors as I did but it does not seem to affect anything let me know if it works for you.... there is still no volume control on the internal mic , but it does work....

P.S. you still need the HDA enabler

#86
bartont

bartont

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

Tom, you will probably get a lot of widget errors as I did but it does not seem to affect anything let me know if it works for you.... there is still no volume control on the internal mic , but it does work....

P.S. you still need the HDA enabler


Yes works! I was able to use Skype for 4 continuous hours today, no issues. The system log does fill with widget errors though.

#87
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
I am not sure why the widget throws so many errors but it does not seem to affect the items we have working however I will continue to work on it and headphones as well. I will let you all know as soon as possible.

Mark

#88
RaidenII

RaidenII

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts

r u sure , i use audio recorder and it works ,
try this kext and see if this helps
and as for when it wakeup from sleep . the sound still works for me


well the mic works but sound card dies from wakeup. weird

#89
jaysonz

jaysonz

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
FINALLY GUYS !!

LINE IN IS WORKING NOW :P
FOR 0x111D76B2

THANKS YOU GUYS FOR THE HELP AND ALL.

HERE THE KEXT

Attached Files



#90
RaidenII

RaidenII

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts

FINALLY GUYS !!

LINE IN IS WORKING NOW :)
FOR 0x111D76B2

THANKS YOU GUYS FOR THE HELP AND ALL.

HERE THE KEXT


Weird, line-in input control is detected but still no response.
Sound card still dies from wakeup.

#91
keeto

keeto

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
I have a Compaq CQ40 and I ran OSX86 Tools to get my audio device. It gave me this:

00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)

I downloaded age_sabres18's AppleHDA.kext from rapidshare and installed it, and it works.. sort of..

The internal speakers and the headphone jack works (the system detects headphones when I plug them in), but the first problem was that I kept on getting kernel panics every time I shutdown. That was easily solved by fixing permissions using OnyX.

The only problem I have now is that the internal microphone and mic jack don't work. They're detected in SP but like others, Audio preferences doesn't give me a way to control it them, nor is my mic detected when I plug it in..

I've read all about pin configs in this post, but I'm totally lost. Can anyone help me? Thank you in advance..

Keeto

#92
RaidenII

RaidenII

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts

try this kext and tell me if it works .

and also can u send me your linux codec .

thanks


Here's my codec. Thank you very much!

ps: that kext still doesn't work...

Attached Files



#93
jaysonz

jaysonz

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

Here's my codec. Thank you very much!

ps: that kext still doesn't work...



so line - in doesnt work for you and wakeup with sound ??

try this one , i edited through your codec
the thing i dont get is how line in doesnt work on yours but
it works on mine same goes to wakeup from sleep.

i will try to fix it

Attached Files



#94
RaidenII

RaidenII

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts

so line - in doesnt work for you and wakeup with sound ??

try this one , i edited through your codec
the thing i dont get is how line in doesnt work on yours but
it works on mine same goes to wakeup from sleep.

i will try to fix it


Thanks for your help. Now line-in works.
The problem of wakeup is still there. I discovered that my laptop cannot go to sleep automatically, only by clicking "Sleep" in the Apple menu it could sleep. Is there anything to do with this?

#95
tdwp2481

tdwp2481

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Heres a noob question but how do I install the HDAEnabler.kext?
And heres another question I dont get how to do the first step can someone explain it??

#96
eric69

eric69

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Thanks for your help. Now line-in works.
The problem of wakeup is still there. I discovered that my laptop cannot go to sleep automatically, only by clicking "Sleep" in the Apple menu it could sleep. Is there anything to do with this?


Raidenll, can you tell me if I can just download the last AppleHDA.kext file you used and load it in my laptop or do I have to follow the instructions at the beginning of the thread.

I believe we have the same audio card;

HP dv7 1175nr
Ven 111D Dev 76B2

Also you mentioned that your Web Cam worked out of the box and I just wanted to confirm you didn't have to make any modifications, as mine doesn't seem to work.

Thanks

#97
Hatch

Hatch

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:New Zealand

Raidenll, can you tell me if I can just download the last AppleHDA.kext file you used and load it in my laptop or do I have to follow the instructions at the beginning of the thread.

I believe we have the same audio card;

HP dv7 1175nr
Ven 111D Dev 76B2

Also you mentioned that your Web Cam worked out of the box and I just wanted to confirm you didn't have to make any modifications, as mine doesn't seem to work.

Thanks


Eric, Can you post your Sound Card IDs for me to compare and where you got them from (images if possible), I have a DV7-1003tx and RaidenII's kexts didn't work for me, I believe he has a DV5t if I'm correct.

Heres a noob question but how do I install the HDAEnabler.kext?
And heres another question I dont get how to do the first step can someone explain it??


You need to delete the kext in system\extensions and then use a separate program or process to install kexts.
I used http://######.com/osx86tools/, can anyone confirm that this is ok?

#98
eric69

eric69

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Eric, Can you post your Sound Card IDs for me to compare and where you got them from (images if possible), I have a DV7-1003tx and RaidenII's kexts didn't work for me, I believe he has a DV5t if I'm correct.



You need to delete the kext in system\extensions and then use a separate program or process to install kexts.
I used http://######.com/osx86tools/, can anyone confirm that this is ok?




Unfortunately I won't have access to my laptop till the weekend. Where cam I get the sound card IDs?

#99
abcbello

abcbello

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
hi guys!! followed all steps and no luck with audio! maybe someone has my same audio card! I have an HP dv3500..!!! any help is greatly appreciated!

#100
Hatch

Hatch

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:New Zealand
Btw my Webcam worked straight off after installing following RaidenII's instructions, it asks you to take a image/video for log in.

Follow RaidenII's guide if you haven't already:
http://forum.insanel...o...=136309&hl=

For your device id, in windows Device Manager:
"Sound, video and game controllers" > IDT High Definition Audio CODEC > Details > Hardware Ids.

Here is mine. Please post your one when you have time.

Posted ImagePosted Image

Regards

Unfortunately I won't have access to my laptop till the weekend. Where cam I get the sound card IDs?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy