Jump to content

Geforce 9500m GS (G84), anyone have this up and running? 10.2.5


  • Please log in to reply
29 replies to this topic

#1
dave q

dave q

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hey all,

I have a Asus M51Sn laptop with the Geforce 9500m GS 512mb DDR2. I know it's fairly new but I'm sure someone has the same GPU and possibly has had some luck. It's apparently based on the G84, or rather is a G84. Specs are identical to the 8600m GT. I'm running Leo's 4 all V3, Vanilla Kernel 9.2.0. I've been playing around with the different drivers the last few days with some OS reinstalls in the process :( and have't gotten too far. Here's the process that works most for me:

Install 10.2.5 -> Install Punk92's Nvidia Installer V1.9 and after rebooting, I can change my ressolution and in system properties, it shows I have a 512mb card, but no QE or hardware excel.

I've also tried to do Aqua's Graphics string, which did not change anything... I'm almost sure I followed the directions right, however can never say forsure.

My other question is if this card is a G84, same as a 8600GT, can I force the OS to see it as a 8600GT then? Can I cahnge the ID's so that they match that of the 8600?

Thanks in advance for any help! :)

#2
dave q

dave q

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
:2cents: :2cents: :D :D :D :D WORKING!!!! :D :D :D :D :D :D

Finally got it working 100% !!! NVinstaller .41 gave me Full QE but white menu's. Then I tried Aquamac's 9800GTX driver package (Automated installer) and everything works now. Full res, QE, no white menu's!!!

Now I just need to get the Audio going. :)

#3
NicoOSX

NicoOSX

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
heya, glad to see somebody finaly solved that riddle. I got asus m50sv , 9500M GS 512MB, kalyway leopard 10.5.1 comboupdated to
10.5.3 then officialy patched to 10.5.4. I tried nvinstaller 4.1 , 5.1 , nvkush , but still got white menus ... thanks for help in advance

#4
rob3r7o

rob3r7o

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Cagliari
Here for audio!

http://forum.insanel...howtopic=120579

#5
arak78

arak78

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
I have the ASUS M51SN as you, I'm French...
I have just to install the aqua mac package thats all.

I install kalyway 10 5 1 or 2 and install the aquamac so my 9500M GS will work ?

#6
zerofil

zerofil

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
arak78 I've tried everything under Kalyway 10.5.1 - 10.5.2 - 10.5.3 and I failed making the graphic card work properly (aqua mac files also...and everytime a fresh install) Ihave try evrything twice on a fresh install and it's not working !!! MAD !!
Maybe the solution reside in using Leo 4 all V3.

I'll try to and post soon.

dave q any help would be greatly appreciated.

#7
arak78

arak78

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
Ok you have the same laptop ? Asus M51sn ?
I'm going to try with kalyway...
I come back

#8
rob3r7o

rob3r7o

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Cagliari
My 9500m Gs full work from 10.5.3
i have download PCWiz9800GTX and NVinstaller-V41
Select 512MB

But now i don't remember other, sorry

#9
rob3r7o

rob3r7o

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Cagliari
Have you webcam ok?

with 10.5.0 - 10.5.2 and PCGenUSBehci.... cam ok (cpu=1 for start osx)

But with kabil bios i have now no cpu problem but i have lost my cam.

#10
zerofil

zerofil

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
rob3r7o thanks a lot for you PM and your answers !!

I'll try PCwiz9800GTX ( http://www.filefacto...CWiz9800GTX_zip ) and report ASAP.
My webcam never did work at all but I'm using Kabyl modified BIOS since the very beginning so...

By the way rob3r7o are you using Kalyway or another "package" ?
Do you also remember wich kernel you are using ?
Are you running a 1440x900 resolution (native from ASUS M51sn) ?

#11
arak78

arak78

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
Rob3ro can you send me one PM and explain me step by step how install 9500m gs I have ASUS M51 Sn too.our, whith link to download please... You will be my angel...

#12
arak78

arak78

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
9500M GS WORK for me.
I have install first NV41 reboot and PCwiz9800gtx reboot
so i am 1400 900 resolution thats great..
But still no sound somebody can help me ?

#13
zerofil

zerofil

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
arak78: Is your Core Image software or Hardware ? Also do you have Quartz Extreme supported ?
You can check that in the : apple menu - About this Mac - More Info... - Graphic/Display


i have installed first NV.41 rebooted and installed PCwiz9800gtx then reboot
i am running 1400*900 resolution but no Core Image and no Quartz Extreme

I can't manage to get it working (Kalyway combo updated to 10.5.3, Vanilla Kernel, Kabyl Modified Bios)

Will try under 10.5.4


arak78 with no CI and no QE you will not be able to use your graphic display to the best... for example try to put a picture in full screen mode under iphoto (you'll have a black screen) it will be the same under other graphic apps.

#14
arak78

arak78

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
OK I will se that !

#15
arak78

arak78

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
Yes no QE and no CI !
:)

#16
zerofil

zerofil

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
:) It really is annoying the only thing is to test it with Kalyway updated to 10.5.4 and to test it with other packages (Leo4all)
Unfortunately I could only try this in a week or so...

rob3r7o : wich OSX86 are you using (Kalyway, Leo4All, etc...) ?

#17
rob3r7o

rob3r7o

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Cagliari
With kalaway 10.5.2 + kalaway comboUpdate 10.5.3 QE CI was Ok for me
I'm not sure if we must have graphicsUpdate from apple too

Now i have 10.5.4 (it is a turkis edition)

I have video resolution 1280x800!?!?!

Ok here my 9500m GS kext
http://rapidshare.co..._9500m.zip.html

Put all file in system/library/extensions


here my graphic card
Graphics by NVIDIA:

Modello Chipset: Graphics by NVIDIA
Tipo: Monitor
Bus: PCIe
Larghezza Lane PCIe: x16
VRAM (totale): 512 MB
Fornitore: NVIDIA (0x10de)
ID dispositivo: 0x0405
ID revisione: 0x00a1
Revisione ROM: NVinject 0.2.1
Monitor:
Monitor:
Risoluzione: 1280 x 800
Profondit: Colore 32-bit
Core Image: Hardware accelerato
Monitor principale: S
Mirror: Spento
Online: S
Quartz Extreme: Supportata
Rotazione: Supportata
Mostra connettore:
Stato: Nessun monitor collegato

#18
zerofil

zerofil

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Okay CI & QE ar WORKING !!!
Very simple in fact :
Kalyway 10.5.3 Vanilla Kernel - NV41 installed (512) then NVinstaller_v.52 installed (512Mb selected)
The only thing is to reboot then set up your resolution to 1280x800 pixel millions of color (via system preferences - then display) then reboot again.

It's not the native resolution of the screen of the ASUS M51SN (1440x900) but it works and it's speed !

I Think it's just Apple who do not recognize this strange resolution maybe.

So it's a PARTIAL Solution but very satisfying one !

Thanks a lot robe3to for your kind help.
(By the way your files didn't work with me ;-)

#19
kmikase

kmikase

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 644 posts
  • Gender:Male
  • Location:New Caledonia
I have the M50SV and my geforce 9500 m GS works perfectly. Native resolution recognized, graphic card recognized, hdmi working
I've just installed this : http://www.mediafire.com/?y3qzy1kczew.
Nothing else, no nvkush or nvinstaller. Just this file in library/preference

#20
rob3r7o

rob3r7o

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Cagliari

Thanks a lot robe3to for your kind help.
(By the way your files didn't work with me ;-)


Good!

I hope you can have 1440x900 soon!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy