Jump to content

10.9 Kernel [XCPM-free]

File Information

  • Rate File: * * * * * 1 Votes
  • Submitted: Nov 15 2013 12:27 AM
  • Last Updated: Nov 15 2013 12:27 AM
  • File Size: 3.32MB
  • Views: 17712
  • Downloads: 2,247

Download 10.9 Kernel [XCPM-free]



mach_kernel 10.9 mavericks osx86 xcpm

I compiled this kernel from Apple's source and since they don't include XCPM in their source, this kernel is without it. This kernel is recommended to anyone who experiences instant reboots with the vanilla 10.9 kernel. With the exception of lacking XCPM, this kernel is completely unaltered from the vanilla stock version. A patched AppleIntelCPUPowerManagement.kext from 10.8.5 is REQUIRED if you expect CPUPM functionality.

Please consider rating this if you found it useful. Thank you and enjoy. :D

Credit to RehabMan for discovering XCPM isn't included in Apple's sources when he compiled his 10.9 kernel.
Thanks to ameris_cyning for reminding me to add the patched AICPUPM requirement.




really worked for my haswell inspiron 7737 with boot arguments -x -f GraphicsEnabler=No    when the grey screen appears wait about 5 mins before installation window loads

How to use this mach_kernel....Copy-Paste on vanila USB installer?

How to use this mach_kernel....Copy-Paste on vanila USB installer?

yeah, thats now i did it

Don't forget, if you want power management you MUST use a patched AppleIntelCPUPowermanagement.kext from 10.8.5. 

Thanks for pointing that out to everyone, ameris_cyning. I forgot to mention that. >_<.

 

EDIT: All fixed now. :)

No probs

 

I had to ensure to tell people this because of my {censored} up

 

I patched a 10.9 AICPM.kext not knowing about how much the Mavericks kext had changed

 

So, after seeing my CPU temps at 100c+, I kinda thought something was very wrong.

 

So yes, don't use a Patched 10.9 AppleIntelCPUPowerManagement.kext if you are on Haswell. It must be from 10.8, before the drastic kernel changes.

appreciate it just the same. it's important knowledge and I forgot to include it. plain and simple. :)

Look guy's problem fixed http://www.insanelym...63cl-i7-4700mq/

But I do not know if it works on Ivy Bridge CPU.And follow this http://racerrehabman...r-early-reboot/ and this https://pikeralpha.w...h-for-maverick/

Good luck.

does not work with AMD Phenom X4 9500

how does one go about transplanting this file?

I'm now not too sure if i did it correctly,

as I'm still unsuccessful at getting installation usb to load installer on a g3220.

it used to freeze on xcpm: registered (left it for hours),

now it doesn't produce that error but it stops at hfs: mounted USB on device root_device.

tried a bunch of flags but still hangs here.

any thoughts or input?


  • 240 Total Files
  • 13 Total Categories
  • 111 Total Authors
  • 484,199 Total Downloads
  • QE_CI Exotic Patch Latest File
  • fantomas1 Latest Submitter

64 user(s) are online (in the past 30 minutes)

22 members, 42 guests, 0 anonymous users


emilz23, Probir, tntkj, dimkatt, Ivan Nogueira, kikokyo, yuvsch, salien, max300, rubs122345, Blocksssss, nutella5600, FalkonLink, fabiots53, shiux, mcjam, Mieze, doels, quochau55, Jorge_CS_, Stroumphs, aazlm

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy