Jump to content

No "NX/XD" in bios... why?


dekpient
 Share

4 posts in this topic

Recommended Posts

I've read.. if I want to use efi+vanilla, i have to enable "Execute Disable" in bios to aviod the reboot after kexts loaded. But in my aspire 5594 Phoenix Bios does not have that function, Why?

I attach my CPU and Motherboard spec.

 

anyway to enable that or use vanilla kernel?

 

Ps.I can patch efi_v80 successfully but after install vanilla kernel from "kalyway 10.5.2 kernel", it keeps saying "You must restart your system, please hold on power button" ..sth like that. how could i fix it?

 

Thanks

 

my system is iAtkos v1.0 r2 + efi v80 and update to 10.5.2 by kalyway combo.

post-157830-1207935963_thumb.jpg

Link to comment
Share on other sites

I've read.. if I want to use efi+vanilla, i have to enable "Execute Disable" in bios to aviod the reboot after kexts loaded. But in my aspire 5594 Phoenix Bios does not have that function, Why?

I attach my CPU and Motherboard spec.

 

anyway to enable that or use vanilla kernel?

 

Ps.I can patch efi_v80 successfully but after install vanilla kernel from "kalyway 10.5.2 kernel", it keeps saying "You must restart your system, please hold on power button" ..sth like that. how could i fix it?

 

first you need to use -v as boot flag (i wonder how many posts about this there are on the forum :D ) so you have a slight chance to see why it is failing.

 

If you have not the option in bios it is because 1. your cpu dont support it or 2. it is enabled or 3. disabled by default. Most likely no. 2.

 

thank you and bye bye

Link to comment
Share on other sites

the core 2 duo T5600 have yes NXBit

 

check you bios settings if not disabled, or in case, try a bios update (if you have way to make this, some pc manufactures uses poor bios).

 

btw, goodluck :D

Link to comment
Share on other sites

 Share

×
×
  • Create New...