Jump to content

Some unresolved problems of 10.5.2 on AMD PC


3 posts in this topic

Recommended Posts

Hi, Everyone. This is my first post. I'm so glad that I can post this under Leopard, and to discuss my problems with you guys.

I have installed Zephyroth's Leopard 10.5.2 for AMD rev2 on my old AMD PC for about one month. I have to say, this is a month of panic. I have encountered almost every problem one may have-- no bootloader after installation, tboot wont dual boot with XP, kernel panic when booting(fixed by changing kernel and appleacpiplatform.kext), cant boot with ps2 device(fixed by disabling usb mouse/keyboard support in BIOS), nv8600gt driver conflict with nforce mobo, nforce ehernet with forcedeth.kext not stable(I finally got a RTL8139), finder crash opening "about this mac"(fixed by changing applesmbios.kext), VPN compatibility with windows and so many problems that I cant remember clearly.


When facing those things, I struggled, searching internet and forums days and nights, finally, I got them all fixed. Now I got all the dirvers installed and functional, I can browse internet using Firefox, listen to some music, watch a couple of movies, even use office 2008/acrobat pro/googleearth...But it seems, this Apple field are still not "entirely stable". I still have some issues, that I searched hard through the internet but still cant get a clue. I guess maybe it's the time for me to ask for some helps...


First, my PC spec:

CPU: AMD athlon64 3000+(754pin) support sse2 sse3

MOBO: Biostar NF4-4X-A7 motherboard

Memory:1GB kingston DDR400+1GB apatar DDR400

GFX: 8600GT 256M

HD: WDC WD2000JS 200GB+ WDC WD3200YS 320GB

Sound: onboard ALC655

Network: onboard nforce ethernet(disabled), PCI RLT8139C

PS2 keyboard and mouse


Leopard version: Zephyroth's Leopard 10.5.2 for AMD rev2

boot loader: I'm not sure, after installing, I got no boot, I use a method from internet to fix the boot sector and MBR and Darwin bootloader

Mach_kernel: From some kernel panic informations, I can see, it is ToH's 9.2.0 kernel

kexts: I change many of them, some from BrazilMac(?), some from a "Leopard-X86-flat-img", they are "AppleACPIPlatform.kext, AppleSMBIOS.kext, ApplePS2Controller.kext" and maybe System.kext, I tried a lot of combinations to finally boot to the system, but I cant say which from where now :D



Now, those are my problems:


1. In "about this mac", it is said Processor 2.01GHz Unknown and Memory 2GB 333MHZ DRAM, in "more info", it is said "AMD" Athlon 64 3000+ @ 2.01GHz, Bus speed: 200MHz. In Memory table, only one bank is shown: A1: 1GB, 333MHz.

Another one is missing. I remember once I can see two bank shown, but that AppleSMBIOS.kext cause finder crash when click "about this mac".

I think the memory speed maybe also wrong, but if those are only information errors, I wont be bothered with them. But if you can enlighten me how to fix those thing, which kext is related to those, I will be glad to have a tryout.


2. Sometimes, about once a week, I got kernel panic while doing random things. once watching a video from VPN neighbor, once open a smb server, once install some apps. none of them gave a panic.log, so I cant address the issue. So I'm being worried about the wrong informations in my system profiles. Are they related to those kernel panic? Could any one tell me how to log those kernel panics at least?


3. I once installed a NV GFX driver, the version is 5.2.2, to be specific, I just download related kext files and OpenGL files, they may be extracted by Pacifist, I put them in proper location and repair permission, but I got random freeze after that. mouse can move but shown a spinning ball, nothing responding. After restart, I find NVchannel(GL) timeout! in console. I searched the internet, found out the even real mac users encounter this problem, and so long, no fix to that. Today I download and installed NVkext.41(driver version 5.2.6), until now, no problem. hope this can fix it.

BTW, after install NVkext.41, I got a lot of "exited abnormally: bus error", when quicklook previewed an item then I closing the finder, and also when selecting a screensaver in system preferences. I replaced the old OpenGL.framework and fixed the problem. I noticed the old OpenGL has a SourceVersion 50612 but the new one is 50620. Don't know why.


4. other minor issues: use ichat login google talk, when chat with someone, give me a "add at least one person to chat" error. Msn told me a "wrong account or password" no matter what I typed in so I cant login. many "abnormally exit" when using Remote Desktop for Mac 2.0 beta.

I also have a Core2Duo Machine in my office, I also installed Leopard 10.5.2, It seems dont have those problems above.


Oh, dear, such a long post, if you can finish reading it, I thank you! Forgive my poor English. If you can give me some suggetions, it will be so helpful!

Link to comment
Share on other sites

  • 1 month later...

1. use this program by zephyroth to change your about this mac http://forum.insanelymac.com/index.php?showtopic=105162


2. No, the lack of info in system profiler etc. is because OSX wasn't designed to be friendly with any hardware that apple doesn't use (and alot of hardware they do use, 8800gt *cough*) From your post, I can see that you have already figured this out. I don't know what to say about your panics, except that it isn't the fact that your processor shows up as "unknown" in about this mac. That said, do a google search for "kernel panic" leopard and you will see that getting OSX 10.5 working only opens the door to a sea of troubles that even Apple customers experience. Apple sucks, and they prey upon ignorant customers and are mediocre in support, design, and marketing. I had been a mac fan boy for 20 years, and I mean hardcore. Today, I see little difference between Apple and Microsoft. The reason that your average joe sees a big difference is because apple has focused all of its wasted potential on looking cool, as evidenced by those insanely stupid tv ads with the straw-man PC representative... There actually used to be things about the computers that set apple apart from the competition, but they have always taken advantage of people who don't know anything about computers (typically with inflated component and repair prices or silly arguments about RISC processors) and they convinced those same rubes that they are all 1337 hax0r5 in the process. To avoid being flammed, I want to make it clear that I do think OSX is awesome... but it probably wont be for very long. sorry for the rant... have you got panic logs yet?


3. I have the same graphics lock up in zephyroth 10.5.1 using the 10.5.2 kext and nvkext .33

Did NVkext.41 solve your problem?


4. I have no clue about your ichat ish.

Link to comment
Share on other sites

  • 1 month later...

How time flies! While doing some random google search, I found my own post posted many months ago. I never expect anyone to reply my long boring post, so first great thanks to sciencefictionado!

I'm now using eddie11c's Leo4allv3 and update to 10.5.4, almost everything is fine now. About this mac shows correct information, no more graphic hang/glitch, no more kernel panic, no more abnormally exit, wonderful! Those kernel panic and abnormally exit were caused by those damn CPUID, as I am an AMD user. So you know how stupid I was at that time. As soon as I know how to use Marvin's AMD Util, everything got fixed.

The ichat and MSN problems were caused by some glitches in zephyroth's version, anyway, it's still a great installation, although Leo4allv3 is greater, IMHO.


So now, I'm running newest Leopard on an AMD machine smoothly, except following problems:


1.Sound Card is Nforce AC97 audio (alc655), using appleac97audio.kext. Sometimes I can not control the volume properly, especially using MIDI software like Guitar Pro. Volumn just reset to default and I cant change it by volume bar.

2.When I connect a windows system by microsoft remote desktop connection for mac 2.0, I got annoying sound output from windows based computer. For example, I logon MSN in windows, when someone chat with me, my Leopard not only receive notifying sound, but also crappy sounds like someone put a phone near your speaker.

Link to comment
Share on other sites


  • Create New...