Jump to content

OSx86 SATA Problems


5 posts in this topic

Recommended Posts

Hello All!


First of all, I would like to say Hello! This is my first try with OS X. I have always been with either Windows or Linux, and I love Apple computers, but have never had quite enough money to buy one. So, I am creating my Hackintosh; my OSX CD is the Leopard 10.5.1 Developer Preview. Here's my pertinent system information:


Dell Inspiron 1501 Notebook

Processor: AMD Turion 64 MK-36 Single Core

Memory: 896 MB (2x 512 MB)

Hard Drive: 60GB SATA

Onboard LAN and Wi-Fi

SD Card Reader

4 USB Ports

Audio: Sigmatel STAC 92XX

Video: ATI Radeon Xpress 1150


My other Hackintosh wouldn't even boot into the installer. Here's its stats:


Gateway 500S Desktop (circa 12/02)

Processor: Intel Pentium 4 Brookdale 2.0GHz

Memory: 256MB SDRAM

Hard Drive: 30GB ATA

Onboard LAN, Linksys 54G USB Wi-Fi

6 USB Ports

Audio: SoundMAX ???

Video: Intel 82845G/GL Integrated


First off, why couldn't the Gateway boot? It got into the Mach kernel (I didn't type anything in at the startup). It went about to all the way down the screen, blanked the screen, and rebooted. I tried it in VMware also, and it restarted, and I can't right off remember, but it said something about a CPU failure or something.


Then, I tried it in the laptop. It booted just fine, and then when it got to the "Where would you like to install it?" screen, there was nowhere to install it to. So, I went to Utilities>Disk Utility. Nada but the CD. Went to System Profiler. Nada but the DVD drive on the ATA Bus. No SATA device recognized. Everything else looked good.


Anything I can do? I have heard that SATA is supported, but no dice here!

Link to comment
Share on other sites

Source: http://www.amd.com/us-en/Processors/Produc...1^12663,00.html

The AMD64 core provides leading-edge 32-bit performance, seamless 32-to 64-bit migration and therefore investment protection


AMD64 technology features uncompromising 32-bit performance and is ready for tomorrow’s software, today.

Vastly expands memory addressability with 40-bit physical addresses, 48-bit virtual addresses

Doubles the number of internal registers with eight additional (sixteen total) 64-bit integer registers and eight additional (sixteen total) 128-bit SSE/SSE2/SSE3 registers

Incorporating 3DNow!™ Professional technology, SSE2 and SSE3, AMD Turion 64 mobile technology is compatible with the largest installed base of multimedia-enhance software


So, it does have SSE3.


And as for the disc, I made sure that it was an OSx86 disc.


The title of the torrent that you can find at The Pirate Bay is: Mac_OS_X_Leopard_10.5.1_for_AMD_SSE2_SSE3_(32bits)


The DVD is patched to run on your PC, all installation packages are originals (except MacOSXUpd 10.5.1 which needed to be repacked) and patched automatically in the end of the installation process. Darwin bootloader is installed at the very end. (See FixLeo.pkg)


Only English and French are available.

Gutenprint Printers Drivers and drivers for Geforce 8800GTX/GTS(NVinject 0.1.3) are available too.


It runs fine on the following machine :


- Athlon 64 X2 4200+ S939

- ASUS A8N5X NForce 4

- 4 x 512 MB DDR400

- Maxtor 250 GB Sata2

- Geforce 8800 GTS

Link to comment
Share on other sites


  • Create New...