Jump to content

Network shares not working

Silent OSX

11 posts in this topic

Recommended Posts

Hi everyone!

I can't connect to servers in Leopard. It says the the URL is invalid eventhough I use smb:// or afp://. In finder the shares are showing up but I get connection failed. The "connect as.." button doesn't seem to work either.

I can ping the other computers just fine.


I tried using my old modified 10.4.x kext but the problem remained the same.


Has anyone got the same problem and/or know a way to sort this out?



Zephyroth 10.5.2 rev2

AMD Athlon64 3500+

DFI Infinity RS482 (x200/SB450)

(built-in Realtek RTL8110SB Gigabit PCI LAN)




Link to comment
Share on other sites

  • 2 weeks later...

I have the same problem. I am using 10.5.2 leo4all v2. I found this: http://docs.info.apple.com/article.html?artnum=307256 - but it didn't help. I've also tried repairing permissions and also tried replacing the System/Library/Filesystems with the files from the leo4all v1 because I didn't have this problem with leo4all v1. What is the difference between them that could be causing this? The document linked above mentions migrated user accounts - that doesn't apply to me as both installs were done on freshly formatted partitions.


Any ideas?

Link to comment
Share on other sites

The problem was the Time Machine and Airport Utility upgrade that was included with packakge (Leo4All v2) or the TIme Machine Fix. I have Kalyway 10.5.2 upgrade (except the Time Machine and Airport upgrade) before and my system work flawlessly meaning I can connect to my shared drive (a Maxtor) connected to a router in my local network but sadly it stopped working when I installed the Time Machine Fix from Leo4All DVD...so back to square one I guess!

Link to comment
Share on other sites

I have just started with OS x, having run WinXP & kubuntu for a while. :)


I havent experienced any problems reading & writing to OS X from windows. It sometimes takes a little while (15secs, max 2mins) after I boot up my XP machine for it to join its workgroup, but the OS x computer is there always immediately. I use an XP home machine with my data on a USB ntfs drive. I can browse read write all the partitions (ext3, hfs+ and ntfs) on os x box from there. when I type ipconfig /all at the XP command prompt, my XP box is listed as a hybrid node (?).


I have had much more problems in the other direction, trying to access XP fileshares from my OSX box. With Kalyway 10.5.1 Its fine. After I use connect to server (samba) my XP box shows up in network and the finder.


My problem is that since the kalyway 10.5.2 update XP can see, read, write to my OS X box but not vice versa. After I kick start a connection by browsing OS X from XP, I can see the XP box & fileshares, but when I try to access them I get an error: "error 6604, the original file cannot be found", options to delete or replace alias & drive cannot be mounted -depending on whether I am in the finder or using connect to server (it times out).


I have searched quite a bit for the exact error message on the various apple forums. It seems to be a very common problem. more so with later OS X versions, particularly 10.5, and not just with hacintoshes but with brand new macs right out of the box. Although I haven't solved my problems & will carry on using 10.5.1 till I do (i have both installed), all sorts of fixes and workarounds have been proposed -sometimes they work. The only consistent facts I found are:


1) Later versions of OS X have increasingly tighter network control policies, particularly 10.5. increasingly difficult to share with windows, particularly vista.

2) The problem may might be with the XP home machine having much less configurable network access. Simple file sharing could be implicated in this, but with XP home you cant disable it. with XP pro this might solve the problem as "LAN communications are always encrypted when using simple filesharing" - this sounds illogical but thats what i was told.

3) highest number of posts is from Macbook Air customers who are trying to access a non-mac network DVD writer. I have seen an official mac support reply posted that said "you need to buy a mac superdrive, your system is not configurable to use third party network dvd shares". So maybe this is one of the driving forces in making OS X increasingly difficult to network successfully with windows - to sell more mac hardware.


Having looked on mac forums for so long, my impression is that my problem is a "standard mac problem" & not because of a mistake in os installation. Time and again I read "you can definately get round this problem, but you might need a network pro to configure it".


I would much prefer to use 10.5.2, until I can sort it I need to keep using 10.5.1, and tweaking 10.5.2.


Can anyone help -at all? I dont know how to diagnose lan connections at all, all I know is ipconfig & netstat.


AlbertE, your system seems to work with 10.5.2, can you shed any light on this issue? How did you install the 10.5.2 update without installing the time machine & airport upgrades? I thought it was just a fully automated package, without install options.

I havent managed to make much sense of kalyways notes, when I open one of his archives I see a lot of unreadable files -I cant figure out how he structures his archives. I just end up picking out the installer from it & using that..


Pentium M 735 1.7GHz (SSE2)

Kalyway 10.5.1, 10.5.2 combo update, Original 10.5.1 kernel

Realtek 8139/810x Family onboard LAN

Link to comment
Share on other sites

OK, if you ruled out your network driver, the other problem I ran into when sharing between macs was the security. I had heard a tip where you could become invisible on the internet using the new Leo option under security to not allow others to see you, limiting access. I had turned that on, but Apple File Protocol (AFP) was an exception in the list that came up by default. For some reason, it was still blocking the sharing using that option. When I changed the settings back to the default, the sharing started working again. Now my sharing is working great between my SSE2 hack, SSE3 hack, and a Mac ibook G4, all running 10.5.2. And my ethernet printer works great with all three connected by wireless.

Link to comment
Share on other sites

never mind, AlbertE -Fixed it.


it seems the problem with my samba shares was due to my bungling.


I restored my 10.5.1 image, Kalyway combo updated to 10.5.2 & that was it. I have an SSE2 chip so I didnt bothe updating the kernel or system kexts. It works just fine.


Maybe I can get some sleep tonight...


kwaaku aka justifiably ouraged

Link to comment
Share on other sites

I ended up getting this fixed by replacing some combination of the files and dirs under /System/Library/Filesystems


Unfortunately, I wasn't being very methodical in my efforts, so I can't say exactly what combination I replaced. But I got most of the replacements from the Leo4all v1 disc.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 months later...

hallo guys...

im a newbie.. here


i just install mac in place with leo4allv3...

i install it at two pc

both for the network card is working out of box


but when i try to connect this two from router both got error

but if it just one work it could connect to other windows perfectly....


ken-ken khabare? from bali

diak ga lae? from east timor

Link to comment
Share on other sites

  • 1 year later...

  • Create New...