Jump to content

I want my old kernel back


3 posts in this topic

Recommended Posts

So I updated to 10.5.2 using kalyways comboupdate, worked great. I decided to install the new kernel on my pentium D machine, worked not so great. It boots and everything but it killed my sleep functionality which I used to use a lot. I was wondering if there is a non-destructive way to get my old ToH 9.1.0 kernel back. I am well versed in Linux so the command line isn't a problem, I just want no data loss, if possible. I saw a topic on restoring an OS X kernel in some topic a while ago, but it just is not coming up when I search for it again. I think there was an easy way to do it that was just replacing a few files if I'm not mistaken.

Link to comment
Share on other sites

Your old kernel is actually left in root in different name.


"tohkernel" or "mach_toh" , I do not remember right clear.


com.apple.boot.plist: booting kernel name is "mach_kernel"




Boot install dvd. Open terminal.


cd /Volumes/xxxxxx (<-Yours bootdisk name here)

ls -la (You see what is old kernel name)


cp mach_kernel mach_kernel92 (copy 9.2 kernel with new name, if You want to do that)

cp -f tohkernel mach_kernel (copy tohkernel over mach_kernel)


chown root:wheel mach_kernel* (fix owner so rightness...)

chmod 644 mach_kernel* (and userlevel to right)


Reboot. Should works now with new (older) mach_kernel version 9.1

It sleeps and wakes well. Only problem is usb automounting, which

is broken. (in 10.5.2) - Someone fix it soon, I presume.


I hope that this help You.




Nasty and ugly way to replace the kernel:

(without boot dvd)


Put the new kernel on the desktop.

Rename the file to " mach_kernel "


Open terminal and type the following:


sudo -s

cp -R ~/desktop/mach_kernel /mach_kernel

diskutil repairPermissions /


reboot (your machine)




New kernel: Colloquy ; irc.osx86.hu ; #10.5

(= program, irc server, irc room)


You can find there link in rapidshare, where the

new kernel and other things are.




Ahh... and this works in THIS situation.

Moving back 9.2 -> 9.1 works well without

anyother fixing.


In common... hmmm... the other guys know better.

(= netkas, team of hackintosh etc.)


Kernel is pair with it's own system kext and _maybe_

with applesmbios.


Normally I personally do not mixing different part of system.

If someone do that, reason must be good. Like this, needed

sleeping not work well in new system.


When new sleeping kernel 9.2 is ready,

I recommended use it.



Link to comment
Share on other sites

something more simple in order to test if the old kernel still works

download onyx or any other app or maybe there is a simplest way to "show hidden files" in mac

paste your old kernel with whatever name you want in /root

and at darwin boot just type: thename_oftheoldkernel

if it works ok delete the old ,rename the one you want to use to mach_kernel and it will boot allways with this

there is no need even to repair permissions etc

Link to comment
Share on other sites


  • Create New...