Jump to content

Ethernet disappears after restart (!)


18 posts in this topic

Recommended Posts

Hi all.


I've instaled Kalyway 10.5.1, and after several attempts it worked very well, but only the first run. After first restart, the system can't find the Ethernet card anymore.


I've tested several things, but only partitioning the HD again it works... but only until the first restart.


I have a Abit motherboat with onboard Broadcom 57xx Netlink.


These are my installer options:



- Vanilla Kernel *NO*

- SSE2_System *NO* (mine is SSE3)

- NVINJECT ... desktop (with a GeForce 7900 GT/GTO)

- AZALIA_out (with Realtek audio)


- Realtek network, YES & NO, same results (with Broadcom 57xx Netlink in Abit motherboard)


- EFI Guid


Please, anyone can help me with the ethernet?

Thanks a lot.

Link to comment
Share on other sites

That's the same thing that happend to me!

I'm using ToH isntead of Kalyway, and I installed and ethernet/network works perfectly but then if I reboot it, my card is sitll detected, but it says the cable's unplugged (but it's not, checked in XP). And if I rebooted it 4 times then it worked! :blink:



Stock Dell Dimension 4600 with:

Nvidia Geforce 5200 128MB

Hitachi 160 GB Hard drive (dual booting Win XP)



Intel 10/100 Ethernet

Link to comment
Share on other sites

If you "restart" the system your network card will be disabled. If you turn off and then turn on the system, the card will work properly. To be sure unplug the power cord, in my laptop I must do like this...

Link to comment
Share on other sites

I think is the same problem for we all.

I've restarted several times with no result.

The system can't find the network card after first restart.

But it works fine once! There must to be a solution for this!

Any expert is listening here?

Link to comment
Share on other sites



The motherboard has 2 interfaces-connectors, but in the network preference pannel only appears one.

Just adding another connection ('Ethernet 2') and it runs.

Very simple but I did not know where to look, and was quite disconcerting that it worked the first time...


So you can take my config as one that runs ok with Kalyway 10.5.1 (Not full tested yet, but the basics works well)

Thank you all and good luck!

Link to comment
Share on other sites

If I boot to my Windows XP partition, and then boot Mac, my network says not connected.


I have to turn off the computer and the switch off the power supply for a few seconds, and then boot. I think this is my motherboard (GA-P35-DS3L) or WinBlows XP and not OSX.


Heres why:


After I shut down or reboot from the Windows partition, the ethernet lights on my motherboard do not light up on post. It's as if the ethernet is unplugged (exactly what OSX reports), maybe windows turns off the nic on shutdown or reboot?


I'm talking about the bios post, before even loading OSX. After shutting off the power supply and then back on, my link lights come on, and when I boot OSX it's working fine.


This problem only happens to me after loading windows and then switching back to OSX, I have them on different drives and use bios boot select on startup to choose which drive to boot from. If I never boot to windows I never have the missing network problem.

Link to comment
Share on other sites

This same issue happens with the Gigabyte P35-DS3 boards that have an RTL8139 NIC inside it.


The solution for us is to boot into Windows (XP or Vista), go to the Properties for your network card, select "Advanced", and there is a setting that is something like ""Wake on LAN after shutdown" that needs to be Enabled.

Link to comment
Share on other sites



i had exactly the same thing with my kalyway 10.5.1 install, when made any changes or rebooted the sys prefs said that the nic was unplugged... I solved this by simply replacing the IONetworking.kext from a 10.4.9 Uphuck install to my Kalyway 10.5.1 install, made the necessary permission changes to the kext and it`s been 100% stable ever since... Infact it seems quicker since i did this aswell.


hope this helps, specs for mine are as below sig...

Link to comment
Share on other sites

  • 7 months later...

For me the fix was:


My Computer > Properties > Hardware > Device Manager > Network Adapters > Broadcom 44x 10/100 Integrated Controller > Properties > Power Management: and then I had to check "Allow the computer to turn off this device to save power" AND "Allow this device to bring the computer out of standby"


Now OS X sees my ethernet on every reboot.


Running iAtkos 4i on a Compaq nx7400

Link to comment
Share on other sites


  • Create New...