Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Sign in to follow this  
dkelley

[HowTo] Fix Auto-Rotating Images Bug

Recommended Posts

ok, this is just a note about something I figured out on my own last weekend. When I was looking at a new core duo 17" imac in Future Shop recently I found it to be performing terribly, locking up all the time then unlocking after 30 to 60 seconds, then locking up again a minute later. It was awful, made the machine seem like a piece of junk.

 

I went home and found the same bug on my hackintosh... you can replicate the bug too and then go back to a fully working system by doing the following:

 

in your system prefs/desktop image chooser, turn on the checkbox for automatically rotating the desktop image and set the interval to every 5 seconds. I don't know if this has problems on machines without QE enabled, but on my hackintosh and on 10.4.4 systems you'll get wonderful transitioning background images (if you have one of apple's groups of background images chosen, such as the default osx blue background image). BUT - after a little bit you'll experience the same seemingly random lockups that I found, with wierd things happening in application and mouse performance. Turn off the auto-rotating images every five seconds feature (uncheck it), reboot, and all should be well again.

 

This is a nasty bug - one that I don't think was in the ppc macs from what I can tell. If you find your mac or a store's display mac doing this strange thing, check if the desktop is changing at regular intervals. If it is, turn that feature off. It looks beautiful if it works, but it doesn't, so let's not use it until Apple fixes that bug.

Share this post


Link to post
Share on other sites
Advertisement
I found rotating paper to be annoying at least on my Mac Mini. The chipset in the Mini does not support CI or QE, so this may well be the main problem.

 

haha - it IS annoying on a machine without QE or CI since it doesn't do the smooth transitions. I tried it on my dell laptop just now and found it very irritating! I'm not sure if the same problem exists for osx86 users without qe or ci though, since my dell laptop crashed almost immediately after I did this. Might not be related, I don't have time to find out right now. But certainly on osx86 WITH QE AND CI, with those fancy transitions, something is seriously wrong with the OS code since the finder will lock up and then unlock at irregular intervals when this setting is turned on.

 

annoying is true though, so hopefully this isn't a bug that most people will run into. I only noticed it and figured out the cause when I saw an imac core duo in the store that was already setup with the transitioning backgrounds when I got there. Now that I know the cause I'll go back to that machine (w. broadway future shop in vancouver bc canada) and turn off the transitioning desktop feature if it's still on. I don't want pc users thinking macs suck because their demo model exploits a bug in the os that isn't even important!

Share this post


Link to post
Share on other sites

Just tested this on my Pavilion laptop (ATI Radeon 9000: not ATI kexts loaded, no CI, no QE, just plain VESA): works fine for me here...

Share this post


Link to post
Share on other sites
Just tested this on my Pavilion laptop (ATI Radeon 9000: not ATI kexts loaded, no CI, no QE, just plain VESA): works fine for me here...

 

I'm thinking it's a QE CI thing. QE and CI are the accelerated graphics systems in osx. quartz extreme and core somethingorother. on both my accelerated hackintosh and on two real imac core duos this bug exists.

 

unless we're seeing something else - maybe it's an interaction between a certain display resolution and the auto-rotating desktop image thing, something like that.

 

Very annoying either way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×