Jump to content

My True "hack"intosh Wireless Solution


17 posts in this topic

Recommended Posts

Hey Guys


Well after buying my Acer 5570-2997 I realized that I would never be able to get the AR5007EG working. Been on every site, almost every page and kept getting the same answer, mini-pcie slots will not power up in my computer. So I was left to buy a USB wireless card. Well this is fine and dandy, but like all other small USB devices they either get left at home, lost or are just so cumbersome they being to be a pain in the ass. Well I came up with my own solution, USB inside my laptop!!


What I started with was a Belkin F5D9050 v3 and my 5570z. My plan was to solder the USB card inside the back plate of my laptop.

I had already installed the Ralink Network Software and was able to configure everything perfectly.


So I did some research and found some USB Pin Layout prints.

Removed my computers plastic shell (this took some time!)

On the back of my computer I have two USB ports

I saw where the leads were soldered to the board and did some testing.

Found out which leads were +5 D+ D- and Ground

Next I was able to find a three foot USB extension cable

Removed the entire sheathe so I had the four wires exposed

Soldered the wires to the board

Did some power tests

Rerouted the wires in the computer so they would not be the way of other devices.

Mounted the USB wireless device to a previously used mount

Reassembled my computer (placing a blocker on the USB port that I stole, to prevent accidental plug ins of other devices)

Started the computer to find out I still needed to configure the RT2500Replug.kext (had to add my device ID!!!)

Once that was done, a quick reboot of the computer, logged in and BAM wireless right off the bat!

Im posting this within 10.5.1 (completely up to date via Software Update) on my schools wireless VPN network!


Some pics











Hackintosh's Rule!!! haha


Have fun guys!!


And yes, I did end up leaving the AR5007EG installed for use while in Vista (which is about once a month...lol)

The Airport Wireless Meter is just for looks (for now)


Link to comment
Share on other sites

Awesome idea!


I've been considering doing something similar, though I'd probably take the time to track down the phantom usb lines inside my laptop... Windows says I have 6 usb ports and 2 are in use (internal camera and card reader), with only 3 ports on the outside of the case... meaning there is one more usb port provided by my chipset that is not connected to anything!


Failing that, I'd probably sacrifice one of my pci-e ports, which have usb embedded in them... though since they only provide 1.5v and 3.3v, I'd have to track down a source of 5 volts somewhere in my laptop...


I got this idea from http://forums.eeeuser.com/ - where you'll be able to find some photo walkthroughs if you plan on freeing up that external port for better uses.


Smooth hack though, I hope mine goes as well (if in fact I can't get the pcie in my laptop to work)...

Link to comment
Share on other sites

The 6 pin plug between the wifi card and the modem card is a USB port.

I have my bluetooth module plugged into it.



You've go to be kiddin me :P Oh well, guess it would pay to do some research before I hack!


Thanks though, I might install my bluetooth dongle now :(

Link to comment
Share on other sites

Wow that is pretty nice lol. Also my Mini PCI slot works (if the mini pci slot is the slot on ur laptop board that looks like a mini pci slot) and I have working Wireless too (I just installed Leopard and it worked).


Yeah the difference is Mini PCI Express, many older acers have the mini-pci which works fine. My model on the other hand (the one that came with AR5007EG) doesn't power up the mini-pci express ports.




Wireless signal has suffered greatly after installing the device inside the computer... but there is always Vista if i'm in an area where Leopard wont pick it up.


Really wish some how, someone will chime in with the "I fixed the mini-pcie problem!" but thats just wishful thinking.

Link to comment
Share on other sites

Read in another topic here about the mini pci-e problem and someone mentioned a solution by taping over pin 20 to make sure that the card is powered all the time.


I have an Acer Aspire 5630-5633WLMI with an intel card so i haven't been able to use it at all in OSX.

I have noticed though that it seem to have both a mini pci-e (currently housing the intel card) and a free mini pci.

I'm guessing that the free slot is for the bluetooth/3G card that is available.

Considering to find an OSX compatible wireless card and try it out

Link to comment
Share on other sites

I followed your "hack" to a degree.


I was using a USB wifi externally for networking, now it's inside like yours.

I put a mini 6-pin plug on a female USB plug with about 4" of wire. The

wifi adapter has a spot on the on the board for a mini coaxial connecter.

I happened to have an old mini pci wifi card so I desoldered one of the connectors

and (carefully) soldered it to the spot on the USB adapter. I use the aux antenna

connection and the reception is pretty good.


If you've got a steady hand and a mini soldering pencil I would recommend the

additional antenna connection.


I think I going to try to split the plug to two ports, I really want my bluetooth back.


Some fun, huh.

Link to comment
Share on other sites

^^^^ What model is your Acer (5570-XXXX)??


For some reason, the Acer's that came with AR5007EG wireless cards just don't work, no matter what card you install, taping the 20th pin, change kext files... nothing..


Yep I can confirm that the 5570-2094 also doesn't work. I spend almost $100 on Mini PCIe cards, I now have a Gigabyte Atheros card (AR5006EGS), a Dell Broadcom (TrueMobile 1390/BRCM4311), an Apple Atheros (AR5006EXS) and the OEM Acer AR5007EG. None of them work.


Fun fun. And I do hope someone comes up with a MinPCIe fix, because my USB wireless (Belkin F5D7050, Zydas) doesn't work in Leopard.

Link to comment
Share on other sites

  • 9 months later...

I have a question. This may seem noobish but here I go I have a Spartan Laptop (msi gx700 clone). and i have 10.5.5 installed and i have a f5d9050 V3 and it works to an extent except after a while it will drop the connection and i have to unplug/plug in the adapter. i usta have a f5d9050 v4 but it just quit on me all of a sudden so i exchanged at walmart for the same one (belkin wireless G mimo) and the new one i got was a version 3. I also had the problem with a belkin wireless N usb.. thats why i went and got the belkin G mimo


Does anyone have any ideas?

I have installed the USB fix and followed msyticus C's directions on his post for doing the 10.5.5 update and it all went thru OK except i had to restore a Kext for the ps2nub.

It seems to drop wheter in 10.5.2 or 10.5.5 (I use kalyways 10.5.2 dvd to load it)


The chipset is a PM965 and the cpu is a core 2 duo t7400 2.2

4gb of ram 8600 nvidia grafix card

i have a hacked bios flashed to it (off osxcores.site50.net) thats how i got OSX to recognize both cores without just rebooting.

the version 4 worked fine until it just quit . the v3 f5d9050 works fine but after a while just drops the connection. i am using drivers off belkin's site (they are 10.4 drivers) could that be it?

anyone know where they have the 10.5 drviers for my usb wireless

Any help will be appreciated


Link to comment
Share on other sites


  • Create New...