Jump to content

Network connection disappears after some time


7 posts in this topic

Recommended Posts

Hello, I have installed the Kalyway 10.5.1 DVD on my system:


Intel Core2Quad Q6600 2.4GHz

Asus P5K-E Wifi/AP

4 GB PC6400 mem

Samsung 320 GB SATA


XFX Geforce 8800GT


When I installed the system, I used the vanilla kernel+AHCI patch and the GUID bootloader (I partioned the disk with GUID type). After the installation, I installed the Geforce drivers from this thread: http://forum.insanelymac.com/index.php?showtopic=78980 and the audio drivers from the p5kefix_leopard script (I commented out the other drivers as I wasn't sure what they did). I have had to add a kernal flag to the com.apple.Boot.plist to limit the memory to 3200MB, otherwise I would get kernel panics when idling (very strange).


Everything runs ok, except that after a few (10-20) minutes of intensive network traffic, my network shares (from an OSX-10.4.11 machine) disconnect and I'm unable to reconnect. Only after a reboot can I reconnect the network shares. Other computers in my network are still able to connect to the shares, only the hackintosh isn't, so I'm convinced it is something to do with this system.


I did install the latest update of iTunes, Quicktime and the security update 2007-009 (and two other things). Could this be causing the problems?

Link to comment
Share on other sites

Ah, how forgetfull of me. I'm using the cable which is connected to a switch. This switch also connects my macbook to the server, so I'm pretty confident it's also not the switch.


The network was working out-of-the-box with the Kalyway DVD, so I didn't install any extra kexts for it.


/edit: I'm now going to reinstall everything to see if the software update was the culprit


/edit2: No, without the software update, the system also loses connection to the server.


If there's one thing I need to be stable, it's the network. What is the best NIC I could alternatively use?

Link to comment
Share on other sites

  • 2 months later...

A little update. After upgrading my network (switch, cables) to gigabit, I found that the onboard NIC wouldn't go into GBit mode. The link always showed up as 100Mbit in the device info. This was also true in windows XP with the latest drivers. I tried the cable on another system and this could do 1000Mbit, so it's not the cable.


I got a new network card from Sitecom (LN027, with a realtek RTL8169 chipset) and it has solved the network crashes and enabled me to use the Gigabit network interface. It worked out of the box in OS-X. So it seems the NIC on board the P5K-E is rubbish, or maybe broken? Anyways, I'm enjoying the GBit experience now (55MB/s).

Link to comment
Share on other sites

  • 5 months later...

I am getting the same problem. I installed Kalyway 10.5.1 onto a Dell GX270 2.8ghz with 2GB (4x512mb) of RAM. When I turn on the machine I can access my network shared folders. It works for about 5 minutes (or maybe less) then the network becomes invisible, although the internet still works perfectly.


The Shared folders are hosted on Windows machines, and they are still visible on other windows machines even after they disappear from the Hackintosh machine.


Also, I tried copying a large file (600MB) from the windows share onto the Hackintosh and it got cut off right in the middle of the file transfer. That leads me to beilieve that the disappearance of the Windows shaded folders has nothing to do with network inactivity.


So is this just an incompatibility issue with OSX and the built in NIC on the Dell motherboard or is it a different kind of software issue (driver, settings, etc.)? I'm a bit stumped...


Any Ideas?

Link to comment
Share on other sites

  • 9 months later...
That strange network behavior is due the RAM size.


If you use more than 2G of RAM, the Onboard Network will lose the connection.


I resolved it removing two of the four memory modules.



I'm seeing this error with networking and have 4gb ram. I'm reluctant to remove memory, is there another way?



Link to comment
Share on other sites


  • Create New...