Jump to content

got to installer, but having lots of issues


thesuffering
 Share

7 posts in this topic

Recommended Posts

okay, so i finally got past "still waiting for root device" by plugging the optical drive on the same ide cable as my hd.

the installer seemed to install os x fine, and when it got to 100% it reset and now it just stops at a black screen with a flashing _. what do i do now? im about ready to pull my hair out

 

also i tried the installer again, and it says I cannot install Mac OS X on this volume. A newer version of Mac OS X is installed.

Link to comment
Share on other sites

You need to set the drive up as primary and give it a boot loader.

Follow these instructions. Boot dvd. Open a terminal window from the utilities menu. Type diskutil list and right down the numbers next to your tiger volume. Use the first number when you see X in these instructions. And the second when u see Y.

 

fdisk -e /dev/rdiskX

 

update

 

f Y

 

“Partition 2 marked active”

 

w

 

Device could not be accessed exclusively.

 

A reboot will be needed for changes to take effect. OK? [n]y (as in yes not your Y number)

 

Writing MBR at offset 0.

 

q

 

then reboot. If that doesnt work then we will require more tinkering.

Link to comment
Share on other sites

im not sure i did it right:

after diskutil list it says:

 

/dev/disk0

#: type name size indentifier

0: GUID_partition sceme *55.9GB disk0

1: EFI 200MB disk0s1

2:Apple HFS Untitled 55.6 GB disk0s2

 

/dev/disk1

#: type name size identifier

0:Apple_Partition_scheme 3.8GB disk1

1:Apple_partition_map 31.5KB disk1s1

2:Apple_HFS Mac_OS_X_Install Disc 3.8GB disk1s3

 

nothing is under disk 3 or 4

 

so anyway, for X i used 0, and for Y i used 1.

everything looked as you typed it except

“Partition 2 marked active”

it said Partition 1 marked active

 

reset, same _ underscore issue...

Link to comment
Share on other sites

ive read in other threads that the partitioning scheme should be Master Boot Record (not GUID), and it says if i go to disk utility>partition and select the appropriate partition there should be an "option" where i can change this. This button is magically missing ;) could this be causing the issue?

my partitioning scheme says GUID

Link to comment
Share on other sites

 Share

×
×
  • Create New...