Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


portforwarding in vmware fusion

5 posts in this topic

Recommended Posts

hey everybody,

just got my kalyway hackintosh to work smoothly and installed vmware fusion, just for my favourite windows application "soulseek" , cause i think all the osx versions are {censored}.

the problem is, soulseek only works properly with the right router settings.

can anyone give me any advice how to do that cause the windows installation is not shown in the router nat settings!?


thanks for any reply


Share this post

Link to post
Share on other sites

I'm not sure about your setup, I'm using Workstation 6 on XP with Vista & Ubuntu installed as VM's.


Instead of using Bridged, I actually assign the VM's their own IP addresses working on the main "192.168.1 . . ."


That way they are seen as separate machines with separate IP's on the same domain.


Then I forward ports just like any other computer.

Share this post

Link to post
Share on other sites


i just installed soulseek ns on my macbook using vmware 2.0 and xp... however no matter what i cannot open the slsk port... tried the network adapter bridged setting but then the internet connection is lost... in NAT setting, even after following the portforward site steps nothing works... any help please? :-)

thanks in advance

Share this post

Link to post
Share on other sites

This may help,

I'm running VMware Fusion 3.2.? under SL 10.6.7 ([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]).


I had initial trouble getting portforwarding for DC++ (file sharing) but have it working now.


I didn't persevere with NAT mode in the XP VM for long. I had tried NAT with my normal XP LAN IP address but i didn't get net access.


Setting the VMware network settings to bridged did the trick. My virtual XP now has the same manually configured IP it had when it booted natively. So my router now forwards to my XP VM as if it was on its old non-VM IP. You just have to click no the the XP warning about two network adapters configured for the same IP.


I'm about to reboot my XP machine natively and see if it works and needs reactivation etc.


BTW....VMware (or perhaps my shakey eSATA external RAID 1 drive) seemed to corrupt a file system on a data drive and a registry on a diff XP native boot i tried to get booting as a VM...so GHOST LIKE CRAZY...glad i did.


All seems good now though...now to boot up my old Logic 5.5 XP install as a VM and start migrating to Logic 9 under SL...gonna take weeks to configure VSTi's and plugins for the old projects i reckon.


Hope this helps.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.