Jump to content

VMWare existing XP partition with GRUB on its own partition

7 posts in this topic

Recommended Posts

My situation isn't quite the same as those in other guides, so I figured it'd be best to ask before I destroy everything.



1) XP (NTFS)

2) Boot (ext3)

3) Leopard (HFS+)


GRUB is installed to the MBR and and its configuration files reside on Partition 2, which is also the partition marked active.


I want to boot the first partition in VMWare Fusion without messing anything else up, either by screwing up my MBR, or accidently VMWare-ing into Leopard... etc.


In the guide located in this forum, it suggests temporarily marking the XP partition as active and setting up VMWare, and then reflagging Leopard's partition, and that's not quite what I've got going (it also says only to use the guide if Leopard is the active partition to begin with).


Am I being overcautious? Is there a better way to do this? Does anyone know what's going to happen? Should I just shut up and find out?


The weirdest part is, when I first opened VMWare Fusion there was already a Boot Camp option there, but it goes right to a GRUB Error 17, so that's not going to pan out.


Thanks for the help!

Link to comment
Share on other sites



with two partitions, copying the chain0 to the XP root worked best for me and there is nothing more easy than booting with this method.


Anyway, just make sure you have a bootable disk with some partitiontools on there. Take some fame and easy progs like partitionmagic, or ontrack etc. Setting a partition active or inactive is no big deal and if you don't mess around with other things then your data will not be touched. It is just like hiding or unhiding a file, nothing more - except you do it with the HD. I would give it a try.


With VMWare, just let it boot up your partition from within Lopard and accept the changes, it won't mess up anything MBR or such.


btw. nice eraserhead and fungi nickname :(

Link to comment
Share on other sites

When I try to mark my XP partition as active, it says:

"Device could not be accessed exclusively.

A reboot will be needed for changes to take effect. OK? [n]"


Of course I say no, because if the change is made and I restart, I won't boot back into Leopard.


This happens even after ejecting the drive in Leopard.




But if GRUB works natively, why doesn't it work in VMWare.... OHHH is it because VMWare can't access the configuration files?? Can I tell VMWare to look at both partitions?


An Eraserhead fan, eh.... not everyday I find one :hysterical:

Link to comment
Share on other sites

If you installed GRUB in to the MBR this wont work with Fusion becausee fusion can only access Partitions not whole disks, Only VMware on Windows and Linux can access whole Physical Disks.


Also you can create VMDK files to acces your physical partitions with a VMware tool, read the other threads that talk about this.

Link to comment
Share on other sites

GAAAH! Foiled.


So I guess my question is, why is GRUB trying to boot in VMWare Fusion? If it's pointed at my XP partition only, and it's accessing GRUB... doesn't that mean it sort of is accessing the MBR?


Is there a way I can make this work without changing the GRUB install? Like, put something on the XP partition to ignore GRUB and just boot?


I just feel like Error 17 means it is accessing the MBR, but it can't find the config files on the second partition because it's not part of the VMWare "image".


I guess I could reinstall GRUB to have its config files on the XP partition?


I am a bit worried that if I use the same bootloader natively and in VMWare that I'll eventually accidentally boot Leopard in Fusion - catastrophic?

Link to comment
Share on other sites

  • 2 weeks later...

I had the same problem before, and now I kind of fixed it. I am quadruple booting Vista, OSX, XP, and Ubuntu (in that order).


I edited the vmdk file to include all partitions so VMware will load all partitions under OS X (of course, not the OS X partition itself). Error 17 means that it can't access your linux partition for Grub to load properly


The only thing right now is XP thinks it's a differen't computer so it won't boot up. (stop error 0x0000007B)... but Vista boots fine. Shame... XP was the one I wanted to boot...


I'll drop by later with a guide or something... a little bit busy ATM



Link to comment
Share on other sites


  • Create New...