Jump to content

Help Please On ATI card


8 posts in this topic

Recommended Posts

Hi to all,


well i got a new rig its an intel 945G chip well every thing worked great then i got this cheap Sapphire card well ur right its Sapphire Radeon x1050 128MB w/ hypermem... i plugged in the card made a freshly formatted install on my hdd tried to install the drivers then after the installation is done my monitor just switched off saying "No Input Signal" so i reinstall OSX Leopard again with out the drivers it worked fine but QE is not supported pls help me i tried all the drivers i saw in this forum but no luck i googled it still no luck i even tried it on tiger 10.4.8 Jas still same prob.. thanks for the help in advanced


My System Specs:


Processor Intel P4 SSe2/SSe3 Supported 3.2gHz <-- working in all OSX i tried

Motherboard: Generic Intel 945G(the one with no box that is only wraped inside antistatic bag"

HDD: Seagate 300GB(IDE)

External HDD: Maxtor 1TB

Graphics Card: Sapphire Radeon x1050(ATI)


Device ID is: 5657 Tried with osx tiger 10.4.8 Jas and osx leopard Kalyway 10.5.1 no luck its like somtimes monitor switches off or i get a kernel panic



Ok i think no ones helping coz i did not said it clearer


My Card Specs is:

Sapphire Radeon x1050(ATI)

Device ID: 5657

On Windows Driver is: x550/x700 Ser...


Link to comment
Share on other sites

I have a similar problem, after the drivers for my ATI X 1600XT are loaded the primary output of the videocard stops working, so i have to change it to secondary output. Try it. The only problem is that the display is not being detected wich is a wide screen, so of all the resolutions i get there is no 16:10 one. Does anyone have a clue how to put a "wide" resolution in there, or make both outputs to work.


I didn't have this problem on JaS Tiger 10.4.8 until i've added another gigabyte of RAM (it's 2GB now) and the same thing happend there. Help pls :(

Link to comment
Share on other sites

try switchresX. With it you can set ANY custom resolution if you have some kind of resolution change available.

It made my life easier in tiger.

I have similar problems with my gfx card in leopard, but I never considered switching to other port.

Will have to try.

Link to comment
Share on other sites

MacJordan thanks it worked i was about to buy a new card then i tried the 2nd it worked, and Crawley thanks for the SW advice im going to try it later coz my screen looked like {censored} with this dell wide screen anyway i got this 2nd hand so myt as well use an sw than get a new 1


thank you everyone 4 helping me ;)

Link to comment
Share on other sites

well im not using the full program i just used the control panel of switchresX ;) but the thing is after a while my card does not work with osx86 again :D so i removed it and just used the built-in 950gma and planing to get an nvidia card soon, but while i was searching on the net i found 1 program that says it can enable QE & custom resolution and supports a wide range of cards but i forgot the name of the program i think its like totalcontrol or somthing similar name, well ill try to look for it and try it and give the news

Link to comment
Share on other sites

  • 4 weeks later...

i have HIS radeon x1050 too..

i use patch from egwan (indonesia) use x550 driver..

when i'm restarting my pc..

the screen only show black desktop with a cursor of mouse..

my mouse works, but no display at all... just black..with cursor


maybe i should change to primary..DVI Connection

now i use secondary... hmm

Link to comment
Share on other sites


  • Create New...