Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Roman2K

Strange wifi speed (and ping) on an Intel-powered iMac

4 posts in this topic

Recommended Posts

Hello,

 

I have a problem with the wifi connection of my iMac Intel Core Duo 17" which is one week old.

 

When I booted for the first time, my WPA-encrypted wifi network was successfully detected and I was asked to enter the key. All went well.

 

But I noticed and notice a strange thing: the downloading speed varies from a high speed to a very low speed (near 0 KB/s) and vice-versa all the time. Moreover, web pages take more time to load than from another computer on the same network; and while pinging a machine on the same network the latency varies from 0 or 1 ms to ~250 ms.

 

All other computers on the same network, wired or not have a 1 ms latency with other computers and download constantly at around 4 or 5 MB/s on the LAN, and at around 600 KB/s on the 'net. Compared to this normal behaviour, my iMac downloads at an average speed of 200 KB/s on the LAN or on the 'net, and pings other machines with an average latency of 100 ms

 

post-20897-1138381055_thumb.jpg

 

Look at the screenshot attached to this post. At the bottom of the "Moniteur d'activité" window, you can see a graph showing the varying speed (green line); and in the "Terminal" window you can see low-to-high latency ping to a networked computer.

 

I suspected a MTU problem but changing it did not change the download speed nor the ping latency.

 

I would be glad yo hear some of you who had the same problem and found a way to solve it, or it you have any idea...

Would the next Mac OS X update 10.4.5 do something good to the Airport wifi connection ?

 

Thank you.

Share this post


Link to post
Share on other sites

I have the same problem with 14e4,4320 (pcmcia version) airport compatible (it's the same actually) on 8f1111a. Maybe the broadcom chip sucks or the Apple drivers suck.

 

be careful, maybe also can depend on AP brand. worked ok with linksys wrt54g (broadcom based) but not ok with asus wl500g (dunno what card it has, maybe broadcom too)

Share this post


Link to post
Share on other sites

I called Apple support and they are aware of the problem but according to what the tech said me, they have not found the solution yet or haven't finished to repair it. It should be fixed soon in Mac OS X 10.4.5 or separately in a downloadable update file.

Share this post


Link to post
Share on other sites

This is not just an issue with Intel-powered macs.

We have the same issue with an powerbook 15".

As soon as it connects to the network and starts trying to use the network (streaming video/copying files) it breaks the network.

Other machines get pingtimes between 1ms-1500ms, same on the powerbook.

This is not something that is a problem when the machine is just used to do moderate surfing, or when the machine is not there.

So expect an update for the airport issues, sound issues & video issues soon hopefully...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • My rig is not booting without the "XCPM bootstrap patch" and "xcpm_program_msrs (c) Pike R. Alpha" patch. Already tested that.  Booting without the TSCAdjustReset.kex is working great and booth sleep and wake is working. The new bios 0603 has an updated microcode and that might be the reason  for the fact that everything is working as it should without the kext.
    • Hello folks,   I may be a privileged user since i own a real mac aka a MBPro 15" mid 2012 runing fine HS... So i wanted to try a personal tip: I hooked my Sandisk 100 GB USB SSD to the real Mac and performed a clean install of High Sierra on it. Then i installed the latest CLOVER on this USB disk and copied the Urashimataro previously provided EFI partition. Then i pluggued this USB to my Xiaomi laptop i5 and tried to boot from this USB SSD. INCREDIBLY BUT TRUE: YES it worked fine. ;-)) Of course i also removed the serials to put mine previously blessed on Sierra...   Happy to share this new tip that lets me boot again my Xiaomi laptop on MacOs, and proud for my own personal solution, since i couldn't retrieve here any workable solution and it drove me crazy and nuts...   Enjoy!
    • Venduto altrove potete chiudere
    • I share your folks pain. Every step forward seems to be two steps backwards in other areas. And at the same time it's soooo worth it with features most forum users are not fully aware of ... yet  Anyway, it would be nice if you could fix this:    Your previous content has been restored.   Not only cannot post as I keep seeing it; the 1st time I saw it also 'restored' (read: removed) something that took me 1 hour to put together. It was a post reply with a quote and image attachments in it. Btw using imgur for external images ain't working either.
    • Hello again @obus.  Hello, everyone. Perhaps, you should now try without any patches for the CPU...? (at your own risk) ... of course only with tsc sinc kext, if now you have an official BIOS v.0603


×