Jump to content

DELL x86 forum..


34 posts in this topic

Recommended Posts

Well i have 10.5.2 V3 but after booting from DVD i have initializing complete and then it hangs.... dunno whats wrong , i think to have the right DVD though.

Maybe it's because i have 4GB RAM installed? or because of my raid setup?


I also have 4GB Ram installed and as i said, with leo4allv3 my raid didn't get recognized either. That is why i installed it onto an external HDD. You might want to try redownload that leo4all iso.

Link to comment
Share on other sites

Latitude D620

Kalyway OS X 10.5.1 with MBR & Netkas Kernel

Boots only with 1 core active, showing 1.67 ghz Core2Solo in About This Mac

Sata works OOB

GMA 950 works fine with acceleration

Audio works with Taruga's Patch (in, out, internal mic)

Batterymeter with PowerManagament.bundle

Shutdown and Restart Ok


Not working

Wifi, Ethernet, 2nd processor core, sleep


Geekbench result : about 1500 points

Link to comment
Share on other sites

I also have Leo4Allv4 running on my XPS M1730.  It was a PAIN to get it to boot the DVD.  Lots of hangups right after the AOPIC ... line.  Basically I just kept rebooting the install DVD and eventually (up to 40+ reboots!!!) would get past it.  No ryhme or reason why it would fail or work.  I had no options (just pressed return key at the Darwin boot screen) on the install.  Persistance pays off I guess.  


For the installation I left everything as default (didn't select any options in custom in the installation screen).


I installed on my primary HD (57G partion, partition #3 on the disk).  I used Vista to resize and create partition and then used the installation (Disk Utility) to actually format the partition as HFS Journaled).  I also had a iATKOS V2.0 disk that booted to the Mac OS installer fine, but had problems after the installation (blank screen with flashing block).  I think there is a fix out there for this as well, but since it was reported that the Leo4AllV3 installation worked I wanted to use that installation.  I did use the iATKOS disk when I needed to change the active partion (see below) back to my Vista partition.


After the installation, when it reboots, I got an HFS+ partition error.  I fixed the problem by using a dual boot configuration and just had to reset my active partition back to my Vista partition (after the Mac install it makes the Mac partion active and I get the HFS+ error)


To reset the active boot partition I boot with the iATKOS disk with the -s option (single user mode).  You can do this with the Leo4All disk as well, but since it wants to hang you may have to keep rebooting to finally get it into the single user mode.


Once in the single user mode use the fdisk command to reset the active partition back to Vista.


at the prompt type:


fdisk -e /dev/rdisk0 (you may need to change the rdisk# to wherever you have vista).

p (to print out the partitions, the partition with the * will be the current active.  Determine the Vista partition you want to make active for the next command)

f 2 (my Vista partition is number 2, yours may be different depending on your setup)

w (writes the MBR back to disk)

q (quits the program).


type 'reboot' to reboot the computer rather than going to the Mac OS installer and remove the DVD from the drive.  You should now boot into Vista (or the Vista bootloader).


I used the windows (Vista) bootloader (search for dual booting Vista and Mac OS X) it actually boots fine when I select my Mac partition (to the darwin bootloader) from the Vista bootloader.


The base install with no customization boots my machine in 1024x768 mode.  Using files for getting the 8700 card to work then allows me to change the resolution to the full 1920x1200.


With the base install my DVD is not recognized when I am in Mac OS X.  I also don't have either the LAN or WI-FI. The bluetooth did work fine with my bluetooth headphones.  Use the prior posted instructions to get the laptop audio working (very simple to get working).


I then updated with the 10.5.3 update disk (also previously mentioned in another post).  Again, I didn't select any custom options with that upgrade.  Again the disk is a royal pain to get to boot but eventually will work (after many hangs & reboots).  After the upgrade is complete you once again have to set the active partition back to the Vista partition.


This time I got another error when it tried booting.  I found (searched on the web, sorry don't recall what the error was exactly) that the problem was with the AppleIntelCPUPowerManagement.kext in 10.5.3.  To remove it I booted into the iATKOS DVD to the Mac install screen and this time when into Utlities -> Terminal.  From the terminal window I did a


cd /Volumes/<my 10.5.3 Mac volume name>/System/Library/Extensions

cp -R AppleIntelCPUPowerManagement.kext AppleIntelCPUPowerManagement.kext.backup

rm -R AppleIntelCPUPowerManagement.kext



my 10.5.3 Mac Volume name is whatever you named your Mac partition when you created it.


Exit the terminal program and exit the installer (reboot the system) and take the DVD out of the drive as well.  That should allow you (hopefully) to now boot into Mac OS X 10.5.3 without any problems.  


10.5.3 recognized my DVD again but...I lost the use of my trackpad and keyboard.  If you have a USB keyboard you can plug it in and use that.  Again there are a couple of kext files that needed to be replaced (specifically the ApplePS2Controller.kext to make the keyboard/trackpad work).


I have attached most (missing the Latest 10.5.3 kexts, but you can get the link to them was posted earlier) all the files I needed to get things working on my M1730 under 10.5.3


Things that don't work (or don't work well)


Wi-Fi (3945 card) - Not working

LAN (Broadcom 57xx Gigabyte card) - Not working

Time Machine - Got it to recognize my external drive once and do a backup, now it won't see it for some reason.

Firewire - Haven't tested

Webcam - Haven't tested

Audio - (Output works, Mic doesn't seem to)


Good Luck




My system is as follows


T8300 CPU

320Gig SATA HD (no RAID)

Dual 8700

Dual Boot (off internal HD) Vista & Mac OS X 10.5.3



Well i have 10.5.2 V3 but after booting from DVD i have initializing complete and then it hangs.... dunno whats wrong , i think to have the right DVD though.

Maybe it's because i have 4GB RAM installed? or because of my raid setup?








Link to comment
Share on other sites

I found a solution to the DVD booting problem.  I had to physically remove 2G of my computers memory (I had 4G installed) and the disk now boots fine!!!  Oh what a relief!!!  BTW, You put the memory back into the system once you get it Mac OSX installed. The Mac sees 4Gig with no problems, it's just the install DVD that has problems apparently.


I also had all my USB devices (USB HD, USB mouse, etc) disconnected during the installation, I don't know if this is necessary or not (now that I figured out the root cause of the non-booting DVD). 


Also, I found out to get time machine to work I needed to install a network driver (iwi3945).  The network driver doesn't wotk but it does allow Time machine to.  I believe it has something to do with setting the UUID of the network or something of that sort.


I also discovered a couple things about time machine backups.  Apparently they don't back up the entire disk (removed the Darwin bootloader).  When I needed to recover my Mac partition, from me mucking up my settings, I found out I could restore the disk but it wouldn't boot (missing bootloader).  To recover fully I just booted into my Leo4All 10.5.3 disk and re-installed just the bootloader (unchecked everything else).  This brought my system back to a bootable condition. ( I had to reset the active partition back to Windows to get that to work, as usual). 



Link to comment
Share on other sites

  • 2 months later...



I'm french, I have a Dell XPS m1730 with dual 8700m GT and my question is for astrman.


Which video driver do you use for your dual 8700 ? Because my video cards doesn't work propely, I'm obliged to boot with "-x" mode.


PS : Kalyway 10.5.1

Link to comment
Share on other sites

  • 2 months later...

DELL Optiplx 745 & 755

both system needed to add "add-in" cards for display , lan, and sound since this 3 onboard chip dont have support nor drivers untill this momment "2008 Dec 04"


Cheers guys


p.s. I got some $cheaper then $10 US audio and lan card for this machine , and a GFX5200 works well

Link to comment
Share on other sites

Dell inspiron 530 (Vostro 200 aswell)


Used iAtkos 10.5.4i

all vanilla kexts installed to GPT disk

installed efiv9

extracted extra.zip to /

installed apple aciplatform 1.1.0, patched applehda and ioatafamily to /s/l/e

used efi studio to add GFX,hda and ethernet strings to boot.plist

used patched dsdt.aml

updated to 10.5.5



btw, instead of removing memory for people who are having problems, try booting the dvd with "maxmem"=2048



Link to comment
Share on other sites

  • 1 month later...

I have 2 dells that I am struggling to do retail installs on . I have a xps m140 and a xps 400 both seem to meet min specs from my research but I continually get ebios erros. i can not figure out how to stop them. It seems its mkext causing the error. But I do not understand how to change the boot 132 img file to remove or modify anything while I am still using windows xp. Anyone have any advice or suggestions?

Link to comment
Share on other sites


  • Create New...